Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Logitech Setpoint not working W7 X64


14 Feb 2009   #1

 
 
Logitech Setpoint not working W7 X64

Hi there,

I can't get Setpoint to install and without installing it my mouse some times laggs on a click. It's strange, sometimes it will work fine then all of the sudden, when I click something it 'sticks' for about 1-2 secs.

Any ideas? Thx

My System SpecsSystem Spec
.

15 Feb 2009   #2

Vista X64 ultimate/ 7 X64 Ultimate (7264)
 
 

Sorry i can't help, but it is a strange one as it installs fine on mine.. 7 7000 X64
My System SpecsSystem Spec
15 Feb 2009   #3

Windows 7 Build 7048 x64
 
 

There's an x64 Setpoint available.
Install that by running as admin, expect a notification saying it has known issues (can't remember the exact warning )
Unplug your device, wait for the windows notification sound
Plug back in and configure.

Am using setpoint x64 and it's working fine.

Let us know how it turns out for yah
My System SpecsSystem Spec
.


15 Feb 2009   #4

Windows 7 Ultimate x64
 
 

It works great on my x64 system, as well.
My System SpecsSystem Spec
15 Feb 2009   #5

 
 

Now you've got it fixed, you can improve it. Try using uberoptions to add a lot more customizability to your buttons:

uberOptions Wiki | Main / uberOptions

It's the only reason I keep using setpoint
My System SpecsSystem Spec
16 Feb 2009   #6

Dual boot XP Pro and Seven/7127
 
 

Quote   Quote: Originally Posted by QuadAllegory View Post
I installed 4.0 from the original disc then updated to 4.6, and then 4.7 and everything went fine.

It was the installing 4.7 from scratch that didn't work.

Thx guys!
Quote   Quote: Originally Posted by smarteyeball View Post
Now you've got it fixed, you can improve it. Try using uberoptions to add a lot more customizability to your buttons:

uberOptions Wiki | Main / uberOptions

It's the only reason I keep using setpoint
Thanks for your advice chaps.
I shall now go and try this on my x32 system.
My System SpecsSystem Spec
16 Feb 2009   #7

Windows 7 Build 7048 x64
 
 

Quote   Quote: Originally Posted by QuadAllegory View Post
I installed 4.0 from the original disc then updated to 4.6, and then 4.7 and everything went fine.

It was the installing 4.7 from scratch that didn't work.

Thx guys!
Glad it worked out for yah
My System SpecsSystem Spec
17 Feb 2009   #8

Windows 7 Build 7048 x64
 
 

I'm using a wireless mouse and I experience mouse lags once in awhile. Lag tends to happen when waking up, I believe it's related to the sudden activity demand on the processor which tends to over shadow some processes including the mouse. If it's persistent or if the lag continues to occur after a few minutes, it's something else.
My System SpecsSystem Spec
Reply

 Logitech Setpoint not working W7 X64




Thread Tools



Similar help and support threads for2: Logitech Setpoint not working W7 X64
Thread Forum
Latest Logitech SetPoint Software Drivers
Another Logitech Setpoint problem. Drivers
Logitech Setpoint 4.8 x64 - VC8 Library Drivers
Logitech EX 310, Windows 7 & Setpoint Hardware & Devices
Logitech Setpoint Drivers
Logitech SetPoint 4.60 (x86) Drivers
Logitech SetPoint installation Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 08:16 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33