Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Dlink DWA-547


01 Dec 2009   #1

Windows 7 RTM x64
 
 
Dlink DWA-547

This is the worst piece of crap ever...sorry for starting like this but Dlink is something i will never buy again...ever..

Their self service portal doesn't work with firefox since it's active x based....it didn't work in IE8 even with compatibility view turned on.

I had to actually boot up a virtual pc win xp with IE 6 to be able to write a support inquire and even then the select os menu didn't show windows 7.

When i finally finished writing my inquire and posted it didn't show up in the list of active support errands so f*ck it. I'm asking the pro's now...you guys.

I have Windows 7 x64 with all the latest updates and whatnot....i downloaded the latest driver for the wireless network card and installed it, when finished the installer said no adapter was found. in the device manager it says if i remember correct error 10 device cannot start...

i installed the driver available in windows update after this and i got no further. it seems like the card has Windows 7 support but to me it doesn't seem like it...what do you say? i did a reinstall of windows and i got the same problem despite my efforts.

My System SpecsSystem Spec
.

01 Dec 2009   #2

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by premier69 View Post
This is the worst piece of crap ever...sorry for starting like this but Dlink is something i will never buy again...ever..

Their self service portal doesn't work with firefox since it's active x based....it didn't work in IE8 even with compatibility view turned on.

I had to actually boot up a virtual pc win xp with IE 6 to be able to write a support inquire and even then the select os menu didn't show windows 7.

When i finally finished writing my inquire and posted it didn't show up in the list of active support errands so f*ck it. I'm asking the pro's now...you guys.

I have Windows 7 x64 with all the latest updates and whatnot....i downloaded the latest driver for the wireless network card and installed it, when finished the installer said no adapter was found. in the device manager it says if i remember correct error 10 device cannot start...

i installed the driver available in windows update after this and i got no further. it seems like the card has Windows 7 support but to me it doesn't seem like it...what do you say? i did a reinstall of windows and i got the same problem despite my efforts.

Hi and welcome

Some things come to mind. first, I assume you are using homegroup for networking. Homegroup sometimes causes random, drops, slowdowns, connectivity problems etc.

Is it a laptop? they often have key combo's to enable wifi. Sorry abt the basic question, but hey you never know.

Error 10 is a usb failure to connect. have you checked the USB devices in device manger to see if they are installed and working?

Hope this helps and let us know the results


Kenn J+
My System SpecsSystem Spec
01 Dec 2009   #3

Windows 7 RTM x64
 
 

hello thanks for taking the time to help.

this is weird since i am using a self built customized desktop computer and the network card in question is a pci and no, i am not using homegroup, i like the old fashioned way that way i have more control. in fact i disabled the homegroup services myself but despite this i can see the homegroup folder in explorer.
My System SpecsSystem Spec
.


05 Mar 2010   #4

7 x64
 
 
DWA-547 Solution

I had massive problems with DWA-547 and trying to connect to a Belkin wireless N router. I tried the standard Windows 7 (x64) driver, Atheros drivers (the chipset 547 uses), and the 8.0.0.162 driver from dlink.com.au but none of it was working.


Temporary fix
I then discovered that if I dropped the Belkin down to Wireless G only that I could connect, but these speeds weren't tops.


Solution
Get the 8.0.0.162 driver, change the router to wireless N and change the security type to WPA2. I also changed to dual channel and am now connected at 300Mbps. Windows 7 will report that settings have changed in the connect so you have to go into the properties and reenter the security information.
Tell me if this worked for you -skittles
My System SpecsSystem Spec
Reply

 Dlink DWA-547




Thread Tools



Similar help and support threads for2: Dlink DWA-547
Thread Forum
dlink ant24-0230 Network & Sharing
Dlink DIR-615 Router Network & Sharing
dlink DSM 320 Extender and WMP 12 Streaming Media Center
problems with dlink dir-600 Network & Sharing
dlink di 634 m. is it possible to change the mac add. Network & Sharing
Dlink USB problem Network & Sharing
Dlink dwl 520 + driver 32 bit :( Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:29 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33