Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Toshiba Satellite L300 notebook,s camera and modem problem in Windows 7

23 Feb 2009   #1
iqbalhuma

windows vista
 
 
Toshiba Satellite L300 notebook,s camera and modem problem in Windows 7

I upgraded windows Vista on my Toshiba satellite L300 (intel 45 express chipset,core 2 Duo 2GHz processor) with Windows 7. All drivers taken automatically. But when I started Webcam (chicony webcam) a message appeared: "Webcam driver open fail.Please restart Camera or Computer." Message persists after restaring repeatedly. Same with Modem, When I tried to connect internet on Dial up modem, message appeared "Dial tone not present." Actually Dial tone was present. Device manager is showing both devices as "Working Properly". Can any one suggest solution?


My System SpecsSystem Spec
.
23 Feb 2009   #2
NosferatuX

Windows 7 Build 7048 x64
 
 

Hi iqbalhuma and welcome to the forum!

Please go to Toshiba support web and download your drivers from them as there are vista drivers for your model.

Cheers
My System SpecsSystem Spec
26 Feb 2009   #3
iqbalhuma

windows vista
 
 

That is main problem.Please read problem again. Devices are working in VISTA. Problem starts when I UPGRADE VISTA to WINDOWS 7. Here Drivers are installed, But devices not function properly. Drivers were downloaded fron Toshiba's Support site.
My System SpecsSystem Spec
.

26 Feb 2009   #4
NosferatuX

Windows 7 Build 7048 x64
 
 

Quote   Quote: Originally Posted by iqbalhuma View Post
That is main problem.Please read problem again. Devices are working in VISTA. Problem starts when I UPGRADE VISTA to WINDOWS 7. Here Drivers are installed, But devices not function properly. Drivers were downloaded fron Toshiba's Support site.
Seeing as this is still in its beta stage, somehow the upgrade path messes things up and if you've noticed, though they've made a lot of effort to accommodate old drivers better than vista, to really see what windows 7 has to offer, you'd have to have the right drivers installed.

In your case, though the drivers are showing that they're installed, I'd strongly suggest, re-installing the drivers. I'd try the manually update driver path to make sure that your current drivers are replaced by the ones you're trying to put it.

Let us know how it goes
My System SpecsSystem Spec
27 Feb 2009   #5
iqbalhuma

windows vista
 
 

I installed again manually on your suggestion. But problem is there. Message is " webcame driver open fail."
My System SpecsSystem Spec
27 Feb 2009   #6
limneos

Windows 7 RC 7100 32bit/64bit
 
 

Have you tried Windows Update to see if it gets any drivers for your devices?

The drivers provided by Windows Update in Windows 7 (if found) are usually the most compatible...
My System SpecsSystem Spec
27 Feb 2009   #7
NosferatuX

Windows 7 Build 7048 x64
 
 

Quote   Quote: Originally Posted by iqbalhuma View Post
I installed again manually on your suggestion. But problem is there. Message is " webcame driver open fail."
Very interesting...You shouldn't really have any issue with your device as vista drivers for it are readily available.

Just an afterthought, please try - Windows 7 Driver Solution, just might do the trick
My System SpecsSystem Spec
31 May 2009   #8
jacqueskleyn

windows vista
 
 
win 7

Hi

I have a Toshiba L300 and it has win vista on it when i tried to install win 7 it installs and everything, but when it wants win to start for the first time it restarts rhe whole time!!!

I have tried everything it wont work, this isnt the beta version its the new premium version that i have, how did you get the win 7 to work on your L300?

Please help !!!!!!!!!
My System SpecsSystem Spec
08 Nov 2009   #9
Happy

Windows 7, Vista Home premium, XP
 
 

Hi Iqbal, Could you finally solve your "Webcam driver open fail.Please restart Camera or Computer" problem? I'm facing the same problem and can't find any fruitful solution yet. Please reply.
My System SpecsSystem Spec
17 Nov 2009   #10
barts96

windows7
 
 

i got same issue with web cam ?web-cam driver open fail."
i am running 64bit windows 7
just wondered if no update out for the 64 bit version??
any update ?
My System SpecsSystem Spec
Reply

 Toshiba Satellite L300 notebook,s camera and modem problem in Windows 7




Thread Tools





Similar help and support threads
Thread Forum
Toshiba Satellite Reformat Problem
http://www.freeimagehosting.net/t/d3qe4.jpg So I went to reformat a Toshiba Satellite today and had this issue with the network adapter... it shows up that like this I could be doing it wrong but any drivers I tried from the Toshiba driver page to fix this problem did not work and I can seem...
Drivers
toshiba satellite 300 series on/off problem
I turn on my laptop, it boots completely up to icon screen last 20 seconds on then laptop turns off, what can it be ?
General Discussion
Toshiba Satellite L500 PROBLEM!
I just want to ask regarding the error message of my laptop that appears every time i will open it. StartRep.exe-Application Error The instruction of 0xfc66584d referenced memory at 0x00000008 the memory could not be read. Do i need to reformat it or should i buy a new memory, but i wonder...
Installation & Setup
Toshiba L300-155 BSOD
Hi, I have 3 Toshiba L300-155 Laptops and they have Blue screen problems. Only one is particularly bad with this. The specs are: Intel Celeron 560 single core 2.13Ghz CPU 2GB DDR2 Ram 120GB Sata Hard drive
Hardware & Devices
Problem with windows 7 for toshiba L300 s502
Hi recently i bought Toshiba L300 s502 with xp windows.now i want to use windows 7 on my laptop.after installing windows 7 i found that every driver is ok but my web cam is not working.on the device manager my web cam driver also show ok. Now i am in great trouble finding drivers for my laptop for...
Drivers
Chicony web camera doesn't work on toshiba satellite a3
Hi, The chicony web camera doesn't work on my toshiba satellite a350-12d and windows 7 64 bit.. I always get different errors like "graph render fail" "the device is locked by another program" etc.. I tried many things and look on a lot of posts but nothing works. I have installed...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:19.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App