Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB device not recognized - Help!

09 Jan 2010   #31

windows 7 pro
usb device not recognized....over and over

It seems like there's some differences in the usb problems talked about here. Here's mine:
All of my usb ports work. Yet I get these "USB Device Not Recognized..." notifications at random times (the sound effect is french horns atm, better than the banjo!!). Some days I don't get any pop ups. Most days I get about 20-30 notifications per hour! If I click the "x" the pop up comes right back. If I click the pop up, they show the "unknown device" to be fixed. All avenues for fixes are dead ends so far. I tried unplugging from the wall, clearing cmos, uninstalling devices, following Windows 7 fixes...i even checked the "do not show me usb errors" in the usb port properties advanced tab! And they still pop up! I think next I'll look into that itunes fix idea from a previous post, other than that, I'm at a loss.

My System SpecsSystem Spec
10 Jan 2010   #32

Windows 7 Home Edition
USB device not recognized...

Ok so bear with me. I got a Dell Inspiron for Christmas with Windows 7 home edition installed on it. I use a logitech Thumb track ball and a Targus cooling pad that are obviously USB devices.. about once a day, I get the "usb device not recognized" and the mouse stops working, though the cooling pad still receives power and the fan keeps running. I wind up unplugging my computer and removing the battery and letting it sit for about a minute and it fixes the issue, however that gets really irritating when I'm doing my coursework and have to shut down. Never mind the fact that it's happening daily when these items worked fine on XP on my old laptop. So are there any fixes for it so you don't have to constantly be taking out the battery, unplugging it?

My System SpecsSystem Spec
10 Jan 2010   #33

Windows 7 Ultimate
USB device not recognized

@ Jasonmellow: where do these errors originate? Do you use an external USB hub? If so, disconnect it from your system (if possible), and check whether the errors remain. If they are gone, it may well be your USB hub that is faulty.

@dragonblade81: I had a similar problem earlier, and I found out (in the end) it was caused by the fact that I had a faulty appointment in my agenda in 1999, which outlook tried to synchronise with my smartphone, which used -yes- and USB-port. I went through the tedious work of checking all my agenda's from 1999 onwards, and it solved the problem.
My System SpecsSystem Spec

11 Jan 2010   #34

Windows 7 Home Edition

@Swier: I wish it were that simple. I don't use outlook whatsoever, nor do I have a smart phone. Thanks for the idea though. Any other possibilities?
My System SpecsSystem Spec
01 Feb 2010   #35

Windows7 Ultimate
Same problem in Windows7 Ultimate

I had the same problem with USB not recognized.

I run a Windows7 Ultimate OS on a Dell Inspiron, Intel Moterboard, Core2Duo CPU and 4Gb RAM.

From what I've seen the problem occurs most often when I plug in my iPhone 3Gs or my HTC Diamond.

I tried to update: Bios, USB driver and Motherboard driver. NO result! After that I applied the "unplug the battery" and it works.

What I want to underline is the fact that before last "critical" update of Win7 I haven't met this problem.

However thanks guys for your advice. It really helped!
My System SpecsSystem Spec
07 Apr 2010   #36

Windows 7 64 bit

Why does microsoft not fully test these issues. I'm having the same issue, worked fine one day and the next it did not. My external hard drive, usb wireless adaptor and usb hub no longer works. It's a shame too, I've only had this computer 3 months and I hate windows.
My System SpecsSystem Spec
13 Apr 2010   #37

windows 7

Just been there, just had that happen, just done that.

Tks to this forum, using a combination of some of the suggestions above, resolved the problem of all/any USB devices suddenly not being recognised in all/any of the USB ports.

Unplugged all USB devices
Turned computer off
Removed battery (and left it out)
Restarted laptop using power connection only
System restore back to point before last update(s) were applied
Turned computer off (NOT just restart)
Turned computer on.
Plugged in USB devices, 1 by 1 ..... all OK
Removed USB devices
Turned computer off
Replaced battery
Turn computer on
Plugged in USB devices 1 by 1 ..... all OK
Re-ran updates
Restarted computer ..... all USB devices still OK
My System SpecsSystem Spec
05 May 2010   #38

Code 43

I am experieincing the same problem. However, Windows 7 tells me that my Tom Tom is unrecognizable and that it can't find the driver. but when I ask the system to check my drivers it tells me that I have all of the current drivers. I noticed that the error started not too long after I got an automatic update from MS a few weeks ago. Did MS do something that upset the OS?
My System SpecsSystem Spec
13 May 2010   #39

Windows 7 64 bit
USB Port

OK, I finally fixed my issue with the USB ports not recognized, here is what I did:
*Unplugged all USB devices
*went to Device manager in windows 7
*uninstalled EACH Root Hub USB driver
*Powered off my computer/unplug
*Powered back on
*Reconnected each USB device
*They all Loaded sucessfully.

I hope this helps.
My System SpecsSystem Spec
17 May 2010   #40


I am amazed at the number of postings regarding this, but I am even more amazed that Microsoft has not come up with a solution. Short of pulling out my hair don't know what the heck to do. I'm thinking of installing my TomTom GPS software ( the only product/USB that my PC does not now recognize but fear that I will screw up my wife's PC. MS, if you're reading these posts, please let us know if your rae taking any steps to figure out what happened and it if can be fixed. It is bad enough that you are not supporting Flight Simulator - which I have been purchasing since the first edition - but now with this problem I wonder if you are dropping support for home customers.
My System SpecsSystem Spec

 USB device not recognized - Help!

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
USB Device not recognized
Hello :) If I opened the topic in wrong section, please sorry... Sorry if bad english. Please read the whole text so you could fully understand what is the point :) Here is my problem. Every Mass Storage device I put in the USB slots, came with the message USB not recognized... It...
Hardware & Devices
USB device not recognized - but there is no usb device connected
It's recognized in device manager as "Unknown device". But I've not connected anything to pc. Also all of my usb ports are working at 1.1 speed. When I try to connect any device, I get the message "that it could work faster, if i connect it to hi-speed usb port". Any suggestions?
Hardware & Devices
USB device not recognized will NOT go away
This is getting irritating enough I am tempted to go back to XP. Every time I plug in a USB device to charge it, for example my GoPro helmet cam, or just have an empty USB cable plugged in to one of the PC's ports and leave it on my desk so its ready to plug something else - I get that...
Hardware & Devices
USB Device Not Recognized
OK Here's my problem. I get a "USB Device Not Recognized" error when I plug my camera into the front USB port of my computer. It works fine when I plug it into the back USB port. Because of the position of my PC, it is a royal pain to get to the back side of the PC, so I really want to be able...
USB Device Not Recognized
Hi guys!! I've been meaning to ask some help regarding the issue that I am having however I was reluctant because of the fact that I fix computers for a living(I'm not that good at it though..:(). I need help!! I've been getting "USB device not recognized". I got the issue after...
Hardware & Devices
USB device not recognized!!! PLZ HELP
i have a hp pavillion dv8301nr windows 7 (64bit) 7600 rtm, allthou this happens in every version, i have a amd turion 64 ml-34 processor, and phenix f.54 (latest) bios, and i can only suspect i have the latest chipset drivers, i installed them from hp site, if someone knows a place where i can get...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:12.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App