Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Unrecognized devices after Win7 install

10 Dec 2009   #1
Mayzie

Vista
 
 
Unrecognized devices after Win7 install

I did a clean install of Win7 and everything worked fine afterwards except my touchpad - it worked but didn't support scrolling, etc.

I checked the Device Manager and noticed there were a number of unrecognized devices. At that time, there were three Base System Devices and two Unknown Devices. And under Mice and Pointing Devices, only a standard PS2 mouse was listed - no touchpad. (Same in Control Panel.)

I installed the Synaptics driver and the touchpad showed up under Mice and Pointing Devices. Now I have scrolling etc, and the Synaptics touchpad now shows up under Mouse in the control panel. So the touchpad problem is fixed - and now there is only one Unknown Device in the Device Manager.

But I have no idea what to do with these other devices or how to figure out what they are - see screencaps. If I click on Update Driver, I just get a message back saying Windows is unable to install the device.

Any ideas? Or do I just wait and see what other devices fail to work?




Attached Thumbnails
-device-manager.jpg  
Attached Images
 
My System SpecsSystem Spec
.
10 Dec 2009   #2
sygnus21

Windows 10 Pro
 
 

Is this a laptop? If so you may need to contact the manufacture to find out what those items are. You'll ned to explain to them what version of the operating system you installed 32 or 64-bit. It would help us here as well

You can also check the driver disk (if you have one). Throw it in the CD ROM and let windows "try" to find the driver. You could help this along by pointing windows to the "Driver" folder...if it's one on the disk.

I myself am unable to say what those items are.

Good luck
My System SpecsSystem Spec
10 Dec 2009   #3
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Hi

Try downloading all up to date drivers from Toshiba:

Satellite A500-15M - Product Specifications - Toshiba
My System SpecsSystem Spec
.

10 Dec 2009   #4
TimStitt

Windows 7 Ultimate 64 bit
 
 

Device manager will also allow you get the hardware and vendor codes which you can then put in an online Vendor Code database to see who/what it is?

1. Open Device manager
2. Right click on the device and choose properties
3. Click on the details tab
4. In the Property drop down, select Manufacturer (although this can be generic, sometimes this answers your question immediately)
5. If you need more info, in the property drop down select 'Hardware ID's' (you'll see something like PCI\VEN_168C&DEV_0023etcetc)
6. Go to this website PCI Vendor and Device Lists
7. The Device number is the one after DEV_ (in my example 0023), put this in the field on the web page and hopefully it's in their database.

Good luck
My System SpecsSystem Spec
16 Dec 2009   #5
Mayzie

Vista
 
 

Thanks to everyone for the help. As suggested, installing all the drivers from Toshiba's Win7 support page did the trick. I should have tried that before asking!
My System SpecsSystem Spec
Reply

 Unrecognized devices after Win7 install




Thread Tools





Similar help and support threads
Thread Forum
NEW DELL WIN7 OS, but I have old hardware devices!!!!!
Would someone please help me on this. I built my own puter about six years ago, after wiping and formatting the older 32 BIT WINXP O.S. and installed a OEM version of WIN 7 PRO 64. I then had to search out 64 Bit drivers for my older Epson all-in-one NX300, (printer,scanner) Realtek Audio, CS5,...
Drivers
Media devices can be seen from Win7 x86 but I cant from Win7 x64
Hi, To give you a brief description of my Home network setup: 1. I have a MSI Wind laptop running Win7 Ultimate x86 2. I have a HP DM1 laptop running Win7 Ultimate x64 3. A 3G Tenda router 4. A DLink DNS-320 NAS So the other day I got myself a DLink DNS-320 from a local computer store...
Network & Sharing
no longer see non win7 pcs, devices
I suspect due to a bunch of win7 patches, I can no longer see XP or Mac pc's on my home network, nor can I see the memory card of a Canon Pixma printer/scanner. In file manager (win explorer), if I click the Network icon of the left panel, I will see the Canon printer listed under Multifunction...
Network & Sharing
Can Win7 power down USB devices not in use?
Hi All Either I made this all up in my mind and am imagining things or I did hear from some where that Win 7 is able to power down and shut off USB devices (for example my 1tb external) automatically when not in use for a certain period of time. Just wondering if this is true and if there is...
Hardware & Devices
Devices not well configured !! help... (using hp/win7)
i hope i am in the write forum(plz direct me if i'm in the wrong one...)... ! i have a "HP pavilion" HP pavilion dv2913cl ( this is wat it said on the bottom, however on the screen i have dv2000 ! its refurbished ) so the laptop originally had windows vista 64bit, but i installed WINDOWS 7...
Hardware & Devices
Connecting non-Win7 devices to homegroup
Most of the PC's in my house are on Windows 7 and they all connect with each other without any problems. I have not been able to get my laptop (WinXP Pro) or Netbook (Ubuntu 9.10) to connect to the Homegroup. I also have a Networked Attached Storage device but this seems to be invisible to Windows...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:41.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App