Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: CD/DVD Drive mounted to Drive E: and F:

13 Dec 2009   #1
abelM

Window 7
 
 
CD/DVD Drive mounted to Drive E: and F:

I recently upgrade from Vista to window 7 and found a minor problem.

Under my computer the CD driver is mounted as E:

When I inserted CD/DVD in CD-ROM it opened as F:

Obviously I have tried to rename Drive F: to drive E: under computer Management. However, there is no Drive E: under Computer management. Only drive F:, When, I was tried to rename drive F: it didn't allow me to change to E: because it has already taken.

I have also openned regedit and looked under devices to change there. There is no Drive E: only Drive F: I changed and reboot the system and nothing happen. i.e not changed to E:

Is there any way I can Delete the E: drive under my computer so that I can change Drive F: to E: ?

Thanks


My System SpecsSystem Spec
.
13 Dec 2009   #2
Zidane24

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64
 
 

Did you install any mounting software under Vista before the upgrade (ex. Alcohol, MagicDisc, PowerISO, etc.)
My System SpecsSystem Spec
13 Dec 2009   #3
abelM

Window 7
 
 

I did installed UltraISO if it is similar to the software listed. The weird thing. Drive E: shown under my computer only. I can't able to find where it associated. It Labelled as CD/DVD drive. However, under device manager, CD/DVD driver labelled as F:

The F: driver is shown under my computer only when I inserted the CD into CDROM. CD/ROM is working as driver F. I want to remove the invalid E: driver and change F to E

Thanks for your valued help......
My System SpecsSystem Spec
.

Reply

 CD/DVD Drive mounted to Drive E: and F:




Thread Tools




Similar help and support threads
Thread Forum
Windows 7 has swapped my drive paths with my boot drive and sec. drive
I have just finished a pc build with a SSD to be used as the boot/OS drive and a secondary 2 HDD setup in raid 0 for storage. First I started with the SSD only and installed win7, applied all the updates etc. At this point the system has rebooted at least half a dozen times with no issue. ...
Installation & Setup
Format & Partition New Drive to Use as a Backup Drive or Storage Drive
I want to prepare a factory fresh drive so that I can use it to save backup images. Soon I will have a second drive that will only be used to store data files. Neither drive will ever be used for the installation of an operating system. From what I've read, I see no advantage to having more than a...
Hardware & Devices
Have lost permission for access to mounted drive
Hi I have lost the ability to access a mounted drive. Previously, I would mount the drive and it would immediately open, saying it was Q: shared drive...). I have never had a problem before. The drive is from a True crypt encrypted file - I can mount the drive by entering the password to True...
Network & Sharing
Can only shut down when DVD drive is mounted or in failsafe mode
I have recently purchased an SSD drive (SANDISK Extreme, works like a charm) and along with that a second hdd drive caddy for my old hdd instead of my DVD drive. My laptop is an ASUS K53sv with i7 2630QM Processor ASUS - Notebooks- ASUS K53SV Both SSD and old hdd in drive caddy works...
General Discussion
Portable hard Drive - not automatically mounted and visable
I have two Identical hard drives . Both have been in use since I built computer Dec10. Now I plug them in and their not visable anymore? Their shown as a usb or scsi drive but no assigned drive letter or their "name". Their showing in the Disk manager and I found I had to manually tell it to...
Hardware & Devices
W7 Loses Mounted Drive at Reboot
I just switched one box from Vista to W7. I mount a network drive, I use it, I reboot, the mount is gone..... WHY? I have been using this drive for many months on Vista, NO problem.:sarc: ps: I set the mount in Windows 7 the same as I did in Vista, including checking the RECONNECT AT LOGON...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:05.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App