Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Problem installing VIA drivers

22 Dec 2009   #1

Windows 7
 
 
Problem installing VIA drivers

I have a PCChips P23g ver 1.0 motherboard running windows 7, and I am adding a new SATA dvd drive. I am trying to update my sata driver, but I cannot find a driver package that works. I checked with my motherboard manufacturer website and it tells me to install VIA Hyperion Pro 4in1 Driver 5.24. But when I try to install it, I get a message "Sorry, the install wizard can't find the proper component for the current platform. Press OK to terminate the install wizard." I have tried downloading several different copies of this driver package (each one is supposed to be compatible with windows 7 according to the site I downloaded it from), but none of them get past this message. Please help.

My System SpecsSystem Spec
.

22 Dec 2009   #2

Windows 7 Professional x64
 
 

Hello slackrslayer,

Are you having issues installing the drive? If so, perhaps we can help you with those. If you want to update your drivers, try searching for chipset drivers. Let's see what happens.

~Jonathan
My System SpecsSystem Spec
23 Dec 2009   #3

windows 7
 
 

I am using the exact same motherboard with windows 7 but I used the Microsoft VIA drivers that came with windows 7 itself. My LG SATA DVD drive is working fine. Why do you need to install the VIA drivers? - are you using a RAID configuration on your SATA harddisks?
My System SpecsSystem Spec
.


23 Dec 2009   #4

Windows 7
 
 

I got it to work. The problem seemed to be with an esata port that I connected at the same time I connected my sata DVD drive. It turns out my motherboard doesnt support esata and it was causing an issue. When I disconnected both and only hooked the Sata DVD drive back up it worked perfectly.
My System SpecsSystem Spec
23 Dec 2009   #5

Windows 7 Professional x64
 
 

Good, thanks for posting. I've got to remember that for future reference.
My System SpecsSystem Spec
Reply

 Problem installing VIA drivers





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:03 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33