Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: CD/DVD Driver missing on install

21 Oct 2011   #101
boma23

Win 8 dev preview, Win7 Ultimate 32bit, Pro 64 bit, XP Pro, OSX, Linux, whatever is needed...
 
 

Just had this trying to install Win7 64bit on on brand new MSI mobo, with i5, 8GB DDR3 and brand new SATA DVD/RW

My Fix:

Go into BIOS
Change SATA operation from IDE mode to AHCI

Bingo


My System SpecsSystem Spec
.

23 Oct 2011   #102
hanomajstor

Windows 7 Professional 32bit
 
 

I have the ame problem
My System SpecsSystem Spec
27 Oct 2011   #103
jefro

windows 7 ultimate x64
 
 

This solved the problem for me and hopefully for you.
Goes on about missing cd/dvd drivers which i first thought where sata drivers but couldn't get them to win 7 to find them on the list.
Go to your bios setup screen which is f2 on my machine.
Then go to the advanced tab at the top and you should see IDE/SATA configuration.
All i did was changed onboard SATA type to NATIVE IDE instead of RAID.
Just make sure your sata isn't set to raid and windows should now boot up set up no problem
Hope this helps
My System SpecsSystem Spec
.


09 Feb 2012   #104
tuyo

windows 7 64bit
 
 

Well 3 years after this thread started yesterday I got the same error message when trying to install windows 7 64 for the first time on a brand new foxconn e350 using a USB DVD drive and a brand new Windows cd. So this problem has still not been resolved.
My System SpecsSystem Spec
19 Mar 2012   #105
elva

Windows 7 Home Premium
 
 
Installing from USB Pen drive SOLUTION!!

Guys, guys, GUYS!! This missing driver issue had me going in circles, disconnecting all other drives, trying IDE, AHCI and RAID, tried loading drivers, wouldn't have any of it. Then I simply changed the Pen drive to another USB port (from the back of the PC to the front panel), and simply going back to the Install Now window and clicking on it WORKED!! Hope this helps somebody out there...
My System SpecsSystem Spec
21 Mar 2012   #106
kyonist

Windows 7 Ultimate x64
 
 

I've finished building my custom rig, trying to install Win7 Ultimate 64bit comes to a quick halt @ starting up (missing CD/DVD device driver... please install correct drivers for your hardware blah blah)...

Facts: New system. Hardware are all functional, successfully tested Linux OS ubuntu 11.10, uninstalled and rewrote partition to NTFS and FAT32.

Regarding DVD: I am using a Win7 Ultimate 64bit ISO from digitalrivercontents. (supposed to be official) I purchased a legitimate copy of Ultimate 64bit English but it will arrive late April. Wanting to set up my system before that I received the product key ahead of time.

In any case, it's come to two possible scenarios:
1. Faulty ISO (somehow the Win7 Boot DVD iso I've downloaded is lacking proper drivers.../ and hoping the actual DVD arriving late April will be successful... but this won't help me now)
2. BIOS / CMOS configuration error. - Unlikely as I've played around with IDE/RAID/AHCI options, none of which allowed me past the driver missing error.

Attempting to install whatever "missing" drivers from my Mobo Utilities disk has resulted in errors as well. It appears to be fully up to date.

I do not have a USB drive large enough to boot Win7.

Any suggestions?
My System SpecsSystem Spec
22 Mar 2012   #107
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Quote   Quote: Originally Posted by kyonist View Post
I've finished building my custom rig, trying to install Win7 Ultimate 64bit comes to a quick halt @ starting up (missing CD/DVD device driver... please install correct drivers for your hardware blah blah)...

Facts: New system. Hardware are all functional, successfully tested Linux OS ubuntu 11.10, uninstalled and rewrote partition to NTFS and FAT32.

Regarding DVD: I am using a Win7 Ultimate 64bit ISO from digitalrivercontents. (supposed to be official) I purchased a legitimate copy of Ultimate 64bit English but it will arrive late April. Wanting to set up my system before that I received the product key ahead of time.

In any case, it's come to two possible scenarios:
1. Faulty ISO (somehow the Win7 Boot DVD iso I've downloaded is lacking proper drivers.../ and hoping the actual DVD arriving late April will be successful... but this won't help me now)
2. BIOS / CMOS configuration error. - Unlikely as I've played around with IDE/RAID/AHCI options, none of which allowed me past the driver missing error.

Attempting to install whatever "missing" drivers from my Mobo Utilities disk has resulted in errors as well. It appears to be fully up to date.

I do not have a USB drive large enough to boot Win7.

Any suggestions?
As the your new MOBO has a uEFI BIOS.
How to install Windows 64 bit on a uEFI BIOS:
UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with

uEFT BIOS setup: Check your manual.
My System SpecsSystem Spec
22 Mar 2012   #108
kyonist

Windows 7 Ultimate x64
 
 

As the your new MOBO has a uEFI BIOS.
How to install Windows 64 bit on a uEFI BIOS:
UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with

uEFT BIOS setup: Check your manual.[/QUOTE]

Hi, thanks for the suggestion...
Are you sure my Mobo is uEFI? Isn't that an Asus product?
Mine appears to be Gigabyte-Touch Bios (Hybrid EFI Technology)
As such there was no UEFI enable/disable in the bios setup
My System SpecsSystem Spec
22 Mar 2012   #109
cyclic

Windows 7 home premium x64
 
 

Quote   Quote: Originally Posted by kyonist View Post
uEFI? Isn't that an Asus product?
Not specifically, it was a combined effort from allsorts of people. Gigabyte are quite wrong to call it BIOS, the whole idea is that the old BIOS and bootstrap loader are replaced by EFI, either the United version or other.
My System SpecsSystem Spec
07 Apr 2012   #110
koolaje

Windows 7 Home Premium 64 Bit
 
 

If the installation is using a USB Flash Disk, this would sort it out:

A required CD/DVD device driver is missing, usb installation - Microsoft Answers
My System SpecsSystem Spec
Reply

 CD/DVD Driver missing on install




Thread Tools





Similar help and support threads
Thread Forum
Cannot install driver / drivers missing on new install win7 ultimate
Hello, this is my first post on the forum, and I hope you can help me. I have recently been given an HP 6465b probook. It had been dropped and the hard drive had failed. I installed a new hdd and got a copy of Windows 7 ultimate x64. The install went well until I discovered I couldn't connect to...
Drivers
Cannot continue install--missing driver
Trying to replace win8 with win7 on a new laptop. It has a 32 GB SSD paired with a 500 GB HDD with Intel RST. I am doing a network installation, since I don't have a spare USB key that's big enough, or an external optical drive. I got the Intel RST F6 drivers, and put them on a USB stick. I...
Installation & Setup
Windows7 cant install on GTP partition & Device Driver install missing
Hi, I recently have posted aboutan issue with recovering from a partition whichwent fine. So I went through to do a clean re-install of windows 7 with a boot USB to get rid of factory bloatware and when I do. it gets to the option to write to a partition it sayscan't write to a GPT partition....
Installation & Setup
cd driver missing during install. using flash drive to install
Help. I can't fix this issue. Tryin to install win7 to a fair array. I disabled qll my SATA controllers except the array
Installation & Setup
missing cd driver message on X64 install
I am trying to install Windows 7 Ultimate X64 on my computer. When I get to the "Collecting Information" stage I get this error about missing cd driver. I have an Abit AWD9-MAX MOBO and a ASUS 24B1ST DVD/RW CD. Any help would be appreciated.
Installation & Setup
missing cd/dvd rom driver after install?
I just did a clean/custom install of windows 7 32bit on an out of the box dell optiplex 760. Everything seems fine except i get a "Drive 1 not found: serial ata, sata-1. Failed to detect one or more drives during POST" message during startup. Any ideas as to where i went wrong or what the problem...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:21.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App