Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: CD/DVD Driver missing on install

26 Aug 2010   #81

win 7 enterprise 64bit

So….I have read through all eight pages and do not see one definitive fix, correct?

I have a standard off-the-shelf HP xw8200. I have not sata or ide optical drives connected, disabled things in the bios that seem to be tied to these two bus types (I’d have to look again to be exact as to the names) and have a bootable usb with the win 7 ent.

I downloaded the ISO and burned it on different media, different speeds….same burner though. I use ImgBurn to extract the ISO and burn it to the dvd.

Currently, I am trying to find drivers for the sata and ide controllers. This machine was not offered with win 7, just vista though.

What the heck.

My System SpecsSystem Spec
09 Nov 2010   #82

windows 7 32bit

Had same issue, resovled after settings CD/DVD Drive as primary boot drive prior to HDD and then start the install. This should fix

Confirm if it works.
My System SpecsSystem Spec
10 Nov 2010   #83

Windows 7 Ultimate

i normally use aspi drivers they do the same thing...
My System SpecsSystem Spec

11 Nov 2010   #84

win 7 enterprise 64bit

Mine was a bad download of the ISO.
My System SpecsSystem Spec
24 Dec 2010   #85

Windows 7 Ultimate x64 x32
I had this twice

Fist time it was a very old DVD drive I changed the drive then it installed fine, The second time was on a new DVD drive I went into the bios and turned off UDMA then all was good
My System SpecsSystem Spec
05 Jan 2011   #86

Windows 7 Ultimate Edition
CD/DVD Driver missing on Installation

I have a Sony VAIO computer model VGN-NR43OE. I had to buy a new SATA HD for it because the technician diagnosed my Laptop needing a new hard drive. This is a SEAgate LP Momentus 500GB SATA 5400 RPM HD. I am installing a clean cut of Windows 7 Ultimate Edition. I ran my BIOS after the SATA HD installation. The BIOS recognizes the hard drive, saying 500GB. However, I got off the live chat with a Sony VAIO technician after she gave me the link to download windows 7 Drivers for my Laptop. I downloaded all the drivers for 32bit and 64bit. I tried 50 times today to install them but it seems Windows 7 is wanting a cd/dvd media driver that does not exist.

My problem is updating the HD SATA drive so Windows 7 recognizes its there upon installation so it can format it before installing the OS on it.

If anyone can help me, I would appreciate it very much, my email is Thank you!!
My System SpecsSystem Spec
06 Jan 2011   #87

windows xp
bad disc

I should have updated this thread with my fix a looong time ago.

Get a new win 7 disc with SP1. Pre SP1 discs have problems with too much memory installed and caused all the installations issues I ever had with win 7, including a missing sata dvd drive.
My System SpecsSystem Spec
07 Jan 2011   #88

windows XP Pro SP3

So, I already spent the money for the disk without SP1. Who pays for my new disk? This is clearly Microsoft's problem. I have stayed with XP on older machines. This just shouldn't be this difficult.
My System SpecsSystem Spec
26 Jan 2011   #89

windows 7 ultimate

I had the same problems also.I thought my installation disc is the problem,but when i try to format another laptop,it work fine.

I wont bother to format it from usb.

what i did was,i take out my hard disk,put in external casing,format it,delete all the partitions.and make a new clean install of windows 7.
My System SpecsSystem Spec
26 Jan 2011   #90

windows 7 ultimate

Quote   Quote: Originally Posted by nagalla View Post
Had same issue, resovled after settings CD/DVD Drive as primary boot drive prior to HDD and then start the install. This should fix

Confirm if it works.
Both,works on laptop,wont work on my Desktop.
My System SpecsSystem Spec

 CD/DVD Driver missing on install

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Cannot install driver / drivers missing on new install win7 ultimate
Hello, this is my first post on the forum, and I hope you can help me. I have recently been given an HP 6465b probook. It had been dropped and the hard drive had failed. I installed a new hdd and got a copy of Windows 7 ultimate x64. The install went well until I discovered I couldn't connect to...
Cannot continue install--missing driver
Trying to replace win8 with win7 on a new laptop. It has a 32 GB SSD paired with a 500 GB HDD with Intel RST. I am doing a network installation, since I don't have a spare USB key that's big enough, or an external optical drive. I got the Intel RST F6 drivers, and put them on a USB stick. I...
Installation & Setup
Windows7 cant install on GTP partition & Device Driver install missing
Hi, I recently have posted aboutan issue with recovering from a partition whichwent fine. So I went through to do a clean re-install of windows 7 with a boot USB to get rid of factory bloatware and when I do. it gets to the option to write to a partition it sayscan't write to a GPT partition....
Installation & Setup
cd driver missing during install. using flash drive to install
Help. I can't fix this issue. Tryin to install win7 to a fair array. I disabled qll my SATA controllers except the array
Installation & Setup
missing cd driver message on X64 install
I am trying to install Windows 7 Ultimate X64 on my computer. When I get to the "Collecting Information" stage I get this error about missing cd driver. I have an Abit AWD9-MAX MOBO and a ASUS 24B1ST DVD/RW CD. Any help would be appreciated.
Installation & Setup
missing cd/dvd rom driver after install?
I just did a clean/custom install of windows 7 32bit on an out of the box dell optiplex 760. Everything seems fine except i get a "Drive 1 not found: serial ata, sata-1. Failed to detect one or more drives during POST" message during startup. Any ideas as to where i went wrong or what the problem...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:31.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App