Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Base System Device driver not installed

24 Dec 2009   #1

Windows 7 Ultimate x64
Base System Device driver not installed

"The driver for Base System Device is not installed. Install the latest driver for the device."

This is message I'm getting. I can find 3 "Base System Device" in Device Manager, but I have no idea what devices they are so I can't search for drivers.

Here are the Hardware Ids if that's any help

Device 1

Device 2

Device 3

I'm running W7 Ultimate 64-bit on an Acer Aspire 4935G laptop.

Any thoughts about this would be most welcome

My System SpecsSystem Spec

24 Dec 2009   #2

Windows 7 ultimate 64 bit / XP Home sp3

Welcome to seven forums. All these are for a jMicron card reader. They actualy have win 7 64 bit drivers Hope this helps. Fabe
My System SpecsSystem Spec
25 Dec 2009   #3

Windows 7 Ultimate x64

Thank you, I installed those drivers and the problem seems to be gone. Thanks again
My System SpecsSystem Spec

25 Dec 2009   #4

Windows 7 ultimate 64 bit / XP Home sp3

Your welcome. Fabe
My System SpecsSystem Spec

 Base System Device driver not installed

Thread Tools

Similar help and support threads
Thread Forum
Base System Device Driver
I have recently reinstalled Windows 7/64 (ultimate) to my Vaio VGN-Z710DD (sold in Canada only). For Device manager the driver is not installed. I have downloaded the driver from Vaio website (Memory Devices for WIndows 7 x64). After the install, the system tell me the installation was no...
Another Base System Device driver not installed!
Sorry folks but would really appreciate anyone helping on this, just installed 7 on my Dell XPS M1330 and playing around saw this: Problem with PnP devicesDetected res://sdiageng.dll/warning.pngThere are problems with some PnP devices. Windows will take additional steps to further troubleshoot...
Base System Device no driver
Hello all, I succesfully installed Windows 7 Home Premium x64. Only one device in devicemanager has no driver, or is not functioning correct. see picture below: Does someone has a suggestion how to solve this?
Installation & Setup
Base system device/Modem driver not installed
My Laptop is sony VAIO VGN-NW11S I recently installed windows 7 32 bit ultimate. After installing OS & Drivers and using sony vaio update s/w installed max driver updates. But still i have two drivers not installed properly. i cant identify them. cant get drivers for the same. pasting screenshot...
Reinstalling Base System Device driver -- please HELP!
My Dell Inspiron 1521 laptop's built-in microphone doesn't work anymore after I installed Window 7. I followed suggestions to uninstall the Audio device driver and to reinstall. I uninstalled the Audio device driver and now my "Base System Device" doesn't have a driver. I troubleshoot and try...
Sound & Audio
Base System Device - drivers not installed
Hi, I recently installed Windows 7 Home Premium and I have the Base System Device error on 3 devices. I am having a problem attaching multiple USB drives simultaneously so I want to make sure that these driver problems are not contributing to the problem. Here are the hardware ID's from device...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:49.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App