Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB DAC issue - bad driver?


09 Mar 2009   #1

Windows 7 beta 32bit
 
 
USB DAC issue - bad driver?

hey guys,

i finally settled for an external "sound card" - the Kingrex UD-01 USB DAC.
the devide gets correctly detected and installed as a new audio device. this one i can select from my audio player (foobar2k).

everything works fine for a while (during playback), or simply after leaving the PC for a few hours untouched.
when i come back and wanna start music again, nothing happens. player won't start playing the music. when going to the control panel, the device is shown correctly. then i try to "reset" it by disabling and the re-enabling the device. unfortunately this is when i get a yellow exclamation sign next to the audio device and the error "The device cannot be started (Code 10)."

do you know what to do to get rid of this issue? it's pretty much annoying ://

My System SpecsSystem Spec
.

09 Mar 2009   #2

Vista Ult 64bit - Windows 7 Ult 7264 64bit
 
 

Hi eXelero, Welcome to Windows 7 forums!

That's commonly a sign of an incompatible driver, and especially since you're using a Beta OS I would say that's the case here too.
It may appear to work or work for a short period of time, as you're seeing, but then it fails as the driver calls another function or has a missing string that the OS expects to be in the driver, and then it fails.

I would start by contacting Kingrex support and asking them if they know of incompatibilities with Windows 7, or if they have any beta drivers for 7 you could help them try out. Never know, you may get lucky..
My System SpecsSystem Spec
12 Mar 2009   #3

Windows 7 beta 32bit
 
 

i almost went back to vista x86 sp1...but i got Windows 7 rc1 today, and for now i tested it successfully. the usb audio drivers have a new version, which for now work fine. the issue above did not appear...yet (cross my fingers).

wish me luck because i don't wanna give up Windows 7
My System SpecsSystem Spec
.


Reply

 USB DAC issue - bad driver?




Thread Tools



Similar help and support threads for2: USB DAC issue - bad driver?
Thread Forum
Driver Issue? Drivers
driver issue Drivers
Win 7 HP Driver issue HELP! Drivers
Can anyone help with this driver issue? Drivers
Driver issue ? Graphic Cards
8800GT Driver issue? Or maybe its a bios issue. Drivers
Please help with driver and RAM issue Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:33 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33