Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: HD 5750 Driver problem!

12 Feb 2010   #1

Windows 7 Professional 64 Bit
 
 
HD 5750 Driver problem!

Hi All,

I have searched for my problem but cannot seem to find anything relating to the HD 5750.

I have just install an intel P55 mobo - i5 750 - 4GB DDR3 1600mhz RAM - ATI RADEON HD5750 1GB.

Everything went fine and it all started great. The only problem I have is the ATI driver is not working.

I have updated the mobo bios and it still is not working. I also have a problem with the windows 7 driver update tool. I have turned this off in the group settings but it still wants to update, so I can't uninstall a driver and restart without it installing again some default crappy VGA driver.

I did manage to get the ATI driver to install once but then when it restarts it states it did not install properly.

So I'm stuck, What else am I not thinking about? What else can I try?

I might just have to completely reinstall windows 7 fresh.

Thanks


My System SpecsSystem Spec
.

12 Feb 2010   #2

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by RADICAL View Post
I have turned this off in the group settings but it still wants to update, so I can't uninstall a driver and restart without it installing again some default crappy VGA driver.
Have you tried disabling it in Device installation settings?
My System SpecsSystem Spec
12 Feb 2010   #3

Windows 7 Professional 64 Bit
 
 

Quote   Quote: Originally Posted by FZ21Z View Post
Quote   Quote: Originally Posted by RADICAL View Post
I have turned this off in the group settings but it still wants to update, so I can't uninstall a driver and restart without it installing again some default crappy VGA driver.
Have you tried disabling it in Device installation settings?

Nope, just done that. I have also I think just updated the chipset as well. So i'll restart and see what happens.

Hold your breath
Thanks
My System SpecsSystem Spec
.


12 Feb 2010   #4

Windows 7 Ultimate x64
 
 

Fingers crossed.
My System SpecsSystem Spec
12 Feb 2010   #5

Windows 7 Professional 64 Bit
 
 

Nope. did not work got this error



So I ran the driver I downloaded again and got told this



And the driver version is this:

My System SpecsSystem Spec
12 Feb 2010   #6

Windows 7 Professional 64 Bit
 
 

Anything else I could try?
My System SpecsSystem Spec
12 Feb 2010   #7

Windows 7 Professional 64 Bit
 
 

Just thought I would uninstall it again and restart.

And guess what, after turning off the Windows driver update tool it updated itself again. So now it's got this VGA generic driver again, which needs to be restarted to get rid of and then it install itself again.

Can someone point me in the direction on a driver for ATI HD 5750 please, just the driver none of the other crap that comes along with it.

Before anybody points me towards the ATI product site saying you can download it separately. It's not separate it comes with everything else as well. The download link on the ATI website is wrong it's not just the driver.

I need to just try and point the device manager towards the driver and see if that works.

Or is there something else at work that I have not tried?

Help me please
My System SpecsSystem Spec
13 Feb 2010   #8

Windows 7 Professional 64 Bit
 
 

So i'm still trying to help myself with this problem.

I am now trying to stop the Windows 7 driver update from doing it's job, so I can get a chance to possibly install my graphics card drivers.

I have edited the group policy settings but it STILL updates itself when I reboot.

Any ideas anyone?
My System SpecsSystem Spec
14 Feb 2010   #9

Windows 7 Professional 64 Bit
 
 

Really need some suggestions here folks.

Anyone come across this?

I have now used the browse function on device manager and asked to install the driver from the ATI folder on the computer, which it did but after a restart device manager stated:

"This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)"

Any ideas how to get around this?

Thanks
My System SpecsSystem Spec
14 Feb 2010   #10

Windows 7 Professional 64 Bit
 
 

I've installed the older 9.12 version of the driver and that works. The 10.1 newest version does not work. Has anyone else come across this?
My System SpecsSystem Spec
Reply

 HD 5750 Driver problem!




Thread Tools



Similar help and support threads for2: HD 5750 Driver problem!
Thread Forum
acer 5750 nvidia driver problem. Drivers
Premiere CS4 horrible stutter (ATI Radeon 5750 as problem?) Graphic Cards
Radeon HD 5750 Graphic Cards
Solved Ati 5750 Graphic Cards
ATI 5750 problem Graphic Cards
5750 vs. 5770 Graphic Cards
Ati HD 5750 1GB but which one? Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:03 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33