Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Vista drivers don't work in W7!!!!

04 Apr 2009   #1

Windows 7 Ultimate 64bit
 
 
Vista drivers don't work in W7!!!!

Well i downloaded the drivers from Intel for my express family drivers(graphic drivers ofcourse) built for vista OS when i install them it says its not for the OS i have?


My System SpecsSystem Spec
.

04 Apr 2009   #2

 

Run the setup in Vista compatibility mode.
My System SpecsSystem Spec
04 Apr 2009   #3

 
 

Quote   Quote: Originally Posted by johngalt View Post
Run the setup in Vista compatibility mode.
Agreed. I've had to do exactly the same as it's a single exe file. It runs 100% in compat mode for Vista & runs the mobile graphics console.
My System SpecsSystem Spec
.


04 Apr 2009   #4

Windows 7 Ultimate x64, XP Mode, W8.1 Preview VM - 7 Pro x64 second remote tower
 
 

Besides opening the compatibility tab in the right click properties screen the troubleshoot compatibilty item is now seen in 7 as a better option since that will create a new value in the registry for the installer or main executable once any program is installed.

That's been a great help seeing older XP programs installed on 7 that simply will not install on Vista despite various efforts.

My System SpecsSystem Spec
05 Apr 2009   #5

Windows 7 Ultimate 64bit
 
 

"Package 50726 has stopped working"

This is the error i get when i run the exe file in Vista capability mode.
now?

and i also did the troubleshooting through which i ended up having the same error.
My System SpecsSystem Spec
05 Apr 2009   #6

Windows 7 Ultimate x64, XP Mode, W8.1 Preview VM - 7 Pro x64 second remote tower
 
 

The best to try now is to look to see if there are 7 beta drivers or Vista/7 beta updates available. I've been running into that a few times on the 7 builds here replacing the ATI Catalyst 9.2 latest for Vista with a new 9.3 listing Vista/7 beta. Or you may have to fight a little harder with the troubleshooting tool in order to finally see any results.

If none are available and you have the software disk for a card installed on a custom build try browsing to the setup.exe file seen on the disk itself and right click on that to see that will work. For prebuild the only option would be looking for something beta if found.

With the 7000 build I saw the Vista updates go on without fuss. When trying the same on the 7068 that's where the 9.3 was needed for that. If you are running a newer build that's probably the time for any beta version from Intel you can find.
My System SpecsSystem Spec
06 Apr 2009   #7

Windows 7 Ultimate 64bit
 
 

well i have been running windows xp so far so in disk i have drivers for xp only there fore i downloaded vista drivers from the intel site which gives that error..

again can you explain what do you mean i have to try harder over troubleshooting?

P.S is there difference btween Intel® 82945G Express Chipset and Intel® 82945G Express Chipset Family? and also do i need to download windows vista drivers or windows vista ultimate drivers?
My System SpecsSystem Spec
06 Apr 2009   #8

W7 X-64 W8.1 X-64 Opensuse 13.1 W2003 Server
 
 

What chipset are you having problems with

Mine installed fine both the 965 chipset for Laptop and the G45/G43 for a desktop.

You might get a message "Did this install correctly" with a choice install again in compatability mode. Just do that and Windows 7 will install it correctly.

There are now some chipset drivers available on the Microsoft update site.
For example the G45/G43 chipset.

Cheers
jimbo


Attached Thumbnails
Vista drivers don't work in W7!!!!-video.png  
My System SpecsSystem Spec
06 Apr 2009   #9

Windows 7 Ultimate 64bit
 
 

i saw at the same place i have the drivers there which are version 8 where as for xp there is only version 7. but still when i run a game it says i need to install updated version of my graphic drivers where as i can run that same game in windows xp with version 7? what could be the problem?
My System SpecsSystem Spec
06 Apr 2009   #10

Windows 7 Ultimate x64, XP Mode, W8.1 Preview VM - 7 Pro x64 second remote tower
 
 

I ran into an OpenGL problem lately with the Catalyst 9.2 I was mentioning before where the 9.3 now seen out indicated 7 beta on it. That cleaned that problem right up.

For older games in 7 one thing besides which driver set is the game's own executable once installed may need to be set to run in XP or Vista compatibility mode. I found that the case with quite few XP programs not able to be installed on Vista yet go on 7 using the troubleshooter on the installer or main exe file once on to see more actually working.

XP itself is a totally separate older version of Windows from 7 like 7 is from Vista with the game written for XP primarily while 7 is working in backwards compatibility already. If you were able to run a 98 game in XP that would be a similar example.

The board here that lacks Vista/7 updates at Asus while NVidia.com and the MS updates will see all of those needed in the optional hardwares. When checking for updates on your own select the custom not express option to look over any optional updates available.
My System SpecsSystem Spec
Reply

 Vista drivers don't work in W7!!!!




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:44 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33