Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Intel PRO/100 M network adapter

23 Feb 2010   #11

Windows 7 x64 with SP1

After searching further, I found these drivers:
Network Adapter Driver for Windows Vista*
These seem to work. I unpacked the installer with WinRAR, went to device manager, update driver, have disk, and pointed it to the "PRO100" folder.
There I selected the "Intel PRO/100 M Desktop adapter", and Windows gave me a warning that the selected driver was not compatible with my hardware, but I installed it anyway, and I see that it works.
I wonder why it doesn't work out of the box just like the Windows Compatibility website says.

Thanks everyone.

My System SpecsSystem Spec
02 Mar 2010   #12

Windows 7 x64 with SP1

Well, it looks like that solution is a bit incomplete.
I only now saw that the driver provides networking functionality, but it always thinks the cable is unplugged.
It's very strange. I plug the cable in, and Windows gets an automatic IP address, and everything works (LAN, Internet), but it says "Network cable unplugged". I can't get to the status of the connection, because it is grayed out.
By using "ipconfig", i can see that I have an IP address and what that is.

So it looks like that driver isn't 100% compatible (like Windows said). Anyone know about another driver that will work?
My System SpecsSystem Spec

 Intel PRO/100 M network adapter

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Intel Centrino 6150 network adapter issues
Hi all, I have an Asus U56E which has an Intel Centrino 6150 Wireless N + Wimax network adapter on it. This card ran fine the first few months I had it. Then I installed Ubuntu 12.04 with my windows install and ran it dual boot. The card worked fine on Windows but I had to make some...
Hardware & Devices
Code 10 Network Adapter intel 82562v10/100
Vista Home premium 64 bit Dell Inspiron 530S Desktop Dear folks, I can’t get the Network Adapter Intel 82562 v10/100 to work despite multiple diagnostics, installations and Dell factory system restore (F8). Consistently I get a recalcitrant ‘Code 10’ in the network adapter driver. ...
Intel Network adapter
For some reason I cant upgrade my network adapter because I cant uninstall the old drivers. I've tried everything i can think of including deleting it from the device manager, add/remove program, and even the registry. It's asking for a file called PROSETDX.msi which there are many of but none of...
HELP!! W7 Home Premium and intel network adapter
Hi, im a newbie to W7. Just done a (Windows 7 Home Premium 32bit) clean install on my PC. i was using WXP Professional. PC SPEC motherboard: Intel Desktop Board DP965LT LAN: Gigabit (10/100/1000 Mbits/sec) LAN subsystem using the Intel® 82566DC Gigabit Ethernet Controller
Intel 2200BG network adapter - Win 7 driver?
That said; Intel has discontinued support for the Intel ProSet/Wireless 2200BG Network Adapter. There might be some generic drivers capable of Win7 out there, but I can't find them on the Intel site. I did find Vista drivers here. Update: These drivers worked and this old lappy is now...
Installing network adapter - Intel 855 Centrino Chipset
Ok. so I'm trying to install this Intel 802.11bg driver on my Tosh lappy. (I am installing it from a USB Flash drive, since the machine has no network connections.) I install in XP2 compatability mode, and the report is that the installation is correct. But on restart, "Windows could not find a...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:43.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App