Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No USB devices work, at all!


06 Mar 2010   #1

Windows 7
 
 
No USB devices work, at all!

I do not know what happened, but it seems as if my computer does not recognize any USB device! From my iPod touch to my USB stick. It just happened recently and I have no clue what happened. I'm running on 32-bit Windows 7 Intel(R) Pentium(R) Dual CPU E2140 @ 1.60 GHz 1.60 GHz and 2 GB RAM. Please help!!!

I have also tried it using different USB ports and it comes to the same problem, "USB Device not recognized" and on device manager it shows it as an "Unknown Device".

My System SpecsSystem Spec
.

06 Mar 2010   #2

MS Windows 7 Ultimate SP1 64-bit
 
 

Win key | type DEVMGMT.MSC | Enter key

Are there any Yellow question marks or red X's?

Did you recently play around in the bios?

Disconnect all usb devices.

Plug in one and only one usb stick. Does the USB stick show up when you: Win Key | Computer
My System SpecsSystem Spec
06 Mar 2010   #3

Windows 7
 
 

Nope. All it shows is:



I only have the USB stick plugged in.
My System SpecsSystem Spec
.


06 Mar 2010   #4

MS Windows 7 Ultimate SP1 64-bit
 
 

That screen shot indicates that you have a USB mass storage device connected.

Please disconnect ALL usb devices, even a USB mouse if you are using one.

Now restart your computer.

Do not plug any usb devices in.

Go to device manager again.

Does it show any yellow or red markings?


.
My System SpecsSystem Spec
06 Mar 2010   #5

Windows 7
 
 

Thanks!! I just uninstalled the 'USB Mass Storage' and now it works perfectly!

+ Rep added.
My System SpecsSystem Spec
07 Mar 2010   #6

WIN7 Ultimate 64bit
 
 

for follow up readers
As karlsnooks says unplug all usb devices then

another way of curing this is to switch off at wall/unplug your power.supply.unit from electric (or detach elec. lead from psu) for a minute/till light goes out on motherboard - this clears/resets the usb chipset? if it's got it's knickers in a twist!
My System SpecsSystem Spec
Reply

 No USB devices work, at all!




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:41 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33