Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Nforce drivers not loading when attempting repair

12 Apr 2010   #1
tommygee

windows 7
 
 
Nforce drivers not loading when attempting repair

Hello,

Basically what happened is my vista drive died. This was the first drive with the MBR on the system. I had been using the Windows 7 raid (Nforce) for a while with no issues until the vista drive died in a fire. So my current problem are as follows:

1. When I toss the Win7 DVD in the drive and attempt to load the NForce drivers for my system (needed for the repair procedure), I get failed to load drivers. Yes I have ensured to point the Windows repair utility to the correct files on the CD that came with the board (XFX 750i). They will attempt to load but just fail.

So my question now is how do I get my RAID 0 setup to boot? There is no MBR on this disk. Is it possible to write the MBR to the disk once the drivers finally get loaded? Or is this just a pave and nuke kinda deal.

Any help would be greatly appreciated!!!

Thanks,

Tom


My System SpecsSystem Spec
12 Apr 2010   #2
not so gray matter

W7 Ult. x64 | OS X
 
 

Try downloading the latest NFORCE drivers from the NVIDIA website.

32-BIT: http://www.nvidia.com/object/nforce_win732_15.51.html
64-BIT: http://www.nvidia.com/object/nforce_win764_15.51.html

Use them via a CD or USB stick.
My System SpecsSystem Spec
12 Apr 2010   #3
MadMaxData

Windows 7 Enterprise x64
 
 

If you saved a backup of the MBR from your old HDD, you can load it at boot.
My System SpecsSystem Spec
12 Apr 2010   #4
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by tommygee View Post
Hello,

Basically what happened is my vista drive died. This was the first drive with the MBR on the system. I had been using the Windows 7 raid (Nforce) for a while with no issues until the vista drive died in a fire. So my current problem are as follows:

1. When I toss the Win7 DVD in the drive and attempt to load the NForce drivers for my system (needed for the repair procedure), I get failed to load drivers. Yes I have ensured to point the Windows repair utility to the correct files on the CD that came with the board (XFX 750i). They will attempt to load but just fail.

So my question now is how do I get my RAID 0 setup to boot? There is no MBR on this disk. Is it possible to write the MBR to the disk once the drivers finally get loaded? Or is this just a pave and nuke kinda deal.

Any help would be greatly appreciated!!!

Thanks,

Tom
You can hit the F10 key to load the default Windows 7 RAID drivers on boot up also. You will need to set up the stripped RAID 0 array when you get there.
My System SpecsSystem Spec
13 Apr 2010   #5
tommygee

windows 7
 
 

Hi there,

First off thanks for the responses!

Anyways, so here is the thing...when I toss the windows 7 disk in and go to repair utility, I am able to access my current RAID 0 with the data. I do this by going to repair option >>click next >> Windows explorer pops up and then I click the K:\ drive, which was my old C:\ drive before and then pow...theres all my data. But when I try and use the latest drivers from Nvidia, the load driver utility comes back saying that it cant load the drivers and no OS/Installatioins are found.

So it comes down to not being able to load the OS in the repair utility. The original idea was to use the fix start up issues or whatever utility and hopefully that would write the mbr to the RAID 0.

Conclusion, I need the RAID 0 to have the MBR on it so it will boot the OS.

Any further help would be great!

Thanks,

Tom
My System SpecsSystem Spec
13 Apr 2010   #6
tommygee

windows 7
 
 

Ok guys I managed to find out how to fix this baby!! This is what I did:

1. I went into the repair utility on the Windows 7 disk
2. Selected next instead of load drivers
3. I went to the command prompt and typed the following:

Diskpart
lis vol
sel vol 3 ( which was my healthy raid)
act
exi
4. exit from command prompt
5. reboot and was prompted that there was a missing bootmgr
6. Went back into the repair utility on the disk and clicked repair( it ran the command bootrec /fixboot )
7. Rebooted
8. Anoying Windows 7 boot sound!!!!!! How I enjoyed that!

I hope this helps other people that are in the same boat. Thanks again forum members for your assistance!
My System SpecsSystem Spec
05 Jul 2011   #7
Tomcup

Vista x64
 
 
Thanks!

Hey thanks so much tommy, you solved my issue! - I had the same problem

I know this was posted a long time ago, but it worked for me on vista 64 with nforce raid 0.

Problem now is...once it booted I realized it was a reallly horrible virus that did it!
I didn't even download anything ughhhh.
I'm gunna try doing system restore to get rid of it, usually works.

Thanks again though!
My System SpecsSystem Spec
Reply

 Nforce drivers not loading when attempting repair




Thread Tools





Similar help and support threads
Thread Forum
startup repair 16 hrs latter still attempting repair
ok HP computer don't want top loose data if possible wont start up even in safe mode goes into startup repair and stays there so far 16 hrs : so is there a way to repair the operating system or start up dir , remember it don't come with win operating cd , dont want do complete restore unless have...
Backup and Restore
nvidia nforce drivers better than win 7 64 bit drivers!!
Question: should i install nforce drivers from nvidia web site or just stick with win 7 64bit drivers. I got this pc from a friend it already had win 7 64 bit on it but i didnt see any nforce drivers in the unistall section.I did however install the latest graghicsw drivers. System is running...
Drivers
Attempting to repair boot failure?
I'm in the process of rebuilding the windows 7 bootloader. After trying command 4 it says (Scanning all disks for windows installations. Successfully scanned windows installations. Total identified windows installations: 0 The operation completed successfully. What's the difference between...
Hardware & Devices
New nForce IDE drivers for Windows 7
NVIDIA obviously has developed new nForce IDE drivers for Windows 7 Windows 7 has in-the-box nForce IDE drivers v10.6.0.3 dated 08/14/2008 and I think, that these drivers will work with Vista too. The associated NVRAID.INF file contains the HardwareID's of all nForce SATA and RAID Controllers...
Drivers
Help regarding nforce drivers
Im having nforce 630a chipset and iam abt to install windows 7 ..where can i get chipset drivers.......:(
Drivers
New Nforce drivers 32 64bit
New nforce drivers for 32 and 64 bit ide drives. nForce IDE drivers v10.6.0.3 for Vista/Win7 (32/64bit)= :) Update: Already posted in another thread http://www.sevenforums.com/drivers/1119-new-nforce-ide-drivers-windows-7-a.html?highlight=nforce+drivers
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:56.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App