Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Athlon XP / Geforce 4 / VIA266 Chipset

24 Apr 2010   #1

OSX 10.6.3 SL
Athlon XP / Geforce 4 / VIA266 Chipset


Took me a while to source everything for this machine, I now have Windows 7 Ultimate running on the following hardware:

AMD Athlon XP 2000+ (1.6Ghz Single Core)
Asrock K7VM2 (VIA266 Chipset) - Built in ethernet + audio
Nvidia GeForce 4 MX 64Mb GPU
VIA Audio
1Gb DDR266 Memory

Just for compatibility, Microsoft claims the hardware was incompatible, I did have problems.

Initially tried using a Radeon 7000 Series GPU, this resulted in BSOD on shutdowns and incompatibility with catalyst control centre.

Tried with an nVidia card from the same era, worked fine with the following drivers
Forceware 71.90 here.
Run in compatiblitiy mode Windows XP SP3 and admin privelages.

Also had trouble with the audio driver however Asrocks was fine (went direct to VIA first)
Audio driver for VIA 266 Audio here.

Ethernet on this chipset worked fine automatically with windows 7 32-bit.

This is just an info post for anyone who may be trying to use anything like this setup and also that it works fine in BASIC mode (without Aero) on this hardware.+


Jamie x

My System SpecsSystem Spec
24 Apr 2010   #2

Windows 10 Education 64 bit

I'm running 7x86 Ultimate on the following hardware:

Motherboard - PCChips M848A (v5.0) SiS Socket A ATX Motherboard
Processor - 2.2GHZ AMD Athlon XP 3200+ 400MHZ FSB 512K Barton Core
Ram - A-Data 1024 Meg x2 for 2048 Megs of 400MHZ DDR 3200
Hard Drive - 80 Gig Westerndigital
Video - GEFORCE FX5500 256 Meg, AGP 8x
Monitor - 17 inch Samsung Syncmaster 750s
Sound Card - Creative Sound Blaster Live 5.1
Speakers - Logitech R-20 2.1, 2 plus sub
Optical Drive - A-Open 16x DVD
NIC - SiS 900-Based onboard Fast Ethernet Adapter
Wireless - D-Link DWA-552 Extreme "N" Wireless PCI Adapter
USB - Integrated SiS 7001 6 USB 2 ports
Keyboard - Generic PS2
Mouse - Logitech Optical USB

The onboard sound wouldn't work at all, the upgrade adviser told me it wouldn't. The SB 5.1 only worked after hunting up a modified driver set. The onboard NIC didn't work initially but the original Vista drivers fixed that once I pointed Windows to the correct folder. I used the 96.85 GeForce Vista drivers for the FX5500. Aero works, it scored a 2.2 and I think you need minimum of 2.0 for it to be enabled. I had to do some searching for drivers but it was worth it.
My System SpecsSystem Spec

 Athlon XP / Geforce 4 / VIA266 Chipset

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
AMD Drivers On An Intel Chipset (South Bridge & Chipset Drivers ?)
Hi, I think my chipset is Intel Pentium 4 CPU 2.93GHz and my motherboard is Gigabyte GA-8TRC410M-NF but when using Driver Genius to scan for driver updates it reports back AMD South Bridge Driver (PCI bus) & AMD Chipset Drivers (ATII/O Communications Processor SMBus Controller) need...
AMD Athlon II X4 640
I've been having troubles with my comp lately, and since sending it in for repairs twice haven't helped I figured it must be something with my drivers, but I can't find one for my processor (AMD Athlon II X4 640 quad core, 3.0ghz AM3, 2MB 95W). I've searched AMDs homepage and tried googling in...
AMD Athlon
Hey, take a look at my computer specs and tell me whats the max stable potential of this cpu ;D Thanks
PC Custom Builds and Overclocking
Amd athlon 64 x2
Quick question here: I've got an AMD ATHLON 64 X 2 designed for a type 939 socket, is it possible to use this processor in an AM3 socket? If not anyone want to buy one? Sent from my DROIDX using Tapatalk
Hardware & Devices
amd athlon II x4 630 help :(
hey all, I recently purchased an Amd Athlon 630 X4. When I installed it, I tried to boot into windows but it just wouldn't work. It would get up to starting windows and would just do nothing. things I have done: Updated BIOS Reinstalled OS with my dual core in then installed my quad core Ive...
Hardware & Devices
Why do I have chipset drivers when I don't use an nvidia chipset? I have GTX 460 with 258.96 drivers. I do not have an nVidia chipset. When I went to check the Driver Sweeper files, I found all these chipset files. Why do I have them?
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:10.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App