Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: ATI Mobility driver for Dell D600 Latittude

29 Apr 2009   #1

Windows 7
 
 
ATI Mobility driver for Dell D600 Latittude

Hi all,

I have a Dell D600 Lattitude laptop that was running Vista Home Prem.
I usually do clean installs but I thought I would give the upgrade option from Vista to 7 a try. Anyways, the upgrade went really smooth. I realize that ATI doesnt support the 9000 series anymore. I was wondering since windows had a driver for the 9000 series for Vista, would it be possible to use that one? The only prob I am having is I cant seem to find the driver anywhere. (googled it etc...) Windows update catalog only lists XP/2000 drivers :-(
I dont think I could install the 9000 series driver in XP mode because of WDDM. Havent tried it yet lol! Any ideas on how i can find a Vista compatible driver for this?

Laptop Specs:

Intel 1.6 GHZ
ATI Mobility 9000
2 GB RAM
Realtek onboard sound
Intel onboard wireless ( really surprised this works in 7!)
120 GB HDD

thanks for the help... :-)

My System SpecsSystem Spec
.

30 Apr 2009   #2

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by brusse01 View Post
Hi all,

I have a Dell D600 Lattitude laptop that was running Vista Home Prem.
I usually do clean installs but I thought I would give the upgrade option from Vista to 7 a try. Anyways, the upgrade went really smooth. I realize that ATI doesnt support the 9000 series anymore. I was wondering since windows had a driver for the 9000 series for Vista, would it be possible to use that one? The only prob I am having is I cant seem to find the driver anywhere. (googled it etc...) Windows update catalog only lists XP/2000 drivers :-(
I dont think I could install the 9000 series driver in XP mode because of WDDM. Havent tried it yet lol! Any ideas on how i can find a Vista compatible driver for this?

Laptop Specs:

Intel 1.6 GHZ
ATI Mobility 9000
2 GB RAM
Realtek onboard sound
Intel onboard wireless ( really surprised this works in 7!)
120 GB HDD

thanks for the help... :-)
Hi brusse ,

Have a look here for the Vista driver Graphics Drivers & Software
I cant say if it will work, try it!!

Pooch
My System SpecsSystem Spec
02 May 2009   #3

Windows 7
 
 

been there done that lol.... but thx for the help. I am ok using the standard vga on this laptop. I have another system that I use for graphics.
My System SpecsSystem Spec
.


03 May 2009   #4

Windows 7 x 64 build 7100 , Ubuntu x64 ,
 
 

Hi ,
use the mobility Modder .. look here: .. choose vista 32 bit driver and it should work for you.. or you can also look at omega drivers here: for the 9000 use >> v3.8.252
My System SpecsSystem Spec
17 Feb 2011   #5

Windows 7 Ultimate x64
 
 

I solved the problem.
Download the driver for Windows XP at Dell Drivers and Downloads

Rightclick the file R82040.exe and set the compatibilitymode to Windows XP (servicepack 3). Execute the file. After installing and rebooting it should work nicely.
My System SpecsSystem Spec
19 Apr 2012   #6

Windows 7 Ultimate
 
 

Quote   Quote: Originally Posted by rony474 View Post
Hi ,
use the mobility Modder .. look here: .. choose vista 32 bit driver and it should work for you.. or you can also look at omega drivers here: for the 9000 use >> v3.8.252
Hi Rony,

I know this is an old thread, but after an XP crash on my D600, I first went to Ubuntu, was thoroughly disappointed with it's video playback performance, and last night just installed Windows 7 and would like to

It's running near perfectly and performing better than when XP was on it. Only issue is this one, the video driver. I used the laptop plugged into the TV, via the S-Video, connected via ethernet and generally running XBMC. Without the ati drivers, I get no S-Video and XBMC doesn't even start up.

I first installed Dell's own drivers in compatibility mode (XP SP3) and they seemed to work fine, but I didn't have the Catalyst Control Center (and didn't check the S-Video, now that I think of it) and if I try to run XBMC, I get a bluescreen on an ati3d*.sys file.

I then removed that one and went to install the Omega driver, again in compatibility mode, because there were no Windows 7/Vista ones available, when at one stage it asked if my bus type was AGP or PCIe, because it's a laptop and has neither, I decided not to continue and when I checked ModTool's list, the difference between what's available for 7/Vista and XP starts when the ATI MOBILITY FireGL 7800 and 9000 are left out from the Windows 7 list, so again, I didn't continue.

Whaddaya think? Dell's own, in compatibility, Omega in compatibility, Modtool, even though they state it's not supported, or is there now another option?

Thanks for any and all help with this.
My System SpecsSystem Spec
Reply

 ATI Mobility driver for Dell D600 Latittude





Thread Tools



Similar help and support threads for2: ATI Mobility driver for Dell D600 Latittude
Thread Forum
Solved Dell Latitude D600 Display Flickering (random horizontal lines) Hardware & Devices
no sound on dell latitude d600 Sound & Audio
Ati mobility 9000 driver Drivers
anyone have working audio driver for a dell d600 Sound & Audio
driver needed for dell latitude d600 Drivers
Dell Latitude D600 Windows 7 Drivers needed Drivers
Wierd Power Prob w/Dell D600 laptop Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:09 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33