Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: SB X-Fi Xtremegamer no driver working for me


30 Apr 2010   #1

windows 7 32 bit
 
 
SB X-Fi Xtremegamer no driver working for me

Upgraded to Windows 7, First I had a Audigy sound card, couldn't get drivers to work(which had trouble with on XP, but I could manually install them from device manager). I was reading alot of people that seemed to have success with X-Fi series drivers, so I bought a X-Fi Xtremegamer(I'm not sure if it is a "Fatal1ty"... on the box, it says Fatal1ty approved hardware, or something like that). Anyway, I have tried EVERYTHING, and every driver I can find, have tried creative's Windows 7 drivers for it, uninstalled, installed manually, tried the support packs(also tried installing them manually, from device manager) Have tried running drivers in compatibility mode(although, if I'm running in comp mode,a driver for XP, do I need to to choose "XP" serv pack 2/3, or do I choose "Vista", or "Windows 7" if available?)
Also, my graphics card is an ATI Visiontek x1300, and I did have a Catalyst Control installed. I had read a thread where they were talking about the Catalyst Control causing problems with sound...So I uninstalled it, tried reinstalling drivers same as before, but no luck. I am somewhat knowledgable on computers, but there is certainly alot that I don't know. I have been to the point of giving up several times, and have a separate HD with XP on it, but I reaaallly want to get sound on Windows 7. I have a dell optiplex(which I need to upgrade, but it's not too bad for now) and my particular model(170l), they have not released any drivers for the onboard sound(SoundMax integrated sound). I create electronic music, so I need a better card anyways. Any ideas will be GREATLY appreciated!!! I will not give up, it just seems that nothing will work. Also when I try to open the "audio control" or other apps installed by the software, it usually says that it can't detect any hardware, and the hardware detection patch did not work, apparently. Thanks in advance for any advice! --Chadow--
update: In my bios(which is old) the only sound option is to turn it on, or off(doesn't give option for "onboard" or otherwise. I've always left it on, and was able to install the sound blaster audigy card. Could this be a problem also??

My System SpecsSystem Spec
.

30 Apr 2010   #2

Windows 7 Home Premium 64bit
 
 

Audio on or off option in bios is for the onboard audio.
It should be set to off if using a dedicated sound card.


You should be able to install (from the Vista CD that came with card) the Volume Control Panel and THX Consol ONLY.
Just make sure to browse to the location on the disc and set all the Setup exes to run in compatability mode (Vista SP2)
Should be the main set up file, and in the Audio Folder the setup .exe for both of these apps.

After you install those, grab the Driver and Console Launcher from the official Site.

Install the console 1st, driver last.

This should work, and have all the options for the card working.

At least mine did.
My System SpecsSystem Spec
30 Apr 2010   #3
Microsoft MVP

Win 7 Ultimate x64
 
 

Chadowshadow, welcome to the forums.

First I would disable the onboard audio just to get it out of the way. Next is something you already know, your computer is old. Biggest problem is the chipset, the Intel 865, which has been declared end of life by Intel so I'm not sure what there is in the way of even native chipset drivers built into Windows. You can try running the Intel INF Update Utility,

INF Update Utility - Primarily for Intel® 5, 4, 3, 900 Series Chipsets

Hopefully that will tell Windows what to do with itself in regards to the chipset and allow you to install the X-Fi driver.
My System SpecsSystem Spec
.


30 Apr 2010   #4

windows 7 32 bit
 
 
Thank you, I will try

Thanks for the info (both of you), I will have to do these things when I get home from work in the morning. Very much appreciated!
My System SpecsSystem Spec
Reply

 SB X-Fi Xtremegamer no driver working for me




Thread Tools



Similar help and support threads for2: SB X-Fi Xtremegamer no driver working for me
Thread Forum
Microphone not working on X-Fi XtremeGamer Sound & Audio
Creative X-Fi Xtremegamer Sound & Audio
NEED HELP creative Xtremegamer soundcard Sound & Audio
Proublem with X-Fi XtremeGamer on W7 Sound & Audio
All the tries went bad with my SB X-FI XtremeGamer Sound & Audio
X-fi Xtremegamer sound issue Sound & Audio
X-Fi XtremeGamer and Win 7 x64 Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:02 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33