Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No drivers for ATI x800?

30 Apr 2009   #1
the lah

Windows 7
 
 
No drivers for ATI x800?

Ive previously installed windows 7 when it was first released to the public. But it didn't work with my card. SO i continued to use windows vista. Now i was wondering if this latest version of windows 7 would support x800 series.

I already posted my complaint about the old build HERE , now i just want to check if there are any updates.


My System SpecsSystem Spec
.

30 Apr 2009   #2
pooch

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by the lah View Post
Ive previously installed windows 7 when it was first released to the public. But it didn't work with my card. SO i continued to use windows vista. Now i was wondering if this latest version of windows 7 would support x800 series.
Hi the lah,

Did you try installing your Vista driver??
My System SpecsSystem Spec
03 May 2009   #3
the lah

Windows 7
 
 

What im asking is when i go to Graphics Drivers & Software

Windows 7 does not support x800 still. Does this mean it wont work with this card?
Ive tried the betas of 7 (first beta) but not the newest RC build. Before downloading this build i was wondering if it would work with my card, because before it did not .
My System SpecsSystem Spec
.


03 May 2009   #4
pooch

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by the lah View Post
What im asking is when i go to Graphics Drivers & Software

Windows 7 does not support x800 still. Does this mean it wont work with this card?
Ive tried the betas of 7 (first beta) but not the newest RC build. Before downloading this build i was wondering if it would work with my card, because before it did not .
All this means is that there is no 7 driver for your card, Did you try to install the Vista driver that works with your card In Windows 7?
My System SpecsSystem Spec
03 May 2009   #5
12eason

Windows 7077
 
 

Catalyst 9.1 for vista will work for the x800 on W7. (going to put this in my sig)
My System SpecsSystem Spec
09 May 2009   #6
Kiada

Windows 7
 
 

Can I just confirm (as I messed about trying to get my card to work all yesterday - and ended up reverting back to XP haha.)

If I grab the vista 9.1 catalyst driver, it will work in Windows 7 RC1 with my X800XT? or is the x800 that much different to the X800XT it wont work?

Also, will I have dual monitors / be able to extend onto my TV?

Any info appreciated
My System SpecsSystem Spec
09 May 2009   #7
12eason

Windows 7077
 
 

It should do, though I can't promise anything. It seems to be the only reliable driver for 'old' ati cards, and looking at the inf the x800 is listed.
Code:
"RADEON X800 PRO/GTO" = ati2mtag_R420, PCI\VEN_1002&DEV_4A49
"RADEON X800 PRO/GTO Secondary" = ati2mtag_R420, PCI\VEN_1002&DEV_4A69
"RADEON X800 Series" = ati2mtag_R420, PCI\VEN_1002&DEV_4A4B
"RADEON X800 Series " = ati2mtag_R420, PCI\VEN_1002&DEV_4A50
"RADEON X800 Series  " = ati2mtag_R423, PCI\VEN_1002&DEV_5549
"RADEON X800 Series   " = ati2mtag_R420, PCI\VEN_1002&DEV_4A4A
"RADEON X800 Series    " = ati2mtag_R430, PCI\VEN_1002&DEV_554F
"RADEON X800 Series     " = ati2mtag_R430, PCI\VEN_1002&DEV_554D
"RADEON X800 Series      " = ati2mtag_R430, PCI\VEN_1002&DEV_554E
"RADEON X800 Series - Secondary" = ati2mtag_R430, PCI\VEN_1002&DEV_556D
"RADEON X800 Series -Secondary" = ati2mtag_R430, PCI\VEN_1002&DEV_556F
"RADEON X800 Series Secondary" = ati2mtag_R420, PCI\VEN_1002&DEV_4A6B
"RADEON X800 Series Secondary " = ati2mtag_R420, PCI\VEN_1002&DEV_4A70
"RADEON X800 Series Secondary  " = ati2mtag_R423, PCI\VEN_1002&DEV_5569
"RADEON X800 Series Secondary   " = ati2mtag_R420, PCI\VEN_1002&DEV_4A6A
"RADEON X800 Series Secondary    " = ati2mtag_R430, PCI\VEN_1002&DEV_556E
"RADEON X800 XT" = ati2mtag_R423, PCI\VEN_1002&DEV_5D57
"RADEON X800 XT Platinum Edition" = ati2mtag_R423, PCI\VEN_1002&DEV_554A
"RADEON X800 XT Platinum Edition Secondary" = ati2mtag_R423, PCI\VEN_1002&DEV_556A
"RADEON X800 XT Secondary" = ati2mtag_R423, PCI\VEN_1002&DEV_5D77
"RADEON X800/X850 Series" = ati2mtag_R480, PCI\VEN_1002&DEV_5D4F
"RADEON X800/X850 Series - Secondary" = ati2mtag_R480, PCI\VEN_1002&DEV_5D6F
"RADEON X800GT " = ati2mtag_R423, PCI\VEN_1002&DEV_554B
"RADEON X800GT Secondary " = ati2mtag_R423, PCI\VEN_1002&DEV_556B
Some people have had success upgrading from 9.1 to 9.2, but it didn't work for my x1950pro.
My System SpecsSystem Spec
09 May 2009   #8
Kiada

Windows 7
 
 

Thanks, i'll give it a go!
My System SpecsSystem Spec
10 May 2009   #9
the lah

Windows 7
 
 

OK so i just downloaded windows 7 RC , and right now i dont have aero and only a limited resolution + my card is not getting detected.

So i am gonna download the Catalyst 9.1... Hope this works.
My System SpecsSystem Spec
10 May 2009   #10
the lah

Windows 7
 
 

ok Ive just installed the 9.1 drivers , and when i restart the computer to apply changes the computer just shuts down =/ so i do a system recovery , and im back at the same place i started. Do you think i need to update other drivers other then my graphics?
My System SpecsSystem Spec
Reply

 No drivers for ATI x800?




Thread Tools





Similar help and support threads
Thread Forum
General Question - Windows Installed Drivers Vs OEM Website Drivers
Greetings, This is a general question for a fresh install of Windows on a computer. Let's say we just completed the installation and we open up Device Manager (we haven't used Windows Update yet). Device Manager shows us that there are - let's say "3" - devices that do not have drivers installed...
Drivers
Base System Device drivers error - unable to find drivers
Hi there, I have an HP Pavilion DV7 2185dx laptop running a freshly installed windows 7 upgrade from windows Vista. Ever since the upgrade my CPU is constantly running at 98-100% all the time meaning I cannot do anything on my PC. After researching a bit online it could possibly be the driver...
Drivers
Ati x800 pro - too old?
Hello I have an Ati x800 pro and windows 7 build 7100. Now I have some dots all over my videos, i can't play videogames and the same dots are over my mouse's cursor. here>> http://img137.imageshack.us/img137/3885/errorudp.png I have installed the driver from windowsupdate. Aero is off. ...
Graphic Cards
Possible problem with x800 pro
Hello! Windows 7 works fine on my computer but in the last few days, they started to appear some coloured points around the the menu buttons. It's better if I show you: Imageshack - capturarb.png They are in the close buttons of the windows too! It is possible that it is some kind of...
Graphic Cards
NVIDIA drivers - Vista drivers or 7 drivers?
Which version should I use for the NVIDIA drivers, the Vista version or the 7 version?
Drivers
Windows 7- Ati x800 has no 1920by1080 and areo
On vista my areo works fine and my resolution (1920 by 1080) gets detected. But on windows 7 areo wont work and the resolution wont reach to 1920 by 1080. Even in the display settings. I updated the drivers and it detects the card. Is there any drivers for the X800 Ati Radeon?
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:19.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App