Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: New WIN 7 Install PCI Bus 3 Drivers no installed

13 May 2010   #1

Windows 7 - Vista
 
 
New WIN 7 Install PCI Bus 3 Drivers no installed

Hello I have just done a clean install of Windows 7 on a separate partition and all seems to be working okay except for the following: the device manager list under Other Devices three item called "Base System Device" Each one has the following information when I click on it. Device Type: Other device, Manufacturer: Unknown, and for each one:
Location PCI bus 3 device 1, function 2
Location PCI bus 3 device 1, function 3
Location PCI bus 3 device 1, function 4

I have upgraded from Vista. Can someone please tell me how do I go about finding the required device drivers and installing them.

Thanks freddo


My System SpecsSystem Spec
.

15 May 2010   #2

Windows 7 - Vista
 
 

Solved my own problem. Was able to have windows search through all the Vista drivers I had backed up and find the needed driver for each device.
My System SpecsSystem Spec
Reply

 New WIN 7 Install PCI Bus 3 Drivers no installed




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:34 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33