Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Realtek ALC888 - Driver that actually works and no dramas

31 May 2010   #1
Armpits

Windows 7: Ultimate (64 Bit)
 
 
Realtek ALC888 - Driver that actually works and no dramas

Alot of problems with this on-board soundcard. Different problems for different people.

Some have had recording problems, popping noises, etc....


Just wondering is there a final fix to all of this for W7 (64Bit), been waiting for months!


My System SpecsSystem Spec
.
31 May 2010   #2
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

I have no problems at all with mine, but I had to go to the Realtek site to get it. Foxconn's driver was mucho ancient...
My System SpecsSystem Spec
31 May 2010   #3
Aphelion

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by Armpits View Post
Alot of problems with this on-board soundcard. Different problems for different people.

Some have had recording problems, popping noises, etc....


Just wondering is there a final fix to all of this for W7 (64Bit), been waiting for months!

Latest driver seems to be very good, the past four or five updates have worked well on my system. It's not only the audio driver that's causing the audio problems you describe.

A resource sucking network adapter driver can glitch both audio and video.

Ap
My System SpecsSystem Spec
.

31 May 2010   #4
Armpits

Windows 7: Ultimate (64 Bit)
 
 

Gigabyte EX58-UD3R - That's my motherboard with the onboard ALC888, so what you think is causing problems? I have popping issues when I'm mastering sound. Also I can record from the soundcard (MSN voice clips)
My System SpecsSystem Spec
Reply

 Realtek ALC888 - Driver that actually works and no dramas




Thread Tools




Similar help and support threads
Thread Forum
Line In - Problem on Realtek HD ALC888
I formatted my computer and I'm still getting this problem. I don't know what is the cause of this and how to fix it. Here's what's wrong with my line in recording. The volume is always maxed out on it even when I turn it down just a tad. And when I record audio it records but I get this sub...
Sound & Audio
Realtek HD Audio (ALC888)
Seems to be big problems with Realtek for everyone. - I've set everything up right but when I try record voice clips from the soundcard, it doesn't detect any sound. - My music mastering software (T-Racks 3) doesn't detect the full duplex, it only detects Generic ASIO, but in Cubase 5 (Music...
Sound & Audio
Gigabyte EX58-UD3R (Realtek ALC888) - What is wrong with Realtek?
Hi, I've been trying to figure out my problem for months and months now. I even contacted Realtek but have no luck getting a reply back. The sound and all works perfect. It's just when I try to record sound from the sound card from my computer for MSN voice clips. It doesn't detect any sound?...
Sound & Audio
Almost inaudible sound from ALC888 RealTek HD (Win 7 x6
Hello there WinSeven! So, the story is this. I recently put together a computer running Windows 7 x64 and the problem I'm having is that my on-board RealTek AC97 HD Audio device (ALC888 model) is not outputting any sound via my headphones and very quiet sound on my Speakers. The...
Sound & Audio
Realtek alc888 amd problem
I went from xp to windows 7. I have a custom built machine. alivesata2-glan board with realtek alc888 on board. I installed build 7600 on it and I cannot get the audio to work. I have the red x in the bottom right. It says no audio output device installed. The DM gives me a code 10. I have tried...
Sound & Audio
Realtek ALC888
Hello everybody. I am from Lithuania, so my English language isn't very good ;D So, i tried Windows 7 and they are great, but I have problem with sounds. My sound card is Realtek ALC888. I downloaded latest driver, codecs and all my 5.1 speakers are working, but rear speakers are working bad....
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:51.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App