Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB device not recognized, in Windows 7 Only

14 Jul 2009   #11

Windows 7

Apologies for hijacking this thread.

(Correction, the USB dongle referred to above was not made by Trendnet, rather was an Encore Wireless-N USB adapter.)

I ordered a Rosewill PCI wireless adapter and installed it into this Gigabyte MB based computer. That solved the mass storage issue, BUT, the Rosewill PCI device didn't work properly. It connected to the wireless access point with a good signal, but the throughput to the computer was awful. When I tested at it was worse than dialup.

So, the common denominator seemed to be the motherboard. The Gigabyte board went back to Newegg and I purchased an Intel DG41RQ MB and installed it last night with Windows 7 64-bit. The Rosewell internal card reader was recognized automatically and worked properly. At separate times, I tried both the Rosewill PCI wireless card and the Encore USB adapter, and they both worked.

All is good.

But, who would have known? Very frustrating. I'm thinking...during the installation with the Gigabyte board.....Wrong drivers? Incompatible OS? WHAT AM I DOING WRONG? All the error messages that aren't really telling me anything useful! No indications at all that it was the motherboard.

Exactly what was wrong with the Gigabyte board? Don't know, but there was *something.*

Computers aren't easy.

My System SpecsSystem Spec
12 Aug 2009   #12

Windows 7 RC

I have come to the same conclusion. I have a USB Keyboard and a USB mouse which are plugged into a KVM which pluggs into the computer via usb. When I disconnect the USB devices connect PS2 mouse and key board and reboot I can add any "mass storage device" and it works fine. The minute I connect the USB mouse and keyboard the problem comes right back. Just a RC version issue and problem fixed in full version? I hope so cause I would hate to have to replace my hardware because of an OS issue. JK
My System SpecsSystem Spec
13 Aug 2009   #13

Windows 7 RC 64-bit

Worked for me too. I couldn't backup using the HP SimpleSave external USB drive (Western Digital). It kept erroring out. I unplugged my printer's USB cord and ta-da! worked perfectly. Thank you for the advice!!
My System SpecsSystem Spec

10 Sep 2009   #14

Windows 7 RC
Similar Problem

I get this notification everytime I resume using the computer after it hibernates/enters standby mode from inactivity. The culprit is my USB mouse. However, the mouse installed perfectly fine and functions fine while the computer is in use, and resumes working after leaving hibernation/standby mode. It only stops being recognized during hibernation/standby mode. I am tired of receiving this notification. How do I disable it?

EDIT: This notification disappears before I can click on it since the device resumes functioning.
My System SpecsSystem Spec
18 Nov 2009   #15

Windows 7
similar usb problems

hello, please excuse me if i have posted this improperly, i too am having a similar usb problem with my windows 7 laptop when i plug in my thumb/flash drive. when i insert my thumbdrive i get the standard "windows is installing the drivers for this usb device" message but after wards i get a message that says "Device driver was not successfully installed" i clicked it for more details and found a message that says" please consult with your device manufacturer for assistance getting this device installed. sandisk cruzer micro usb device failed" at first i thought it was my USB drive but i checked other USB drives and computers running windows xp, vista, and 7 the problem only happens on computers running windows 7. please help me i'm running a dell xps 1640 with windows 7 64 bit if you need more information to help please let me know what it is. thank you
My System SpecsSystem Spec
19 Nov 2009   #16

Windows 7

it seems that i have stumbled upon a "temporary" fix. when i left my sandisk usb drive in during a restart the computer seemed to recognize the thumb drive and now i have full access to it in my computer as well as in devices and printers. altho windows still pops up that blaloon that says device driver not successfully installed but this seemed to work for me. i hope the windows 7 team will find a permanent fix if this helps any one please let me know
My System SpecsSystem Spec
27 Dec 2009   #17

Windows 7 Ultimate x64

I have had the same problem (USB harddisk not willing to run 2.0) on and off. I usualy solve this by deactivating my Logitech settings in the systemtray. Right after that 2.0 works again.
My System SpecsSystem Spec
24 Aug 2010   #18

windows 7 64 bit

my usb mass storage hard drive don't work in windows 7 .its plugged in the light is on a pop up says the device is ready to use,but it isnt showing up in my computer.i go to admin tools,computer management,storage,disk shows up as disk 5 unknown Not initialised,when i try to initialize it a window pops up saying the device is not ready.anyone know how to fix not answer this question with another question (i see a lot of that on here lmao)there is all the info you need.thanks
My System SpecsSystem Spec
25 Aug 2010   #19

WIN7 Ultimate 64bit

This can work for laptops and desktops
Just switch off & pull the mains lead (take out laptop battery) for a few minutes.

The residual memory in the usb chips then gets erased/reset and will relook for connected usb devices on starting system.

Worth a try.

- internal wires/connector of external h/d loose > check/push together.

Try different usb ports
check usb lead is ok
My System SpecsSystem Spec
26 Aug 2010   #20

Win 7 Home Premium 32 bit,

@ f3rr3ll...

Hi, Have you re-formatted that external HDD yet?

You have to give it a letter & then go through the format procedure.
It's probably showing up as "not allocated."

I just went through it with my external HDD which I had formatted with another M/C before the Win 7 install.

HTH.Regs, M..
My System SpecsSystem Spec

 USB device not recognized, in Windows 7 Only

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
USB device not recognized in Windows 7?
I have the strangest problem I've yet to encounter with my computer. As you may have guessed from the title, I am constantly getting the message displayed. Any fix that has been suggested has been unhelpful or worked for a bit until my computer restarted again (I'll get to that) First off it...
Hardware & Devices
Intuos 4 + Windows 7 = USB device not recognized
Please tell me if this is not the right sub-forum. I've been encountering error Code 43. I've tried a lot and I am running out of options. I'm working on an Acer Aspire 5542G. My operating system is Windows 7. The USB device not being recognized is my Wacom Intuos 4 PTK. - I've...
USB device not recognized - but there is no usb device connected
It's recognized in device manager as "Unknown device". But I've not connected anything to pc. Also all of my usb ports are working at 1.1 speed. When I try to connect any device, I get the message "that it could work faster, if i connect it to hi-speed usb port". Any suggestions?
Hardware & Devices
device not recognized
Hi, would or could someone help me, all of a sudden a usb device has stopped working, it is not recognized now im sure that i have searched every where for an answer i have tried lots of things, it says windows has stopped this device it has reported problems, the device is a sony walkman mp3...
Hardware & Devices
Windows 7 ultimate 32bit, sound device not recognized
sound device is not recognized(no sound, video and game controllers in device manager) plus my internet(wireless built in PCI card) does not work im thinking the drivers somehow were deleted when i attempted to charge my ps3 controller via PC(how it all started, went on to do a clean install of...
Sound & Audio
USB device not recognized!!! PLZ HELP
i have a hp pavillion dv8301nr windows 7 (64bit) 7600 rtm, allthou this happens in every version, i have a amd turion 64 ml-34 processor, and phenix f.54 (latest) bios, and i can only suspect i have the latest chipset drivers, i installed them from hp site, if someone knows a place where i can get...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:44.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App