Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: wireless network adapter not working after updating driver please help

28 Jun 2010   #1
badabing

windows 7 ultimate edition
 
 
wireless network adapter not working after updating driver please help

hello everyone. i have this lenovo 3000 Y410. i had vista installed on it but decided to get windows 7 ultimate. i had to do a lot of driver upgrades and most of them worked fine. the wireless networking card, which is intel wireless wifi link 4965AG was disconnecting at times so me and my buddy decided to upgrade it too from version 12.4.1.4 to the latest version 13.1.1.1. and after that, it stopped working. the light thats supposed to glow after i switch on the wirless key remains lit off. and i cant connect to my wireless connection. and i cant roll back to previous version either because the roll back driver option is greyed out. somebody please help.


My System SpecsSystem Spec
28 Jun 2010   #2
badabing

windows 7 ultimate edition
 
 

oh i forgot to add one huge detail. when i install the latest driver version, the install doesnot complete properly. during the process it says "now performing intel(R)wireless network driver installation operations please wait" and then it suddenly disappears. it doesnt say it installed completely or correctly or anything
My System SpecsSystem Spec
28 Jun 2010   #3
NoN

Windows 7 Professional SP1 - x64 [Non-UEFI Boot]
 
 

Quote   Quote: Originally Posted by badabing View Post
hello everyone. i have this lenovo 3000 Y410. i had vista installed on it but decided to get windows 7 ultimate. i had to do a lot of driver upgrades and most of them worked fine. the wireless networking card, which is intel wireless wifi link 4965AG was disconnecting at times so me and my buddy decided to upgrade it too from version 12.4.1.4 to the latest version 13.1.1.1. and after that, it stopped working. the light thats supposed to glow after i switch on the wirless key remains lit off. and i cant connect to my wireless connection. and i cant roll back to previous version either because the roll back driver option is greyed out. somebody please help.
Just download from Lenovo the old version 12.4.1.4 driver then reinstall. Or roll back from the "Device Manager" your card to previous drivers version.

Control Panel=>Device Manager=>Scroll to Lan Card, see the listed one (wifi link 4965AG) , right click properties then "Pilote" to the tab "Previous version".
My System SpecsSystem Spec
28 Jun 2010   #4
NoN

Windows 7 Professional SP1 - x64 [Non-UEFI Boot]
 
 

Quote   Quote: Originally Posted by badabing View Post
oh i forgot to add one huge detail. when i install the latest driver version, the install doesnot complete properly. during the process it says "now performing intel(R)wireless network driver installation operations please wait" and then it suddenly disappears. it doesnt say it installed completely or correctly or anything
You can uninstall the Intel software from your "Programs" in the" Control Panel", reboot, this will load again the generic driver.

Reinstall the Lenovo driver.
My System SpecsSystem Spec
28 Jun 2010   #5
badabing

windows 7 ultimate edition
 
 

hi. do you mean uninstalling the latest driver version from the control panel> uninstall a program? i cannot find my driver listed there. i even tried uninstalling the driver from device manager but after installing the previos version i.e. 12.1.4, it still shows 13.1.1. and still the same result
My System SpecsSystem Spec
29 Jun 2010   #6
NoN

Windows 7 Professional SP1 - x64 [Non-UEFI Boot]
 
 

Quote   Quote: Originally Posted by badabing View Post
hi. do you mean uninstalling the latest driver version from the control panel> uninstall a program? i cannot find my driver listed there. i even tried uninstalling the driver from device manager but after installing the previos version i.e. 12.1.4, it still shows 13.1.1. and still the same result
If you don't find it in "uninstall a program" it is because the version of the driver 1.3.1.1.1 was the lite one install. Thought was the full install...

Go directly in "C:\System32\drivers", and delete the drivers NETw5s64.sys and NETw5v64.sys.

It's also stored in "C:\System32\DriverStore\FileRepository", the folder just underneath the "drivers" one. That's maybe why it still shows the 1.3.1.1.1 version (see attached thumbnails)

Try to Delete the folders Netw5s64... & Netw5v64...
If it doesn't delete, let them as is...doesn't matter, the right driver might be there aswell.

Reboot your computer (don't allow the install of the driver on boot, click cancel) and reinstall the proper Lenovo driver 12.4.1.4.....

If it is still does not install properly, you might have to go in Safe Mode at reboot pressing F8 Key, then you 'll have to add security settings for Administrator rights to those folders, to be able to delete them, to get rid of the wrong drivers in "C:\System32\DriverStore\FileRepository"


Attached Thumbnails
-capture.png  
My System SpecsSystem Spec
19 Sep 2010   #7
shuhyaku

Windows 7 Ultimate 32bit
 
 

Hi,

My Lenovo Y410 experienced the same problems regarding wireless connection as well after installing win7 ultimate.

Even when I turned on the Network button, the Wireless connection on display remained "disable". Can anyone help me regarding the matter?

Cheers
My System SpecsSystem Spec
Reply

 wireless network adapter not working after updating driver please help




Thread Tools





Similar help and support threads
Thread Forum
Wireless Network Adapter Says it's Working Properly But It's Not
Last night my wireless adapter (Atheros AR5007EG Wireless Network Adapter) stopped working. In the properties it says it is working properly, however, it will not find a single wireless network to connect to, only the big red X over the icon in the system tray. My wife's laptop which is 5 feet from...
Network & Sharing
Wireless network adapter not working
I've followed some on the steps provided on here, but I still can not connect to the internet via wireless option error message appears as "there might be a problem with the driver for the wireless network connection adapter" I've downloaded the latest version from the Dell support site and it...
Network & Sharing
Wireless Network Adapter not working properly
Yesterday I bought a new desktop and I decided I wanted wireless, so I bought a TP-Link TLWN851ND wireless PCI adapter. After installing all the drivers I had internet access for an hour or so but then the download speed gradually went to 0 and I lost internet access, this morning I turned on the...
Network & Sharing
Problems with wireless network adapter and network connection driver
Hi, So recently I have removed a nasty zeroaccess rootkit virus(es) from my laptop. My Windows Firewall, Defender and Updates would not work (still won't), my browser kept redirecting to unrelated websites, and I was just overall having a TON of irritating issues. I installed MalwareBytes and...
Network & Sharing
Wireless network adapter suddenly not working
I have had my HP Pavilion dm4 for a year and a half now, and when my school gave me a copy of Windows 7 Enterprise (it came with Win7 Home) I installed it and all the necessary drivers, and everything's been running smoothly - til now. Tonight all of a sudden my Internet connection showed that...
Network & Sharing
Wireless Adapter driver not working .
I use Toshiba Satellite L645-S4056. I lost my recovery partition so i installed windows 7 from another DVD. Previously my laptop had home premium but i installed ultimate with a DVD. After installing computer doesnot detect any Network adapter. It doesnot even show wireless adpater in device...
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:45.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App