Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Onboard LAN drivers

12 Jul 2010   #1
eldinv

DOS^
 
 
Onboard LAN drivers

Is there a universal Microsoft driver for on board Ethernet??

I have a Gigabyte GA-M57SLI-S4 (rev. 2.0)

Onboard Lan
Lan Chipset Marvell 88E1116
Max Lan Speed 10/100/1000Mbps

I don't want to buy a new Ethernet card but looks like I can never find a solution. Whenever doing gaming on downloading,anything intense the connection fails or disconnects intermittently. I called ISP and they came out and everything was fine. They couldn't reproduce any problems. I remember in Vista I didn't have a problem as long as I didn't install the chipset drivers. This time I had to when installing Win OS 7 because I had no internet.

I couldn't find a driver on Gigabyte page, so I downloaded NVIDIA.
nForce Driver



Version:

15.53 WHQL

Release Date:

2010.03.15

Operating System:

Windows 7

Language:

English (U.S.)

File Size:

59.4 MB





Release Highlights
Supported products
Additional information

Windows 7 32-bit Driver Versions:
  • Ethernet Driver (v73.20) WHQL
  • Network Management Tools (v73.16)
  • SATAIDE Driver (v11.1.0.33) WHQL
  • SATARAID Driver (v11.1.0.33) WHQL
  • RAIDTOOL Application (v11.1.0.30)
  • SMBUS Driver (v4.74) WHQL
  • SMU Driver (v1.71) WHQL
  • Installer (v7.57)

Please go to main driver page to find latest NVIDIA nForce drivers for your MCP.

nForce 7 series:
790i SLI, 790i Ultra SLI, 780i SLI

nForce 6 series:
680i SLI, 680i LT SLI, 680a SLI

nForce 5 series:
550, 590 SLI AMD, 570 SLI AMD, 570 Ultra AMD










I'm pretty sure the problem is related to the Ethernet Driver. I remember something about Comcast sends to many packets and the Ethernet controller gets confused and freezes for a second or fails.

When this happens, I usually have to disconnect power from the modem, wait a few seconds and then turns back on. Sometimes if I just disable the card and then enable problem is solved.


My System SpecsSystem Spec
.
12 Jul 2010   #2
pebbly

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Hi eldinv, download these drivers GA-M57SLI-S4 (rev. 2.0) - GIGABYTE - Support&Download - Motherboard - Driver and install the in compat mode Compatibility Mode you should have more luck with these
My System SpecsSystem Spec
12 Jul 2010   #3
eldinv

DOS^
 
 

do u have this board? are u aware of problem i speak of, lol. dont mind installing this, as i knew it existed but this is in reference to a problem that occured both in vista and now in windows 7
My System SpecsSystem Spec
.

12 Jul 2010   #4
DeaconFrost

Windows 7 Ultimate x64 SP1
 
 

You said in your original post, that you have a Marvell LAN, so aren't going to find the answer by installing Nvidia drivers. Go to Marvell's site and download the latest driver for your card. You can enter the part number on the right-hand side of the page.

Marvell: Support
My System SpecsSystem Spec
12 Jul 2010   #5
eldinv

DOS^
 
 

Quote   Quote: Originally Posted by DeaconFrost View Post
You said in your original post, that you have a Marvell LAN, so aren't going to find the answer by installing Nvidia drivers. Go to Marvell's site and download the latest driver for your card. You can enter the part number on the right-hand side of the page.

Marvell: Support

its an nvidia board with onboard graphic, under my boards website it said:
Onboard Lan
Lan Chipset Marvell 88E1116
Max Lan Speed 10/100/1000Mbps

im trying the compatible mode.


plus on there site my model number is not listed
My System SpecsSystem Spec
12 Jul 2010   #6
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

My System SpecsSystem Spec
Reply

 Onboard LAN drivers




Thread Tools





Similar help and support threads
Thread Forum
Onboard driver help please
Hi there. I have installed Windows 7 but currently cant get the right drivers for the onboard sound. The mobo is a Foxconn 915PL7AE-S Its a clean install 32 bit gold (retail) version I have tried the latest R230 realtek drivers but all i get is no audio output device is installed and a...
Sound & Audio
Unable to update onboard LAN controller drivers?
I am unable to update my Realtek Ethernet drivers to 5/03/12 for some reason. It only goes up to 4/11/12. When I try to force update it to 5/03/12 the ethernet driver does not work. Is there any way I can fix this?
Drivers
Onboard audio not working and audio drivers won't install
Hello everyone, I'm having a problem using my motherboard’s onboard HD audio instead of my video card’s audio, so without further ado here is the situation; I have an Asus maximus iii gene motherboard which has a SupremeFX X-Fi built-in sound card (this is a very nice card provided you can...
Sound & Audio
via onboard sound
hi i have installed my motherboard drivers and my sound driver does not pick the front mic and audio out up the microsoft driver that are given with windows seven have worked fine thanks saakeman;)
Drivers
Drivers for ASUS A7V600-x Soundmax onboard sound
Just posting up the driver I used for my onboard sound card. It's a 'soundmax' but I used the Realtek ALC650 driver: http://dlsvr01.asus.com/pub/ASUS/misc/audio/alc650/alc650_wdma341.zip It works fine outputting PCM via the s/pdif port but I've had no success outputting DTS or Dolby Digital....
Hardware & Devices
Drivers for ADI® AD1988B onboard soundcard?
Got a P5K-E Wifi/Ap motherboard, which according to the specifications got an ADI® AD1988B onboard soundcard. Just wondering where i could get drivers for this soundcard? When i enabled it through the BIOS, Windows 7 automatically installed some drivers, and in the volume control panel it's called...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 10:01.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App