Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: W7 and ThinkPad T400 ATI Radeon 3400 series driver

12 May 2009   #1

XP/7
 
 
W7 and ThinkPad T400 ATI Radeon 3400 series driver

Hi,

I have a T400 which has the following two display adapters:

ATI Mobility Radeon HD 3400 Series
Mobile Intel(R) 45 Express Chipset Family

After installing Windows 7 and checking device manager, the ATI adapter does show up under the "Display adapters' section, but it has a ! sign on it, and if I click for details, it says:

This device cannot start. (Code 10)

I tried downoading and installing this:

Lenovo Support & downloads - ThinkPad Switchable Graphics Driver for Windows Vista 32bit and 64bit - ThinkPad T400, R400, T500, W500

and when I rebooted, it went through some diagnostic tests in a cmd window to finish installation. But when I checked the device manager again, the ATI adapter still says it cannot start.

I also tried this:

ATI Catalystâ„¢ Mobility Display Driver

which I got to by selecting Windows 7 32-bit > Mobility Radeon > Mobility Radeon HD 3000 series.

It seemed to install OK, but I got a message which I've gotten with previous attempts, which says:

"The Catalyst Control Center is not supported by the driver version of your enambled graphics adapter. Please update your ATI graphics driver, or enable your ATI adapter using the Displays manager."

I went to the device manager, right-clicked on the ATI adapter and did Update Driver, and it did at first find a better match but said it couldn't be installed with the same error message from above (Code 10). Now, when I try to update the driver again, it says the best driver software is already installed.

Any ideas to fix this? Thanks.


My System SpecsSystem Spec
.

13 May 2009   #2

Windows 7
 
 

I am also running a Thinkpad T400 with an ATI Radeon HD 3400 Series with Windows 7 32 bit. I cannot uninstall the current driver (8.56.1.13) nor can I update using the ATI driver package.

Any help would be greatly appreciated!
My System SpecsSystem Spec
14 May 2009   #3

windows 7
 
 
Exact same issue with t400 and ATI Radeon 3400 series

My Lenovo has the exact same issue as futurejp with the driver not loading properly. Only difference is mine is 64 bit.
My System SpecsSystem Spec
.


14 May 2009   #4

Windows 7 RC Ultimate x64
 
 

I have a t400 also running RC x64. In the device manager it says "The device cannot start (code 10)"

Also I can't seem to enable my secondary monitor hooked up to my docking station via HDMI. The secondary monitor is enabled so my desktop stretches but its not displaying anything on the attached LCD. I can't figure out how to disable the extended configuration so now it is set to a seondary monitor I can't see!

Are there others having similar problems?
My System SpecsSystem Spec
14 May 2009   #5

Windows 7 RC Ultimate x64
 
 

So I connected my monitor via VGA and it seems to be working. Now just to get the DVI working...
My System SpecsSystem Spec
15 May 2009   #6

Windows 7 Ultimate x64
 
 

The ATI Windows 7 driver is now back in Windows Update. I just installed RC1 on a machine with an X1400 and Windows Update said it was only too happy to provide a nice driver for that.

Bye.
My System SpecsSystem Spec
22 May 2009   #7

Windows 7
 
 
Did it Install?

What is the exact link? I have done all the updating and cannot get the ATI catalyst/switchable graphics to install and work. Thanks
My System SpecsSystem Spec
22 May 2009   #8

XP/7
 
 

Now I have a different problem: every time I close my laptop's lid in 7, and reopen it, my display properties have changed and it thinks I'm using an extended display. So when I go to use a scrollbar or something, my cursor flies off the right end of the screen into imaginary-secondary-display-land. So every time I open my lid I have to Windows+P to fix it.

It's obviously not a huge deal, but really annoying. Any ideas?
My System SpecsSystem Spec
22 Jun 2009   #9

Windows 7
 
 

Did you guys get it working by now? I havent- I got the Radeon 3400 in my T400, and I tried all different kind of drivers from ATI - especially those that are supposed to work with WIndows 7. I always have the yellow mark in the device manager and the error code 10 "device could not be started".

Any help would be appriciated. My current driver version is 8.56.1.13
My System SpecsSystem Spec
23 Jun 2009   #10

Windows 7
 
 

Ok, now I got 8.62 installed. Windows 7 RC Build 7100 starts, shows Logon screen. I enter the password, i see the Desktop, after about 1 sec. the system freezes.....
My System SpecsSystem Spec
Reply

 W7 and ThinkPad T400 ATI Radeon 3400 series driver




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 12:03 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33