Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Clock gadget look weird after resetting IE10 on WIN7


23 Jun 2013   #1

Windows 7 SP1 Ultimate x64 bit
 
 
Clock gadget look weird after resetting IE10 on WIN7

Clock gadget look weird after resetting IE10 on Windows 7



OK here another one of my weird stories


I downloaded update ‏KB2836502 alongside ‏KB2834140 and ‏KB2808679 and it made Windows 7 startup to crash so I done system restore to fix the issue, then day after I rest IE10 (not related to the updates but to the fact that IE10 in rare times crash for me when I open more then around 80 tabs so I thought that a good rest may fix the issue which unfortunately didn't..) and start to get issue with the clock gadget which end up look like in the photo I uploaded (it still works though)

I tried to trun off and on all gadget and it didn't help

I tried to fix this issue with uninstalls and reinstalls the Windows gadgets via optionalfeatures, didn't help

I tried to use regedit and deleted the zones folder:
[HKEY_CURRENT_USER]\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\


and then it seem like it fix the issue for me.

almost week after that I only download ‏KB2836502 because I use alot of jpeg formats daily and it import update for me, and then I got the same issue with the clock again.

I tried the three methods again and nothing help.

I even tried to deleted the settings.ini. file of the gadgets and tried to run sfc /verifyonly which didn't find any issue on my system


it seem that deleting Zone folder again do fix the issue but when I use some app that shows RSS links (Nero 10 in my case) or something of that sort the clock change back to it's corruption look, then the werid part is when I open the same app again it moves back to it's normal look o_o


I heard that there's a way to registration the DLLs of Windows 7 gadgets but don't know how to do so... does anyone can help me solve this issue?

thanks



Attached Images
 
My System SpecsSystem Spec
.

28 Jun 2013   #2

Windows 7 SP1 Ultimate x64 bit
 
 

I found this tutorial

Gadgets not Displaying Correctly in Windows 7 - Fix


and I want to ask if it safe to use it?

since I saw some commits from people who tried to mess with the reg and dll files and end up ruined ALL of the gadgets instead of fixing the one who was corrupted.


also this tutorial been made before IE10 was out and show only command lines of regsvr32 DLLs of 32 bit OS

mine is 64 bit and Windows 7 have both 32 and 64 version of the gadgets in it... so is it going to work ? :0

it won't mess up the OS, IE10, or the gadgets even more ?
My System SpecsSystem Spec
28 Jun 2013   #3
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Hello egozi,

There's no guarantee that it'll work in all situations, but it's completely safe to try and use. It only resets your security zone settings back to default, and re-registers the .dll files for gadgets. It works for both 32-bit and 64-bit.
My System SpecsSystem Spec
.


28 Jun 2013   #4

Windows 7 SP1 Ultimate x64 bit
 
 

Thanks for replying Brink


I tried the bat file but it didn't help me ;(

all gadgets works including the clock (like before the bat) but each time I open Nero 10 the clock change to it's corruption look, and if I close nero 10 and open it again the clock will move back to how it was...

it all start for me after i manually rest IE10 settings so I bet it have something to do with IE10, Moreover I've notice that deleting or resting zones to default NOT set "Security" and "Security level for this zone"to default in IE10 but instead set them to nothing and I need to manually press on the "rest to default" button in the Internet Options


I think that the bat or older methods to fix the gadgets are outdated and won't work for people who have IE10 on their Windows 7 since IE10 is different then how 9 works and moreover it install that platfrom directx update which may have something to do with it... wish I could test IE9 and IE10 on resting and see what IE10 done differently then 9 in order to fix the issue...


I just hope that the bat didn't ruin anything on my OS... like making other gadgets to stop works or other things that relate to the OS ....
My System SpecsSystem Spec
28 Jun 2013   #5
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

The issue you are having with your gadgets appears to be different that what the .bat is intended for, so it's not going to help, but it will not hurt anything either.

Does this happen when you open anything other than Nero 10? If not, then I would focus on Nero 10 as a possible cause, and see if there may be an update available for Nero 10 that may address this.
My System SpecsSystem Spec
28 Jun 2013   #6

Windows 7 Pro. 64/SP-1
 
 

In the first post it states 80 tabs open in I.E. 10. Could this be part of the problem. Just asking.
My System SpecsSystem Spec
28 Jun 2013   #7
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Good point LB.

@egozi,
Even with 16 GB of RAM, having that many tabs open is going to cause lag and other possible performance issues. Does your gadget do this when your system is not under such high demand?
My System SpecsSystem Spec
28 Jun 2013   #8

Windows 7 SP1 Ultimate x64 bit
 
 

Umm yea, the clock do this even when my system is not under such high demand

also I tend to open ton of tabs for years, even on ie7, ie8, and ie9, and my ram or cpu never reach to the limits so far (well back then when I had ie7 and 8 I till had only 4 ram but if I got issue only the browsers were the ones who would started to get slower till i close the tabs) , and IE10 take even less resources and I check the ram and cpu when i open high number of tabs, they usually not reach to high demands (not passing the 30% -+ usually), of course it depend on the sites I tab But i usually only tab ton of jpeg pictures and not sites, So far only IE10 gave me issue with randomly freezing after I open too much tabs, I check the ram and cpu and don't see it even close to the limit and I was able to open even more tabs with IE9 and still able with Firefox, and also that freeze happen randomly but only when i open too much pics with jpeg format.

I saw on google that some other people have similer issues with IE10 so I bet it either the browser or some addon that don't get so well yet with IE10


But let go back to the gadget issue xD, that issue start happen to me after I rest IE10 settings and happen randomly when I was browsing or open random apps, then after the first time i deleted "Zones" reg the issue seem to stop occur unless I open nero 10, I assume that it can happen on other apps which I may didn't tried yet but so far it only happen with nero, It happened before completely randomlly so I don't think it nero who is the culprit here but rather something that IE10 done when I rest it.

I can't use restore point since I done ton of stuff since then and don't want to lose them.
My System SpecsSystem Spec
28 Jun 2013   #9
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

If you like, you could uncheck Windows Gadget Platform in Windows Features to turn it off, click OK, restart PC if prompted, check Windows Gadget Platform in Windows Features to turn it back on, etc.... to see if it may toggle it to display properly again.

Windows Features - Turn On or Off
My System SpecsSystem Spec
29 Jun 2013   #10

Windows 7 SP1 Ultimate x64 bit
 
 

Umm

I actually tried it twice

I even note it here

Quote:

I tried to fix this issue with uninstalls and reinstalls the Windows gadgets via optionalfeatures, didn't help

though... it may be worth a try after the bat?

I found this site which shows almost all the possible ways to fix the gadgets
and I've notice that the admin added new fix that MS release which was really not long ago (13-05-2013)

But I really don't trust MS and their fixs and don't know what that fix does so I kind of scare to try it

if you want you can take a look in it here:

Fix: Windows 7 Gadgets are not working

If you may know what it change and fix I will be really glad if you could share it with me :0



P.S completely off the topic my pc start-up seem to crash today again :/

it may be relate to all of the new Windows 7 patchs that were released in this month... or it may be something with my pc, I notice that in the only two rare times I got this start-up crash I had dvd inside the drive and it was ofc some time after I updated my os with the new Windows 7 patchs/updates.


My drive may be dying or it may be the OS which become unstable... CMD scan didn't find anything though.

what i did notice was that after the second start-up crash my PC kept trying load the DVD and acted slow till I restart and took the DVD off....

my mobo is a bit problemtic with Satas so I update the bios to the 06.06.2013 version just in case....

I never EVER had a start-up crash on Windows 7 till now that was caused from OS or hardware instability (I did had it ofc here and there when it was relate to sudden power off issues but never when it come to the OS)

So I never even tried the start-up repair that windows suggest me to do after each start-up crash, Is it even safe to do it or mess with system files like system repair does?

Sorry that I ask too much " Is it safe" questions xD but to be honest it only because I completely don't trust Microsoft anymore... their patchs gave me hell in the past and their fixs usually ruin my OS even more, no matter if it was fresh installed OS without any apps that may interfere, no matter the machine I had/have, Though most patchs and updates Did work fine after a fresh install... but they made me format my machines quite alot for it...

I stopped use automatics update long ago... but MS seem to release their new patch and updates with issues on the first days and fix them way after~
My System SpecsSystem Spec
Reply

 Clock gadget look weird after resetting IE10 on WIN7




Thread Tools



Similar help and support threads for2: Clock gadget look weird after resetting IE10 on WIN7
Thread Forum
System Clock randomly resetting to different date/time General Discussion
My computer clock keeps resetting back to an earlier date General Discussion
CPU Clock Gadget preventing Win7 from turning off by itself Gadgets
Solved clock keeps resetting General Discussion
The Clock Gadget Gadgets
Clock gadget? Gadgets
Which clock gadget is best for these...? Gadgets

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:07 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33