Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Gadgets broken


12 Nov 2013   #1

Windows 7 Home Premium 64bit
 
 
Gadgets broken

I installed the update for Internet Explorer 11 this morning and gave it a quick look, then went on with my day. Got back on my computer later and noticed my CPU Meter gadget on the desktop had a new look. I exited the CPU Meter and opened it again with the same results.

The Weather, Headline Feeds and Currency gadgets are broken also.

A System Restore to a time before the IE11 install failed.

The only gadget I use is the CPU Meter so it's not a big deal, but I like for things to work properly. Is it possible that IE11 broke my gadgets?



Attached Thumbnails
Gadgets broken-capture.png  
My System SpecsSystem Spec
.

12 Nov 2013   #2

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 8.1 Pro
 
 

My System SpecsSystem Spec
12 Nov 2013   #3

Windows 7 Home Premium 64bit
 
 

Thanks for the quick reply Jerry!

Looks like MS is serious about doing away with gadgets!

Good to know the problem is not just mine!
My System SpecsSystem Spec
.


12 Nov 2013   #4

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 8.1 Pro
 
 

Check you DPI setting some are saying the update changes the setting to high see if that it, you need 100% DPI Display Size Settings - Change

Jerry
My System SpecsSystem Spec
12 Nov 2013   #5

Windows 7 Home Premium 64bit
 
 

Wow! Setting the DPI to 100% fixed the gadgets.

I normally have the DPI at 125% because of my tired old eyes.
My System SpecsSystem Spec
12 Nov 2013   #6

Win 7 Pro
 
 

The same IE11 update killed my Gadgets too and setting text to 100% makes them re-appear -- as well as the 6 other clocks I added when I was trying to fix it. Thanks for the workaround !!


With fonts set to 100% the onscreen type's pretty small. So I'm stuck with choosing between legible onscreen text and having the Clock and Weather gadget. While the gadget issue is minor, I wonder what else the IE11 update might be causing problems with.

Anyone know of a registry hack that will enlarge the UI type while not affecting the Gadgets?

Let's hope it's a problem that extends beyond Gadget display and Microsoft will issue an update to correct whatever's misbehaving.

Russell
My System SpecsSystem Spec
12 Nov 2013   #7

Win 7 Pro
 
 

Found the Reg key:

HKEY_CURRENT_USER\Control Panel\Desktop, Name=LogPixels and tried setting it to 120 (=125%) and the symptom returned.

I've settled on using a custom setting of 110% which still has the desktop Gadgets appearing but causes a small purple smear to appear on the tip of the clock's minute hand. I can live with that for now and the type size is better than the teeny tiny type displayed at the 100% setting.

Is this really the best place on this forum to post this bug?

Russell
My System SpecsSystem Spec
13 Nov 2013   #8

Windows 7 Ultimate x64 & Windows 8.1 Pro Dual Boot
 
 

The problem is indeed caused by the DPI settings of the PC. Gadgets appear incorrectly if the DPI value is set above 100%, although one may use a custom value of 110% and gadgets seem to appear almost correctly. The reason for the problem is that the default gadgets in Windows 7 have a DPI-locking tag. So there are two ways to resolve this issue:
1. Set the DPI value to 100-110% as mentioned above.
2. The second one requires some basic XML editing skills. One has to delete the locking tag from the XML file completely as setting the value to auto will not resolve it. I am not sure, but this however, might be against Microsoft's policy. In case someone wants to try this one, please, at least make a backup copy of the original file.
My System SpecsSystem Spec
14 Nov 2013   #9

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 8.1 Pro
 
 

Here are a couple members have found a solution have a look

http://www.sevenforums.com/browsers-...ml#post2594918

Jerry
My System SpecsSystem Spec
Reply

 Gadgets broken




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:20 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33