Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Gadgets will not load


28 Nov 2009   #1

Windows 7 Ultimate
 
 
Gadgets will not load

Hey all,

I've been using windows 7 since the RC, but something strange happened when I booted up my Ultimate laptop this morning. The gadgets wouldn't run!

I tried the standard troubleshoot:
-> system restore
-> restart the gadgets program
-> install a new gadget
-> check the policy/registry

and yet still, I can 't seem to make it work. Anyone have any ideas? Are there programs that block gadgets?

So what happens when I try to load gadgets is there are no gadgets on my desktop and the loader screen is blank. Trying to reload installed gadgets from the control panel yields an error message that states that there are no gadgets to reload


My System SpecsSystem Spec
.

28 Nov 2009   #2

 

Have you turned off any background services which gadgets might depend upon?
My System SpecsSystem Spec
28 Nov 2009   #3

windows 7 RTM
 
 

Windows Gadgets will not run with User Account Control set to Never Notify.

Try this:

"Maybe you noticed that once you turn off UAC you can’t use the gadgets anymore, as a security measure. But if you want to risk using them, there a simple way to do it, even with UAC turned off. Press the Windows Key, type ‘regedit’, go to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Sidebar\Settings and create a DWORD value named AllowElevatedProcess and set its value to 1. Now you should be able to use your gadgets. If not, then reboot your PC and you should be done."

This is not mine, But I do not have the original Link. In any event it worked for me.
My System SpecsSystem Spec
.


28 Nov 2009   #4

 

Quote   Quote: Originally Posted by rerice View Post
Windows Gadgets will not run with User Account Control set to Never Notify.
I'm not so sure. I've got UAC switched off on my present profile, and there are six desktop gadgets showing up right now - all working properly...
My System SpecsSystem Spec
29 Nov 2009   #5

Windows 7 Ultimate
 
 

I have had UAC off, and I thought that was a problem only with Windows 7RC? I definitely have not noticed that on Home Premium or my Professional computer. I know that the elevated gadgets was the only way to make them work without UAC, but I believe that it is no longer the case. I tried it anyways.... still nothing

I reactivated all the services I had off (fax, some random windows media player support services), but no difference.

It is so bizarre. I went back to one of the oldest system restores on my computer before I managed to bring them back. It makes me think that maybe one of the programs I installed for work was interfering with it. Would XML/MSXML versions interfere with gadgets?
My System SpecsSystem Spec
29 Nov 2009   #6

windows 7 RTM
 
 

Hello Odis,

The Gadgets would not load at all until I used this reg entry. I wonder why
it worked in one case and not the other.

In any event this was the cure
for me!
My System SpecsSystem Spec
Reply

 Gadgets will not load




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:43 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33