Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't Add Gadgets to Sidebar

01 May 2009   #1

Vista Ult SP2/Win 7 Ult SP1/Win 8.1 Pro w/MC (all x64)
 
 
Can't Add Gadgets to Sidebar

I've setup the sidebar so it works like the Vista one and the default gadgets work fine, but if I try to add any external ones, such as BBC News etc. some "unspecified error" occurs and everything just hangs until I end task. I can, however, add ones that are listed in the get more gadgets window. I can only assume something has changed from 7000 to 7100 as I did the permissions things the same as I usually do. Unless of course I messed up somewhere, but I can't for the life of me spot where I've gone wrong.

Is it possible to restore the sidebar folder to its original state and start over again?


My System SpecsSystem Spec
.

01 May 2009   #2

Vista Ult SP2/Win 7 Ult SP1/Win 8.1 Pro w/MC (all x64)
 
 

OK, let me re-word this...if I turn off Windows Gadgets in Programs, Turn Windows features On & Off, reboot and then turn them back on again, does that restore a pristine Sidebar or not?

I really don't want to format and reinstall all over this stupid issue.

Anyone...??

Addendum: That didn't work. Now trying sfc /scannow.
My System SpecsSystem Spec
01 May 2009   #3

 

Sorry, not sure what is causing that - let us know how the SFC went.

I am assuming you upgraded to 7100 from 7077?
My System SpecsSystem Spec
.


01 May 2009   #4

Vista Ult SP2/Win 7 Ult SP1/Win 8.1 Pro w/MC (all x64)
 
 

Well it didn't upgrade in the end. Due to my own fumbling I installed a fresh copy of 7100 and ended up with 7000 ensconced in windows.old.

Everything works fine except adding certain gadgets to the sidebar.

The system file check only caused Windows Mail to disappear again, it's back now. It didn't repair the gadget issue.
My System SpecsSystem Spec
01 May 2009   #5

 

Could it be that those gadgets are not set to work with the RC build for some reason?

Also, what is your UAC status?
My System SpecsSystem Spec
01 May 2009   #6

Vista Ult SP2/Win 7 Ult SP1/Win 8.1 Pro w/MC (all x64)
 
 

Quote   Quote: Originally Posted by johngalt View Post
Could it be that those gadgets are not set to work with the RC build for some reason?

Also, what is your UAC status?
Could well be that they are no longer compatible. It would make sense as some do work and others don't.

I have UAC set to default.
My System SpecsSystem Spec
02 May 2009   #7

Vista Ult SP2/Win 7 Ult SP1/Win 8.1 Pro w/MC (all x64)
 
 

I was wondering if any of you could try installing the BBC Radio Gadget (and/or BBC News or CBC Radio) and see if they work, with or without the sidebar activated.

It could be that 7100 has something that causes them to break.

It's not possible to use Compatibility Mode with a downloaded gadget so that option is out. I can't find anything on the web from anyone else, so perhaps I'm unique here? (In which case I've obviously screwed up...!).
My System SpecsSystem Spec
03 May 2009   #8

Vista Ult SP2/Win 7 Ult SP1/Win 8.1 Pro w/MC (all x64)
 
 

I just discovered the strangest thing. This operation seems to have broken my Vista Sidebar completely as I can't even get it to open. Weird considering all I did in the above was follow the tutorial and copy files from Vista. (Maybe I "Cut" in error...?).

Back to the drawing board....LOL.

Addendum: Fixed using Vista Forums Sidebar Wont Start Tute.
My System SpecsSystem Spec
14 May 2009   #9

Win 7 rc build 7100
 
 

Thanks all for pointing me in the right direction here we go.
1. Make sure your logged in as an admin.
2. open up task manger and close down sidebar if its running. (just kill the process)
3. open up c:/program files/windows sidebar
4. right click the sidebar application go to security, check the status of the settings, my load had sys, admin and users with read as the only permission. If this is the case keep on with the next step.
5. Go to the advance tab and go to owner and take ownership of the file with your admin account. then ok out of the boxes, so this setting can take effect.
6. right click/properties/security tab.
7. now select system and hit edit, change it to full control, I also put admin with full control and gave users modify.
8. now click ok to run out of it.
9. double click sidebar. Be prepared, I had 34 different gadgets jump onto my desktop after I did this.
This fixed my inability to maintain gadgets on the desktop after rebooting, it also allows me to edit the gadget settings, and I no longer have a ghost icon from the My gadgets window if I drag and drop a gadget to the desktop. I also let trustedinstaller account have full control, I didn't see any reason to mess with it. UAC is disabled by the way. and I haven't installed any "fixes" from vista. If this help anyone out, let me know.


RM1(SS)
Ya know windows 7 is like the last Highlander Movie, one was awesome (XP), Two was what the hell were they thinking (vista), and three (win 7) was back to the original story line or an apology for messing things up with two (vista).
My System SpecsSystem Spec
14 May 2009   #10

Vista Ult SP2/Win 7 Ult SP1/Win 8.1 Pro w/MC (all x64)
 
 

Hmm, interesting, but still wont let me add certain gadgets. Others are OK.
My System SpecsSystem Spec
Reply

 Can't Add Gadgets to Sidebar




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:05 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33