Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Weather Gadget

19 Jul 2010   #1

MS Windows 7 Home Premium 32-bit
 
 
Weather Gadget

Hi guys

I have a R530 Samsung Notebook with Windows 7 Home Premium and for the last 3 days I've noticed that the Weather Gadget stopped working.
I bought this notebbok last month and until now everything worked fine.
Can anyone help me with this?

Thanks

My System SpecsSystem Spec
.

19 Jul 2010   #2

64-bit Windows 8.1 Pro
 
 

Have you tried a different gadget??
My System SpecsSystem Spec
19 Jul 2010   #3

MS Windows 7 Home Premium 32-bit
 
 

Hi,

The basic gadgets that came with Windows 7 are all running excpet the weather.
I tried another weather application and worked and that's why I think that this situation is a little bit stange.
My System SpecsSystem Spec
.


19 Jul 2010   #4

Windows® 7 Home Basic 64bit, Build 7600
 
 

Quote   Quote: Originally Posted by zk1974 View Post
Hi guys

I have a R530 Samsung Notebook with Windows 7 Home Premium and for the last 3 days I've noticed that the Weather Gadget stopped working.
I bought this notebbok last month and until now everything worked fine.
Can anyone help me with this?

Thanks
Hello and Welcome to SevenForums.

You can update and download those gadget from thier sources. It's Free.
My System SpecsSystem Spec
19 Jul 2010   #5

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

Each gadget can use a different provider for the data. But, have you tried changing locations in the weater gadget to see if a different location's temperature works OK? Try a location in a different city, not somewhere close to your location.

You could also try the System Restore and restore the PC back to a restore date when it did work OK.
My System SpecsSystem Spec
19 Jul 2010   #6

MS Windows 7 Home Premium 32-bit
 
 

Quote   Quote: Originally Posted by elsuirad View Post
Quote   Quote: Originally Posted by zk1974 View Post
Hi guys

I have a R530 Samsung Notebook with Windows 7 Home Premium and for the last 3 days I've noticed that the Weather Gadget stopped working.
I bought this notebbok last month and until now everything worked fine.
Can anyone help me with this?

Thanks
Hello and Welcome to SevenForums.

You can update and download those gadget from thier sources. It's Free.
Hello,

I tried to uninstall the Weather Gadget, cleaned the Cache folder and install the gadget again...nothing happened
My System SpecsSystem Spec
19 Jul 2010   #7

MS Windows 7 Home Premium 32-bit
 
 

Quote   Quote: Originally Posted by fireberd View Post
Each gadget can use a different provider for the data. But, have you tried changing locations in the weater gadget to see if a different location's temperature works OK? Try a location in a different city, not somewhere close to your location.

You could also try the System Restore and restore the PC back to a restore date when it did work OK.
That I didn't do yet. Will try later at home to see if it works
My System SpecsSystem Spec
19 Jul 2010   #8

MS Windows 7 Home Premium 32-bit
 
 

Hi,

Tried a situation that I saw in a Portuguese Forum:

- Connected to Home Lan I still don't have updates with Weather Gadget
- Connected with Internet Sharing (HTC Blackstone) the Weather Gadget works perfectly

Resuming, if I use my mobile to acess Internet the Gadget works perfectly but if I use my Cable Internet Connection the Gadget stops the updates...stange no?
My System SpecsSystem Spec
12 Oct 2010   #9

Win 7
 
 

(I already posted this at another forum, so I hope you don't mind me posting here as well...)

If someone's looking to fix issues with the
Weather Gadget in Windows 7, I hope this helps you...

Sooo, I finally got it figured out - at least the thing that's helped me.


I was beginning to get worried, since everyone else seemed to fix their problem easily, e.g. pressing the x button by the location list didn't work for me at all. Even when I'd try to enter a location, I'd have to type two letters for the text to get recognized at all. Only then would I be able to select and delete the 'Search for location' text and type my own location - although not being able to click the Search button or anything.


I was really getting super frustrated by that time - as someone pointed out (on one of the dozens of forums I've checked), it's the small things that drive us wild, so I just couldn't let it go. I've tried several other gadgets, but they didn't work either.


I thought it had something to do with the Language and Location settings, but that wasn't it. It wasn't the Work Offline option on Internet Explorer either. It just didn't seem to work whatever I did...


Not to prolong my rant, here goes! Note that, naturally, I can't guarantee this will work for everyone, so
please read the whole thing (and eventual posts after this one) before proceeding!

Seems that my
mshtml.dll file was corrupt and needed to be dealt with. You have to be authorized to delete the file, but unfortunately I can't remember how to do that exactly. I guess you can google it or someone can maybe find a good explanation.

I remember searching mshtml.dll from the Start menu; right-clicking it and changing the Security options so that the User (whichever name you've got there) has got the Full Control option checked which will enable you to delete the corrupted mshtml.dll file.


I'm sorry, I don't really remember how exactly I did it - I just ran into a link from a forum that explained how to change the permissions. Hope you find it easily and you're able to delete the file without much trouble.


Now, from what I've read, it's not such of a big problem to get the mshtml.dll file back. What you have to do is to enter
sfc /scannow in the Run window, which will scan the whole system and restore the (deleted and) missing mshtml.dll file. I guess you should restart in between these steps (even if not prompted) - at least that's what I did.

The corrupted file was replaced by a working one and my Gadgets seem to be working just fine now.


Phew!
My System SpecsSystem Spec
Reply

 Weather Gadget





Thread Tools



Similar help and support threads for2: Weather Gadget
Thread Forum
weather gadget Software
Weather Gadget Gadgets
Weather gadget issue Gadgets
Weather Gadget Help [LOOK] Gadgets
Which weather gadget is this? Gadgets
Name this weather Gadget Gadgets
Weather gadget problem Gadgets

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:06 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33