Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Graphics issue with Age of Empires II: The Conquerors

16 Mar 2011   #51

Windows 7 Ultimate 64-bit

Quote   Quote: Originally Posted by somerlot View Post
Going to this thread Windows 7/Vista Color Fix and following the advice at the very bottom of the registry worked for me. Involves no programs, no closing explorer and restarting explorer. Adding this to your registry and you can play with no color issues and you can alt tab out of the game during play and back in again with no issues. At least no issues I for me so far.

Awesome, I'll try this. Thanks

My System SpecsSystem Spec
18 Mar 2011   #52

windows 7 premium x64

hey guys i read the first few posts not hole thing and realized that you guys are having some problems with the graphics and my youtube video should be able to help you btw this works for all older games for windows 2000 or lower or it should anyways (third person on top view down)
how to play old games on windows 7 with full hd graphics this removes grass and water looking like confetie and makes it look like you were running windows xp
My System SpecsSystem Spec
19 Jul 2012   #53

Windows 7 home premium 32 bit
Way to go Dragon 1 !

Had been looking for a solution to this problem and found Dragon1's (starcraft fix). This worked for me perfectly !!
My System SpecsSystem Spec

24 Jul 2012   #54

Windows 7 Pro 32bit
still have problem

hello there...

I still have problems here. Everytime i run the game on my win7 pro, it can't go fullscreen so i can see 2 black areas on either side and the colors are wrong, the grass and water are not completely green and blue. I've tried all the solutions above but none worked. I really like this game so if you have any other solutions, pleaseeee help me
My System SpecsSystem Spec
25 Jul 2012   #55

Windows 7 Home Premium 64bit


Just like triplez, I'm still having problems running AoE on my computer. I have tried the various solutions listed here, but that will either stop the game from running, not start the game at all, or simply continue the game with the red grass. I dearly love Age of Empires and I would love the chance to play it again, nothing else seems to compare.

I have the black bars on the sides, but I could live with that. I just want to know how to fix the grass and water. I have Windows 7 Home Premium 64 bit. I have also looked up various other solutions, but none have worked.


Never mind, I have gotten my game fixed.
My System SpecsSystem Spec
25 Aug 2012   #56

Windows 7 Ultimate x32
HERE is the answer

To fix the color issue
1.change your window theme to windows 7 basic
2.go to screen resolution(leave this window open,do not close) the game and the color will be fixed

To fix full screen issue:
1.change the resolution to 1024x768 the game and play
the opening page doesnt fit but the game does so start a game you'll understand

I tried so much and found these answers:-) enjoy the game
My System SpecsSystem Spec
14 Oct 2012   #57

WIndows 7 Ultimate 32 bit
Conquerors Fix Twist

First thanks for everyone efforts on this tremendous game... There is certainly a passion for this game... Ok, I have tried the solutions above and find that server work almost flawlessly. The .BAT file and the changing of the theme to classic fix the color issue perfectly. But, here is a strange one... When I run the Conqueror's edition, it says conquerors on the opening page, but when the game starts it looks like the basic Empires of Ages II game (no expansion). You can tell right away when clicking on the scout and seeing that there are no Attack Stances listed, just the basic icon to put then in a building. I still run under a different computer on XP just fine, but would love to make the switch... (Don't know how long computers will support XP). (Thanks!!!J) Issue Resolved... Works perfectly... Thanks...
My System SpecsSystem Spec
07 Dec 2012   #58

64 bit windows premium 7

Quote   Quote: Originally Posted by aceivaswe View Post
hello everybody!!!
I have ''windows 7'' and i'm playing ''age of empires 2 & the conquerors expansion''. I had the same graphic issue but i read some forums and i started to test it my own.

After a while i found a solution that is working fine for me!!

Go to your game folder and locate ''age2_x1''.
Right-click, properties and choose ''compatibility'' tab.
Then press on ''choose settings for all users'' button.
Mark the ''run this program in compatibility mode for:'' and choose
''windows 98 / windows me''
then under settings mark ''disable visual themes'', ''disable desktop composition'', ''disable display scaling on high dpi settings'' and ''run this program as an administrator'' and click ''ok'' and again ''ok'' and you are done.

Please test if this works and post.
doesnt work
My System SpecsSystem Spec
17 Feb 2013   #59

win 7
age 2 graphic fix

check out this new unofficial expansion for AoE II, there are some new features, AIs, units, etc. and the
graphic issue is solved by installing it... it works for me on Win7 64

Age of Empires II: Forgotten Empires
My System SpecsSystem Spec
18 Feb 2013   #60
Erick Aguilar

Windows 7 professional X64

Quote   Quote: Originally Posted by ddumbo View Post
check out this new unofficial expansion for AoE II, there are some new features, AIs, units, etc. and the
graphic issue is solved by installing it... it works for me on Win7 64

Age of Empires II: Forgotten Empires
It does, I've been using it for the past months.
The new AI is incredibly brutal though.

I hope they implement the old basic AI too, I am not an AoE hardcore player, and I like taking my time and not having to rush everything in fear of having the new AI destroy my village after 5 minutes of starting the game.
My System SpecsSystem Spec

 Graphics issue with Age of Empires II: The Conquerors

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Age of Empires 2 Conquerors - Problems with the usual Color Fix
OK, so I've been at this for 6 hours straight now (so please forgive me for any mistakes here, grammatical or otherwise) and I'm flat out of ideas, so I thought it might be a good idea to post my problem online and at least get some second opinions. So the story goes like this; I just recently...
Age of Empires II: The Conquerors Expansion graphics and crashing
Hello, I know that there are loads of threads about the graphics problems (the red grass and the purple oceans), and I do have that problem as well. Unfortunately, when I try and play a random map in compatability mode (I have tried multiple OS's) the game crashes when I fix the red grass +...
Age of Empires 2: The Conquerors freezing.
Hi, I'm using win 7 x64 ultimate. dx updated. most win updates installed (omitted malicious software tool & etc.) Versions: Age of Kings: 2.0b (failed with 2.0a too), The Conquerors: 1.0e (fails with 1.0c too) AoE: Forgotten Empires installed, runs ok. AoE: Age of Kings runs ok. Tried killing...
ago of empires 2 the conquerors expansion.
My windows 7 premium 64 bit comp will install age of empires but refuses to run the game . I've tried adjusting the resolution and coloure bit but still no good.does anyone have any solutions to this problem?
Age of Empires II The Conquerors-High Resolution+Music Fix on Win7 64
Hi all I just got a huge itch to play the Age of Empires series again. I played Age of Mythology last week and worked without a hitch on Windows 7. But when trying to install my all time favorite Age of Empires 2 yesterday, ran into a lot of problems - after hours of googling, I have managed to...
age of empires II conquerors
salut , am si eu o problema si de fapt nu doar eu cam toata lumea pe care o cunosc si joaca age of empires II conquerors , la win 7 nu merge bine in joc se vede foarte nasol culoarea , am vazut aici la voi ca spuneti ca nu are nici e problema, dar nu e asa , nu e compatibil jocu sau daca voi chiar...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:18.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App