Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Graphics issue with Age of Empires II: The Conquerors

14 May 2009   #1
Xenochria

Windows 7 Build 7100
 
 
Graphics issue with Age of Empires II: The Conquerors

I have been a long time Age of Empires II player, and have once suffered from the classic red grass and purple water graphics issue that a lot of people suffer from. However, using one of the below solutions, it eventually corrected itself. Recently, I installed Windows 7, build 7100 as my main operating system. AoEII (Conquerors exp. too) did not work on the original Windows 7 build, but now does, however, no matter what I do, scouring the internet for solutions and ways to solve the problem the graphics issue of the red grass and purple water stay. Here are the solutions I've read about and tried, all to no avail.


Changing the resolution
Alt tabbing
Opening a folder before the game loads
Unchecking "CPU 1" on the "Set Affinity" box in Task Manager
Updating graphics drivers to most recent
Updating DirectX to most recent
Running the game in compatibility mode for XP, Vista, 98, etc.

None of these solutions work at all, the green grass is still red, and the water is still purple.

Here are my system specs.

Windows 7 Ultimate 64-Bit Build 7100
AMD Athlon 64 6000+ ~3.0GHz
2GB RAM
NVIDIA GeForce 8800 GT
Direct X 11
Running at 1920x1080

Can anyone recommend any other solution to the graphics problem? Thanks.

Here's a picture of the issue (screenshotting doesn't show the graphics problem)

http://img4.imageshack.us/img4/6167/140520091107.jpg



My System SpecsSystem Spec
.

15 May 2009   #2
Cesarcsrf

Windows 7 Ultimate 7100
 
 

i have no ideia.. but tell me one thing can u still play that online ?
My System SpecsSystem Spec
15 May 2009   #3
Xenochria

Windows 7 Build 7100
 
 

Yep, flawlessly.
My System SpecsSystem Spec
.


16 May 2009   #4
AeonGamer

Win7 7100 / WinXP SP2
 
 

It's AoE:The Mars Expansion
Did you try finding a different Video Driver? or Dumbing down your graphics options outside the game?
Do keep in mind it was a game built for a different Technical Era of computers.
They didn't have things like HD Cards back then they didn't even have DDR Cards far as I recall.
So knock down the graphics a good bit find a video driver maybe a newer one and see if it fixes the Wacky Red Grass Purple Water Mars effect.
My System SpecsSystem Spec
27 Aug 2009   #5
kyzawarrior

Win7 RC build 7100
 
 

My System SpecsSystem Spec
06 Sep 2009   #6
aceivaswe

Windows 7
 
 
Solution to ''Age of Empires 2 Conquerors''!!!

Hello everybody!!!
I have ''Windows 7'' and i'm playing ''Age Of Empires 2 & The Conquerors Expansion''. I had the same graphic issue but i read some forums and i started to test it my own.

After a while i found a solution that is working fine for me!!

Go to your game folder and locate ''age2_x1''.
Right-click, Properties and choose ''Compatibility'' tab.
Then press on ''Choose settings for all users'' button.
Mark the ''Run this program in compatibility mode for:'' and choose
''Windows 98 / Windows me''
Then under settings mark ''Disable visual themes'', ''Disable desktop composition'', ''Disable display scaling on high DPI settings'' and ''Run this program as an administrator'' and click ''ok'' and again ''ok'' and you are done.

Please test if this works and post.
My System SpecsSystem Spec
06 Sep 2009   #7
AeonGamer

Win7 7100 / WinXP SP2
 
 

No no no and No for me
Matter of fact it made it look worse.
My System SpecsSystem Spec
22 Oct 2009   #8
dragon1

Windows 7
 
 

didn't work for me either...
however the fix suggested for starcraft worked for AOE2 but not starcraft:
StarCraft fix holy cow!

i've tried everything i possible could for AOE2 and starcraft but this only seems to work for AOE2 and not starcraft for me...
My System SpecsSystem Spec
22 Oct 2009   #9
logicearth

Windows 8.1 Pro (x64)
 
 

I downloaded a mod to run AOE2 in a window which solves the graphic problems.
My System SpecsSystem Spec
22 Oct 2009   #10
Code Hunter

Windows 7 Ultimate
 
 

Hello, have you tried to adjust your screen's resolution? And if so, what is the lowest resolution you tested? This will sometimes fix the issue.
My System SpecsSystem Spec
Reply

 Graphics issue with Age of Empires II: The Conquerors




Thread Tools





Similar help and support threads
Thread Forum
Age of Empires 2 Conquerors - Problems with the usual Color Fix
OK, so I've been at this for 6 hours straight now (so please forgive me for any mistakes here, grammatical or otherwise) and I'm flat out of ideas, so I thought it might be a good idea to post my problem online and at least get some second opinions. So the story goes like this; I just recently...
Gaming
Age of Empires II: The Conquerors Expansion graphics and crashing
Hello, I know that there are loads of threads about the graphics problems (the red grass and the purple oceans), and I do have that problem as well. Unfortunately, when I try and play a random map in compatability mode (I have tried multiple OS's) the game crashes when I fix the red grass +...
Gaming
Age of Empires 2: The Conquerors freezing.
Hi, I'm using win 7 x64 ultimate. dx updated. most win updates installed (omitted malicious software tool & etc.) Versions: Age of Kings: 2.0b (failed with 2.0a too), The Conquerors: 1.0e (fails with 1.0c too) AoE: Forgotten Empires installed, runs ok. AoE: Age of Kings runs ok. Tried killing...
Gaming
ago of empires 2 the conquerors expansion.
My windows 7 premium 64 bit comp will install age of empires but refuses to run the game . I've tried adjusting the resolution and coloure bit but still no good.does anyone have any solutions to this problem?
Gaming
Age of Empires II The Conquerors-High Resolution+Music Fix on Win7 64
Hi all I just got a huge itch to play the Age of Empires series again. I played Age of Mythology last week and worked without a hitch on Windows 7. But when trying to install my all time favorite Age of Empires 2 yesterday, ran into a lot of problems - after hours of googling, I have managed to...
Gaming
age of empires II conquerors
salut , am si eu o problema si de fapt nu doar eu cam toata lumea pe care o cunosc si joaca age of empires II conquerors , la win 7 nu merge bine in joc se vede foarte nasol culoarea , am vazut aici la voi ca spuneti ca nu are nici e problema, dar nu e asa , nu e compatibil jocu sau daca voi chiar...
Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:59.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App