Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Graphics issue with Age of Empires II: The Conquerors


14 May 2009   #1

Windows 7 Build 7100
 
 
Graphics issue with Age of Empires II: The Conquerors

I have been a long time Age of Empires II player, and have once suffered from the classic red grass and purple water graphics issue that a lot of people suffer from. However, using one of the below solutions, it eventually corrected itself. Recently, I installed Windows 7, build 7100 as my main operating system. AoEII (Conquerors exp. too) did not work on the original Windows 7 build, but now does, however, no matter what I do, scouring the internet for solutions and ways to solve the problem the graphics issue of the red grass and purple water stay. Here are the solutions I've read about and tried, all to no avail.


Changing the resolution
Alt tabbing
Opening a folder before the game loads
Unchecking "CPU 1" on the "Set Affinity" box in Task Manager
Updating graphics drivers to most recent
Updating DirectX to most recent
Running the game in compatibility mode for XP, Vista, 98, etc.

None of these solutions work at all, the green grass is still red, and the water is still purple.

Here are my system specs.

Windows 7 Ultimate 64-Bit Build 7100
AMD Athlon 64 6000+ ~3.0GHz
2GB RAM
NVIDIA GeForce 8800 GT
Direct X 11
Running at 1920x1080

Can anyone recommend any other solution to the graphics problem? Thanks.

Here's a picture of the issue (screenshotting doesn't show the graphics problem)

http://img4.imageshack.us/img4/6167/140520091107.jpg



My System SpecsSystem Spec
.

15 May 2009   #2

Windows 7 Ultimate 7100
 
 

i have no ideia.. but tell me one thing can u still play that online ?
My System SpecsSystem Spec
15 May 2009   #3

Windows 7 Build 7100
 
 

Yep, flawlessly.
My System SpecsSystem Spec
.


16 May 2009   #4

Win7 7100 / WinXP SP2
 
 

It's AoE:The Mars Expansion
Did you try finding a different Video Driver? or Dumbing down your graphics options outside the game?
Do keep in mind it was a game built for a different Technical Era of computers.
They didn't have things like HD Cards back then they didn't even have DDR Cards far as I recall.
So knock down the graphics a good bit find a video driver maybe a newer one and see if it fixes the Wacky Red Grass Purple Water Mars effect.
My System SpecsSystem Spec
27 Aug 2009   #5

Win7 RC build 7100
 
 

My System SpecsSystem Spec
06 Sep 2009   #6

Windows 7
 
 
Solution to ''Age of Empires 2 Conquerors''!!!

Hello everybody!!!
I have ''Windows 7'' and i'm playing ''Age Of Empires 2 & The Conquerors Expansion''. I had the same graphic issue but i read some forums and i started to test it my own.

After a while i found a solution that is working fine for me!!

Go to your game folder and locate ''age2_x1''.
Right-click, Properties and choose ''Compatibility'' tab.
Then press on ''Choose settings for all users'' button.
Mark the ''Run this program in compatibility mode for:'' and choose
''Windows 98 / Windows me''
Then under settings mark ''Disable visual themes'', ''Disable desktop composition'', ''Disable display scaling on high DPI settings'' and ''Run this program as an administrator'' and click ''ok'' and again ''ok'' and you are done.

Please test if this works and post.
My System SpecsSystem Spec
06 Sep 2009   #7

Win7 7100 / WinXP SP2
 
 

No no no and No for me
Matter of fact it made it look worse.
My System SpecsSystem Spec
22 Oct 2009   #8

Windows 7
 
 

didn't work for me either...
however the fix suggested for starcraft worked for AOE2 but not starcraft:
StarCraft fix holy cow!

i've tried everything i possible could for AOE2 and starcraft but this only seems to work for AOE2 and not starcraft for me...
My System SpecsSystem Spec
22 Oct 2009   #9

Windows 8.1 Pro (x64)
 
 

I downloaded a mod to run AOE2 in a window which solves the graphic problems.
My System SpecsSystem Spec
22 Oct 2009   #10

Windows 7 Ultimate
 
 

Hello, have you tried to adjust your screen's resolution? And if so, what is the lowest resolution you tested? This will sometimes fix the issue.
My System SpecsSystem Spec
Reply

 Graphics issue with Age of Empires II: The Conquerors




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:14 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33