Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: GTA San Andreas


30 Mar 2012   #41

Windows 7 Ultimate x64
 
 

Pretty old post but since I ended up here I figured I would add my $.02.
I have an ASUS gaming laptop with Win 7 Ultimate 64 bit.

Installed GTA SA a few min ago and it ran fine but the mouse didn't work. Found another forum with a fix that worked for me.
In the GTA SA.exe properties, compatibility I have the following... Run in XP SP2, Disable Visual Themes, Disable Desktop Composition and Run As Administrator.

The "Themes" and "Composition" is what fixed the mouse issue for me.

Also; I read that some of you have no sound. When I was installing I chose custom install and saw that "Game Audio" was un-checked by default. Perhaps it never got installed for you.
Try custom install and be sure Game Audio is checked to be installed.

I also saw a video on youtube that touched on the DEP (Data Execution Prevention) feature of Windows 7. The user had to set an exemption for GTA SA.exe.
However I didn't set one, as I only have DEP on for Windows system programs, not all programs.
So far, as of posting this, GTA SA is working, intro movies, audio and mouse. Happy gaming!


My System SpecsSystem Spec
.

01 May 2012   #42

Windows 7 Ultimate 32bit
 
 

Quote   Quote: Originally Posted by SuperD38 View Post
Pretty old post but since I ended up here I figured I would add my $.02.
I have an ASUS gaming laptop with Win 7 Ultimate 64 bit.

Installed GTA SA a few min ago and it ran fine but the mouse didn't work. Found another forum with a fix that worked for me.
In the GTA SA.exe properties, compatibility I have the following... Run in XP SP2, Disable Visual Themes, Disable Desktop Composition and Run As Administrator.

The "Themes" and "Composition" is what fixed the mouse issue for me.

Also; I read that some of you have no sound. When I was installing I chose custom install and saw that "Game Audio" was un-checked by default. Perhaps it never got installed for you.
Try custom install and be sure Game Audio is checked to be installed.

I also saw a video on youtube that touched on the DEP (Data Execution Prevention) feature of Windows 7. The user had to set an exemption for GTA SA.exe.
However I didn't set one, as I only have DEP on for Windows system programs, not all programs.
So far, as of posting this, GTA SA is working, intro movies, audio and mouse. Happy gaming!
This worked for me and I'm so glad you posted this! It's never too late to help someone out! I am very, very, very, very grateful you came back and gave this info.

Signed up just to thank you!
My System SpecsSystem Spec
19 May 2012   #43

Windows 7 Ultimate x86
 
 

I have a problem too here. Everytime I run gta_sa.exe it won't run. Just made a blackscreen a second and then close itself. Can anyone help me?
My System SpecsSystem Spec
.


Reply

 GTA San Andreas




Thread Tools



Similar help and support threads for2: GTA San Andreas
Thread Forum
GTA San Andreas and iV Gaming
Solved GTA San Andreas !!PROBLEM!! Gaming
GTA: San Andreas Gaming
Problems With GTA San Andreas Gaming
gta san andreas win 7 Gaming
GTA San Andreas Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:38 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33