Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: The Saboteur


17 Sep 2010   #1

Windows 7 Ultimate (x64) SP1
 
 
The Saboteur

What setting should I play The Saboteur with my current hardware, just a thought.


My System SpecsSystem Spec
.

17 Sep 2010   #2

windows 7 Pro x64
 
 

Something medium, and be careful with official patch 1.2.
My System SpecsSystem Spec
17 Sep 2010   #3

Windows 7 Ultimate (x64) SP1
 
 

Ok, medium then, what's with the patch 1.2, I've heard about 1.3- are the patches buggy?
My System SpecsSystem Spec
.


17 Sep 2010   #4

Windows 7 Home Premium x64
 
 

The "beta "patch fixed everything for me, and the performance is flawless, Playing it right now, actually, one last time.
It's always best to just try out by yourself what settings suit you best, but yes, medium should be good enough. If performance keeps being an issue, lower the distance setting and possibly post processing.
My System SpecsSystem Spec
18 Sep 2010   #5

windows 7 Pro x64
 
 

Patch 1.2 never done a good job for me and as it seems other players of the game too, but some gamers had no problems, go and guess it... If there is 1.3 than probably that patch is ok, just create Restore Point before installing patch... just in case... Anyway good luck and pleasent time playing "Saboteur", punish those nazis!
My System SpecsSystem Spec
18 Sep 2010   #6

Windows 7 Home Premium x64
 
 

It's a well known fact that the game has major issues with ATI GPUs and no patches can completely fix them.

I have none, as I have nVidia :P
My System SpecsSystem Spec
18 Sep 2010   #7

Windows 7 Ultimate (x64) SP1
 
 

Thanks ppl! Will report after playing with 1.3 patch.
My System SpecsSystem Spec
20 Sep 2010   #8

Windows 7 Ultimate (x64) SP1
 
 

Runs just fine, folks :-)

P.S.

The game is really buggy, even on my Nvidia card with 1.3 update. crashes every time I try to exit to windows.
My System SpecsSystem Spec
02 Nov 2010   #9

Windows 7 Ultimate (x64) SP1
 
 

I finally managed it to run unpatched,once I uninstalled it and ran reg cleaners, and installed again without updates it ran fine with minor glitches.
My System SpecsSystem Spec
02 Nov 2010   #10

Windows 7 Home Premium x64
 
 

Cool. Glad you worked it out.
My System SpecsSystem Spec
Reply

 The Saboteur




Thread Tools



Similar help and support threads for2: The Saboteur
Thread Forum
The saboteur not working Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:39 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33