Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: High enough specs,,NO Performance..Static Black Screen on certian game

06 Oct 2010   #1
ITz

Windows 7 Ultimate 32bit
 
 
High enough specs,,NO Performance..Static Black Screen on certian game

Please someone help,this is driving me insane..

I know quite a bit about pc's overall,,done A+,N+,Server 2003,Linux+,SQL
I now work as a sql jr.dba but love my gameing.

So my problem starts: I've got a alright system at home
SPECS-
-ASUS P5QL-EM Motherboard
-2GB Kingston DDR2 800 Ram Running in duelline
-Single core intel 3.2GHZ cpu
-Radeon PowerColour HD5500 Graphics 512MB
-Onboard sound but using Xforce-5 5.1 channel surround
-Just 17ch display

I play a few games like - AssasinsCreed,TorchLight,Lost ect. and have no problem
but as soon as i pull a bit more graphics like - Crysis or Sniper Ghost Warrior the screen
goes black and my sound keeps repeating itself going rrrrrrrrrrrrrrrrrrrrrrrrrrrrr!!! And i have to reboot manually.. Ive got the latest drivers,catalyst,directX and so on..
Even tried some older compaltible versions,but still does the same.. I have looked at game requirements and they follow:

Sniper Ghost Warrior-
Minimum:
o OS: Windows® XP (SP3) / VistaTM (SP1) / 7
o Processor: 3.2 GHz / AMD Athlon 64 3500+
o Memory: 1GB for XP / 2GB for Vista and 7
o Graphics: Nvidia 6800 or ATI X1650, 256 MB RAM, Shader Model 3.0
o DirectX®: DirectX® 9.0c
o Hard Drive: 6GB
o Sound: Compatible with DirectX® 9.0

Crysis-
Minimum System Requirements:
OS - Windows XP or Windows Vista
Processor - 2.8GHz or faster (XP); 3.2GHz or faster * (Vista)
Memory - 1GB RAM or 1.5GB RAM (Vista)
Video Card - 256MB **
Hard Drive - 12GB
Sound Card - DirectX 9.0c compatible

I'm running a duelboot with xp and tried the games on xp aswell..Same story soooo
i fiqured that the problem lies with hardware,, I was thinking on buying QuadCore cause thats the only ''Slower'' Component... Please Advise me...


My System SpecsSystem Spec
06 Oct 2010   #2
LiquidSnak

W7 Professional x64
 
 

What you're describing sounds like processor hang. Can you run the game in the background while looking at resource monitor or task manager to see how much processor you are using?
My System SpecsSystem Spec
06 Oct 2010   #3
taylorig

Windows 7 Pro x64
 
 

I agree with Liquidsnak. That 3.2GHz P4 Cpu is definitely bottlenecking the rest of your system, the HD5500 for sure.

Even though the games today recommend certain mimimum specs to run the game it's all dependant on the users system and how well balanced the components are and it's usually on the basis that the user is running very low resolution/settings. I'd also look in to upgrading that 2Gb or ram to 3Gb at least (4Gb recommended depending on what budget you have of course. Just remember 64bit OS needed for this though).

So the bottom line is what you already pointed out yourself about your CPU. Maybe try lowered settings in the meantime. The rest of your system is fairly ok and the motherboard is pretty upgradable when it comes to CPU's.

Good luck with it
My System SpecsSystem Spec
06 Oct 2010   #4
ITz

Windows 7 Ultimate 32bit
 
 

Thanx, i really have tried everything it has to be the gpu overheating(Not enough cooling)or the cpu that needs a upgrade..I would like some more advice from everyone please..
My System SpecsSystem Spec
06 Oct 2010   #5
ITz

Windows 7 Ultimate 32bit
 
 

Quote   Quote: Originally Posted by LiquidSnak View Post
What you're describing sounds like processor hang. Can you run the game in the background while looking at resource monitor or task manager to see how much processor you are using?
Sorry have checked the monitors and it seems at launch to sky abit but ingame actually seems really stable..I don't understand..
My System SpecsSystem Spec
06 Oct 2010   #6
LiquidSnak

W7 Professional x64
 
 

Have you tried to run it in compatibility mode for XP or Vista?
My System SpecsSystem Spec
07 Oct 2010   #7
ITz

Windows 7 Ultimate 32bit
 
 

Ghost Warrior by default is running in XPServicePack 3 compatibility, have set the compatibility to Vista and the problem seemed to increase..Soz,but thats one of the first things I tried..But,,,,Last nite i installed ATI's EXPERTool and set 'only' the GPU fan speed to 100%,,now the screen goes blank but I can still hear the sound(Freezed),,No walking,shooting ect. Only backgroud sounds like rustling & water.. I had to restart manualy again,task manager does not pop-up... Then I had a look at eventviewer,and saw the dates & time of all the critical errors,found the same one over and over,,it says 'Kernal Power (R60)' Sooo,I don't know what the error means.... If you can find out what causes the error,PLEASE inform..
My System SpecsSystem Spec
08 Oct 2010   #8
ITz

Windows 7 Ultimate 32bit
 
 

Where's the GURU's,,LOL,,Please here is eventviewer critical error..

10/7/2010 9:20:26 PM

-<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
-<System>
<ProviderName="Microsoft-Windows-Kernel-Power" Guid="{331C3B3A-2005-44C2-AC5E-77220C37D6B4}" />
<EventID>41</EventID>
<Version>2</Version>
<Level>1</Level>
<Task>63</Task>
<Opcode>0</Opcode>
<Keywords>0x8000000000000002</Keywords>
<TimeCreatedSystemTime="2010-10-07T19:20:26.324820800Z" />
<EventRecordID>61185</EventRecordID>
<Correlation/>
<ExecutionProcessID="4" ThreadID="8" />
<Channel>System</Channel>
<Computer>Pdz</Computer>
<SecurityUserID="S-1-5-18" />
</System>
-<EventData>
<Data Name="BugcheckCode">0</Data>
<Data Name="BugcheckParameter1">0x0</Data>
<Data Name="BugcheckParameter2">0x0</Data>
<Data Name="BugcheckParameter3">0x0</Data>
<Data Name="BugcheckParameter4">0x0</Data>
<Data Name="SleepInProgress">false</Data>
<Data Name="PowerButtonTimestamp">0</Data>
</EventData>
</Event>

The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.


Can't be powersupply,,just put in a new sparta 500w..
My System SpecsSystem Spec
12 Oct 2010   #9
ITz

Windows 7 Ultimate 32bit
 
 

I got it sorted finally,,opened my box
,cleaned the heatsink
,cleaned the cpu fan
,cleaned and applyed some new thermal paste

and...............
and...............

BOOOOOOOOM!!!!! Problem solved... thanks to everyone who tried helping>>>
This game rocks,,just started dragonage origins


Ps.how do i close this thread..
My System SpecsSystem Spec
12 Oct 2010   #10
Lomai

Win7 HP (x64)/Win7 Ultimate (x64)
 
 

Quote   Quote: Originally Posted by ITz View Post
I got it sorted finally,,opened my box
,cleaned the heatsink
,cleaned the cpu fan
,cleaned and applyed some new thermal paste

and...............
and...............

BOOOOOOOOM!!!!! Problem solved... thanks to everyone who tried helping>>>
This game rocks,,just started dragonage origins


Ps.how do i close this thread..
Thanks for letting us know. Refer attached - click the icon on the far-right (will alert Mods) and enter Solved in the dialogue box.


Attached Images
 
My System SpecsSystem Spec
Reply

 High enough specs,,NO Performance..Static Black Screen on certian game




Thread Tools





Similar help and support threads
Thread Forum
Screen goes black when playing a game
For the last few weeks I'm encountering a serious problem. When I play a game after 10 minutes all the way to several hours (It is definitely getting more frequent) my screen turns black (I can still hear sounds, I can still speak on Skype etc.). But the computer is completely locked - I can't...
Gaming
W7 Black Screen when start then goes to desktop hdd activity high
HI I dont know what happened , but when I load up Win7 after the please wait screen there is a black screen with my pointer.I can move the pointer fine but I have to wait till the black screen goes so I can get to the desktop.I normally have to wait an additional 5 mins (on top of the normal W7...
General Discussion
Black screen on any online game
I get random black screens followed by a shutdown while playing online games. I tried reinstalling the graphic card drivers but it does not seem to work. Reinstalling the game "fixes" this momentarily and once it starts to show a black screen it repeats itself. Temps while gaming: CPU: 70-75C...
Gaming
RE: I'm stumped -- Getting Sometimes A Flashing Black/Static Screen??
Hello. I need your help. I'm stumped!!! For the past few days now, I am having an issue. I am 'now' using Windows 7 Professional 64-Bit. I was using Windows 7 Pro 32-Bit. This issue is with both. This is what is happening: Approximately 50% of the time (random) when I statup my desktop...
Performance & Maintenance
NVidia GF GT 325M - black screen on high-requiring games
Sorry, I'm making quite a mess in this forum, cause I've already posted identical post in other thread, but nobody answered me yet. So I thought the reason of this, is that this thread is marked as solved (which isn't, frankly I think) and none is even looking there to check if something new has...
Graphic Cards
High WEI Low Game Performance
I am new here on forum so...I have this problem: i have high WEI and lowest subscore is 5.7 and it is for HDD.My pc works fine but when I play games it has a low performance ingame,so i think it could do better.My graphic card is Leadtek PX8600 GTS
Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 14:16.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App