Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Company of Heroes

01 Jun 2009   #1

Windows 7 Home Basic
 
 
Company of Heroes

I have an odd situation with COH running in Windows 7 (RC).

Skirmishes run flawlessly and very smooth at high settings, except when scrolling fast around the map there is often a pause of a small, but still significant amount. It makes me think something is struggling for RAM, but the system has 2GB and vid card 512MB, so it should not be that.

I have it running at exact same settings as it's installed in XP, where it runs without these hiccups.

Has anyone else had the same problems?

My System SpecsSystem Spec
.

01 Jun 2009   #2

SEVEN x64
 
 

Quote   Quote: Originally Posted by Fritz Fraghof View Post
I have an odd situation with COH running in Windows 7 (RC).

Skirmishes run flawlessly and very smooth at high settings, except when scrolling fast around the map there is often a pause of a small, but still significant amount. It makes me think something is struggling for RAM, but the system has 2GB and vid card 512MB, so it should not be that.

I have it running at exact same settings as it's installed in XP, where it runs without these hiccups.

Has anyone else had the same problems?
thats not a lot of RAM TBH mate....... while it may meet requirements to run the game its often still not enough for smooth operation.

COH is a hella intensive game, my copy still locks from time to time & i have 8GB system RAM & 896mb VRAM....stick another gig in there, it should help.....

ive always said ''3GB for happy operation''




SK
My System SpecsSystem Spec
02 Jun 2009   #3

Windows 7 Home Basic
 
 

Thanks for the answer. It was a good suggestion, but I managed to solve the problem another way.

It appears COH turns vsync on by default, even though it does not appear in game graphic options. (The only way to turn it off is with a command line option.)

That is fine having it on, but I then saw my nVidia profile for COH had Triple Buffering turned off. Turning Triple Buffering on improves frame rates when Vsync is on in games and changing this solved my problem. Now I have no stuttering and perfectly smooth frame rates as it should be.

See you on the battlefield!
My System SpecsSystem Spec
.


26 Jul 2009   #4

XP, Win_7 64 7100
 
 

I am curious why the time to load a game is so much longer in Win 7 and VISTA than XP. My sense is Win 7 is quicker than Vista. But generally I am the last to load to the map in multiplayer games. If I boot and run COH in my XP partion I am usually first or close to it.

I am running an Intel Core 2 Quad Q6600 at stock 2,.4 Ghz and 4 x 1megs of DDR3,

Both partitions are on a Rocketraid 3510 Raid 0 array with 2 x 150 GB Raptors

Win 7 RC is the current install

Is it just me or have others observed the same?
My System SpecsSystem Spec
25 Jan 2010   #5

Windows 7 home premium
 
 
Crashing with Windows 7

I have an
AMD AMD Phenom(tm) II X4 965 Processor 3415.1 Mhz

ATI Radeon HD 4670

4 gig of ddr3

Speakers (Realtek High Definition Audio

COH starts to play and then crashes

any suggestions, help!!
My System SpecsSystem Spec
25 Jan 2010   #6

 

Quote   Quote: Originally Posted by Fritz Fraghof View Post
I have an odd situation with COH running in Windows 7 (RC).

Skirmishes run flawlessly and very smooth at high settings, except when scrolling fast around the map there is often a pause of a small, but still significant amount. It makes me think something is struggling for RAM, but the system has 2GB and vid card 512MB, so it should not be that.

I have it running at exact same settings as it's installed in XP, where it runs without these hiccups.

Has anyone else had the same problems?
remember Windows 7 uses more resources (more efficient with them as it is) and it also the game will be running DX 10 and not just DX 9 for COH
My System SpecsSystem Spec
27 Jan 2010   #7

Windows 7 home premium
 
 
winsows seven, COH crashing mid game

COH is still crashing on WIndows 7. my specs are above. Not sure what is happening, I get into the game, begin skirmish play and right in the middle, crash. I've been sending in the crash reports to relic but so far no reply. ANy suggestions, similar eperiences???
My System SpecsSystem Spec
29 Jan 2010   #8

Windows 7 Home Premium 64-bit
 
 

Quote   Quote: Originally Posted by Whitewarlock View Post
COH is still crashing on WIndows 7. my specs are above. Not sure what is happening, I get into the game, begin skirmish play and right in the middle, crash. I've been sending in the crash reports to relic but so far no reply. ANy suggestions, similar eperiences???
Same here mate. I too have been experiencing constant freezes and sending reports to Relic. I also contacted them earlier this week, and they advised to use earlier nVidia drivers in my case (I have a nVidia GTS 240 card). That brought some stability but still freezes.

I have tried a number of things since including: playing offline (without RelicDownloader), closing Windows Firewall and Kasperky Anti-Virus (temporarily), and lowering my shader settings. Still freezing. I have managed to replay some of the campaign but just too many lockups to enjoy this older (but still great) RTS game.

Hopefully there will be a patch/video driver update/etc to address this issue. I'm at a loss to understand what's going on. In the meantime I wonder if COH shouldn't be taken off the Windows 7 compatibility list. Perhaps others are not having any problems.

Regards
My System SpecsSystem Spec
30 Jan 2010   #9
stew2

 

Quote   Quote: Originally Posted by TargetSlayer View Post
In the meantime I wonder if COH shouldn't be taken off the Windows 7 compatibility list.
Hi TargetSlayer

Im not having the problems you guys are having. For me COH works as it should, although the time it takes to load has definately increased when compared to vista.

You could try a clean install of the game then lower every setting in the graphics and audio settings to as low as they will go. Play the game and see if it works ok. Dont install any mods etc while testing it.
My System SpecsSystem Spec
30 Jan 2010   #10

Windows 7 Home Premium 64-bit
 
 

Thanks for the comments stew2. Fresh install of Windows 7 and the game. Everything has been updated, except for going back to older nVidia drivers as suggested by Relic's helpdesk.

Glad to hear it works for you. Can't help but notice you have an ATI card and a Duo system opposed to a Quad. Maybe the problem lies in one or both of these things for me (not sure about other folks).

I messed around with it all week. If solving the problem means playing at really low settings then it will stay broken. Enjoyed it a lot under my old system (XP and 6800 card), so the game doesn't owe me anything. Just wanted to enjoy the campaign again with maximum settings, which work smoothly except for the freezing that eventually occurs (sometimes within minutes, other times 1/2 hour to even an hour or so).

Regards
My System SpecsSystem Spec
Reply

 Company of Heroes




Thread Tools



Similar help and support threads for2: Company of Heroes
Thread Forum
company of heroes error Gaming
Company of heroes Gaming
Company of Heroes only 6 FPS Gaming
Company of Heroes crashes Gaming
Company of Heroes Gaming
Company Of Heroes OF Gaming
Company of heroes after effect Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:14 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33