Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: problems in battle net


11 Jun 2009   #1

windows 7
 
 
problems in battle net

Hey all, just installed WC3 onto my laptop with windows 7 (release 7100 I believe)

Naturally I wanted to play games on battle.net, but I find for some reason, my connection starts to die off throughout the game til between 10-20 minutes in, I disconnect entirely. This seems to apply only to battle.net as my web browsing works smoothly. Furthermore, I have tested with my other computer (Mac OSX) and I do not ever disconnect on there, leading me to believe the problem is specific to windows 7.

Has anyone else had network connection issues with WC3 and has a solution?

My System SpecsSystem Spec
.

Reply

 problems in battle net




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:35 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33