Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Installing/downloading games with steam.


15 Jun 2009   #1

Windows 7/Vista 64 Bit
 
 
Installing/downloading games with steam.

Hey sorry if this has been asked before, didn't see any though.

I have just downloaded Windows 7 64 bit 7100, and installed steam to install all my games on my new raptor HD. However when I attempt to download a game, a second window opens up with a progress bar (this always happens prior to the download) however once the bar appears to complete nothing happens, and all I can do is cancel it. (which makes it stop responding)

Some times, even after a crash when I reload steam it actually works and the game starts downloading, however this is taking quite a bit of time and doesn't always work.

So has anyone else run into this problem? Any fixes or advice would be great! Thanks for your time.

My System SpecsSystem Spec
.

15 Jun 2009   #2

Windows 7 build 7100
 
 

To be honest I dont really know, try uninstalling steam and reinstalling it with compatibility on for XP and when you run it also, even try running it under admin powers.

When I installed windows 7, same builds, I already had my steam files on another partition it just told me it had to download some files to adapt itself and they run perfectly, except for the ping issue I have...
My System SpecsSystem Spec
15 Jun 2009   #3

Windows 7 x64 Pro
 
 

The only steam game that I installed so far is the last remnant and for that I had a disk Never tried downloading it from the web.
My System SpecsSystem Spec
.


15 Jun 2009   #4

64-bit Windows 7 Ultimate Build 7100
 
 

Strange, This does not happen to me. Did you download steam from the actual website? I figured that the steam on my CD would be too old for Windows 7 or something. If anything, I would just reinstall steam.
My System SpecsSystem Spec
15 Jun 2009   #5

Windows 7 Ultimate x32
 
 

sounds like an x64 problem. i haven't had any trouble with steam on any of the recent builds (all x86).

try opening steam with admin rights, maybe because its adding programs, UAC is not allowing it, and just not telling you.
My System SpecsSystem Spec
15 Jun 2009   #6

Windows 7/Vista 64 Bit
 
 

Well, its working, its just taking way to long. (like 30-45 minutes to long) However since I'm almost done I will just finish up and hope what ever it is gets fixed with a new build.

I did turn off UAC (the first thing I did) but I will still try with admin.


Thanks for all the replys
My System SpecsSystem Spec
16 Jun 2009   #7

64-bit Windows 7 Ultimate Build 7100
 
 

Quote   Quote: Originally Posted by holo88 View Post
sounds like an x64 problem. i haven't had any trouble with steam on any of the recent builds (all x86).

try opening steam with admin rights, maybe because its adding programs, UAC is not allowing it, and just not telling you.
It's not a 64-bit problem. As I said it runs fine on my machine, which is 64-bit. I think re-installing might work.
My System SpecsSystem Spec
28 Jan 2010   #8

Windows 7 x64 Ultimate
 
 
The Last Remnant issues starting up

Ok im on Windows 7 Ultimate x64 with build 7600. I have a similar if not the same problem. I installed the game off Disc and steam installed via the disc contents. I tried running the game but it crashes on the first splash screen. Then i thought it might be the Steam being out of date so i downloaded it from the official site but again it crashes on the first splash screen. I then tried allowing steam to download the game instead and once again it crashes on the first splash screen. I dont know what the problem is. Only thing i can remotely think it might be is the fact that i upgraded from vista x64 to Windows 7 x64. Ive never done a upgrade before and was warned it could cause issues later. Is it possible for that to cause the problem i am having now? I have also tried installing STEAM under compatibility for lower versopns of windows but that still results in the same out come of crashing on the first splash screen that pops on screen.

Any help on this matter would be greatly appreciated otherwise im just gonna format and clean install Windows 7 again.......


Thanks

Chaos

Edit: I have UAC diabled and have tried right-clicking and running as admin for all the steps listed above but still thesame result
My System SpecsSystem Spec
Reply

 Installing/downloading games with steam.




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:54 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33