Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Compatability issue with Elder Scrolls: Oblivion


06 Jan 2011   #1

Windows 7 Home Premium 64bit
 
 
Compatability issue with Elder Scrolls: Oblivion

I recently bought Oblivion from steam, and when I first started the game it would freeze almost instantly. I searched the internet and found a forum post that suggested that I run the compatability troubleshooter, which set it to Xp (service pack 2), and now when I try to play the game I get to the launcher and when I hit play, it asks me for permission, it says that Oblivion.exe would like to make changes to this computer, I hit yes, the screen goes black for a second and acts like it is about to do something, then it goes back to the launcher, and no matter how many times I hit play, it will keep asking for permission, and will never run, also, yes I am running the game as administrator.

Can someone please help me.

My System SpecsSystem Spec
.

06 Jan 2011   #2

Windows 7 Home Premium x64
 
 

Welcome to SF, ejand11!

I run Oblivion on my system. This is what I have done:

  • I installed MagicDisc in order to have a virtual CD Drive. You can get it here: Using MagicDisc to mount CD/DVD image - Freeware
  • Don't confuse this with MagicISO by the same company
  • I have the .iso that I created mounted so I don't have to mess with the original disc all the time and perhaps damage it.
  • I don't run Oblivion with the 'Launcher'; I use the 'oblivion.exe' file (you'll find that in your Oblivion installation directory).
  • Just change your shortcut to point to that instead.
  • If you have problems with no voice in the game, then let me know what speaker setup you have and we can go on from here
  • If you really want an in-depth guide, check out this link: TweakGuides.com - Elder Scrolls IV: Oblivion Tweak Guide
Hope this helps!
My System SpecsSystem Spec
06 Jan 2011   #3

Windows 7 Home Premium 64bit
 
 

Thanks for trying to help rap33042, however I don't have a disk since I bought it off of steam, and there is no .iso. Also it doesn't seem to matter if I run the launcher or Oblivion.exe, I still have the same problem, it will just keep asking me for permission, even if I try to run the game as administrator. Thanks for the tweak guide by the way, if I ever get this game working, I will be using it.
My System SpecsSystem Spec
.


07 Jan 2011   #4

Windows 7 Home Premium x64
 
 

Have you tried changing the compatibility settings to XP SP3? or lower?
I presume it's UAC asking for permissions? Have you tried disabling UAC?
If you are not sure how to do this, let me know...

My retail copy requires a disc in the drive in order for it to run- I can't speak for the downloaded version or how it installs, or what it requires to run- sorry.

I'd really like to see you get this going. Oblivion is an awesome game that has stolen many hours from my life- and I don't regret it a bit
My System SpecsSystem Spec
07 Jan 2011   #5

Windows 7 Home Premium 64bit
 
 

Oblivion is an awsome game, this is the second time I bought it, it was on sale so I had to get it. Also, I do not know how to disable UAC, and so far I have only gone as low as XP service pack 2, I will try to go lower and see how that works.
My System SpecsSystem Spec
07 Jan 2011   #6

Windows 7 Home Premium x64
 
 

To change your UAC settings go to: Control Panel/User Accounts/Change User Account Control settings

I always have mine disabled (against the advice of many) because I can't get used to the nag screens- that's just me, however.
This is your decision to make.

How about DirectX 9- do you have that installed? Oblivion might need that and it doesn't come stock with Windows 7.

If you find that you need it, you can DL it here: https://www.microsoft.com/downloads/...1-50ceb6d8fa8d
My System SpecsSystem Spec
07 Jan 2011   #7

Windows 7 Home Premium 64bit
 
 

Thanks for your help rap33042, I turned off UAC and it worked. I still don't know why it has a problem with UAC but at least I know that I can play the game if I turn it off.
My System SpecsSystem Spec
Reply

 Compatability issue with Elder Scrolls: Oblivion




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:33 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33