Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: LOSS of proformance on 7

22 Jun 2009   #1
Green Fox

Win7/Vista/Ubuntu
 
 
LOSS of proformance on 7

So I've bean using Win7 for a few months now. I decided to run FRAPS to see what kind of frame rate I was ACTUALLY getting. I was disappointed with the results (could have swear they use to be higher), so I ran those same benches on the old Vista install. They where about twice what I was getting on Win7. I have all the right drivers, and I have AVG anti virus.

I haven't bean keeping the Vista install up to date, but it seems to be doing better. I don't understand. I've tried updating drivers and everything else that updates... Can't figure this out. If it is useful, I could post the DxDiag.txt specs.

I don't think the fact that it is the 3rd partition on my 1TB hdd should matter, does it?

Core 2 Duo 8400
Nvidia9400 Chipset Gigabyte Motherboard
EVGA 9800 GTX+
6gb of ram (1 gb dedicated to the 9400 on board graphics card)

1TB hdd, Win7 install starts on a partition that starts in the last 1/4 of the HDD. Vista is in the first thing on the HDD.

Thx


My System SpecsSystem Spec
.

22 Jun 2009   #2
digitalrurouni

Windows 7 x64 Pro
 
 

What drivers are you using? what games were you benchmarking? What fps were you getting?
My System SpecsSystem Spec
22 Jun 2009   #3
sup3rsprt

XP, Seven, 2008R2
 
 

Benches in Win7 should be roughly equivalent to those of Vista. After all, Win7 is just Vista refined.

But digital is right, you left out some pretty valuable info.
My System SpecsSystem Spec
.


23 Jun 2009   #4
grouchpunk08

Windows 7 Ultimate retail // Windows 7 build 7264 x64, Vista Home Premium SP2 x64
 
 

Idk why, but in my experience I get better gaming performance in Win7 than I did in Vista. Nothing too spectacular, but I can usually bump up the graphics a setting or two on 7
My System SpecsSystem Spec
23 Jun 2009   #5
Green Fox

Win7/Vista/Ubuntu
 
 

about 30 fps or less on L4D win7 vs 50-60 on Vista

15-25 on Crysis Wars on Win7 vs 30-40 on Vista

a few others, but I haven't recorded anything.

Could the fact that I have 2 different graphics cards be part of it? If I disable the onboard graphics card on the motherboard, could that improve performance (My screen is plugged into the 9800)

I tried Win7 because I heard there was better performance on Win7, but I'm not seeing it.
My System SpecsSystem Spec
23 Jun 2009   #6
Green Fox

Win7/Vista/Ubuntu
 
 

I'm using the lastest nvidia drivers available. I even uninstalled the drivers and reinstalled them. Still no proformance boost.
My System SpecsSystem Spec
23 Jun 2009   #7
grouchpunk08

Windows 7 Ultimate retail // Windows 7 build 7264 x64, Vista Home Premium SP2 x64
 
 

Quote   Quote: Originally Posted by Green Fox View Post
I'm using the lastest nvidia drivers available. I even uninstalled the drivers and reinstalled them. Still no proformance boost.

Which build of win7 are you using?
My System SpecsSystem Spec
23 Jun 2009   #8
ikilledkenny

Windows 7 Professional, Windows Longhorn 4074
 
 

I can't even play games in Win7. I think it's a DirectX thing.
My System SpecsSystem Spec
23 Jun 2009   #9
grouchpunk08

Windows 7 Ultimate retail // Windows 7 build 7264 x64, Vista Home Premium SP2 x64
 
 

Quote   Quote: Originally Posted by ikilledkenny View Post
I can't even play games in Win7. I think it's a DirectX thing.

At first I couldn't either, the game would come up then stop responding. I solved that by downloading the latest directX from the website(google directx download, that should take you to it) then I updated my graphics drivers, and all was good. maybe you could see if it would work for you
My System SpecsSystem Spec
23 Jun 2009   #10
ikilledkenny

Windows 7 Professional, Windows Longhorn 4074
 
 

I installed DirectX 9.0c, but the drivers that come with Windows 7 are better/newer than intel's drivers. Like, they are intel's drivers, but intel doesn't have the version I have on their website.

Yet another reason to dislike intel...
My System SpecsSystem Spec
Reply

 LOSS of proformance on 7




Thread Tools





Similar help and support threads
Thread Forum
Evening Internet Connection Loss -- Unable To Identify Source Of Loss?
I need your help!!! I got a real challenge for you! I am confused! I cannot locate the Internet connection loss source. Every night for the past 5 late evenings my Windows 7 Pro 64-bit has been losing my Internet connection on my desktop computer anywhere between 8 PM-12 AM (Last 3 nights: 11:05...
Network & Sharing
Am at a loss
Am at a loss as to why people insist on using this garbage I recently saw a great niece (12 yo) of mine post onto my brothers facebook site a video of people being burnt to death in Kenya I think it was. So how come this rotten site is allowed to carry on take a look Firm: Facebook 'bug' worse...
Chillout Room
Power Loss To Notebook Shows Loss of Windows Activation (!!??)
I had a power loss while running on battery (it still showed power left, but suddenly shut down anyway) and when I restart, it reports that the Windows is not activated and Window is not genuine and system might be a victim of "counterfeiting." Is this a virus (I have MSE on continuously and...
Windows Updates & Activation
HELP PLEASE. at a loss :(
Hi all, I recently changed my browser from Firefox to IE9, i imported my bookmarks as explained via another thread here and all was good. There was one folder however that i couldnt get off the bookmark tab so i went into user-pc name etc, favs and deleted it there. I opened IE9 and it was gone,...
General Discussion
At a Loss
Ladies and Gentlemen, I ask for your assistance. I am at my wit's end. I have been researching this issue for months, and have tried most of the suggestions I have found with no avail. My last resort is to post the error dumps and hope someone smarter than myself can find out what is...
BSOD Help and Support
I'm at a loss
HI all, Can anyone make heads or tails of this bug report. I can't tell what it is. I suspect new bios update but it could be software All comments are welcomed. Microsoft (R) Windows Debugger Version 6.11.0001.404 AMD64 Copyright (c) Microsoft Corporation. All rights reserved.
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:29.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App