Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: LOSS of proformance on 7

22 Jun 2009   #1

Win7/Vista/Ubuntu
 
 
LOSS of proformance on 7

So I've bean using Windows 7 for a few months now. I decided to run FRAPS to see what kind of frame rate I was ACTUALLY getting. I was disappointed with the results (could have swear they use to be higher), so I ran those same benches on the old Vista install. They where about twice what I was getting on Windows 7. I have all the right drivers, and I have AVG anti virus.

I haven't bean keeping the Vista install up to date, but it seems to be doing better. I don't understand. I've tried updating drivers and everything else that updates... Can't figure this out. If it is useful, I could post the DxDiag.txt specs.

I don't think the fact that it is the 3rd partition on my 1TB hdd should matter, does it?

Core 2 Duo 8400
Nvidia9400 Chipset Gigabyte Motherboard
EVGA 9800 GTX+
6gb of ram (1 gb dedicated to the 9400 on board graphics card)

1TB hdd, Windows 7 install starts on a partition that starts in the last 1/4 of the HDD. Vista is in the first thing on the HDD.

Thx


My System SpecsSystem Spec
.

22 Jun 2009   #2

Windows 7 x64 Pro
 
 

What drivers are you using? what games were you benchmarking? What fps were you getting?
My System SpecsSystem Spec
22 Jun 2009   #3

XP, Seven, 2008R2
 
 

Benches in Windows 7 should be roughly equivalent to those of Vista. After all, Windows 7 is just Vista refined.

But digital is right, you left out some pretty valuable info.
My System SpecsSystem Spec
.


23 Jun 2009   #4

Windows 7 Ultimate retail // Windows 7 build 7264 x64, Vista Home Premium SP2 x64
 
 

Idk why, but in my experience I get better gaming performance in Windows 7 than I did in Vista. Nothing too spectacular, but I can usually bump up the graphics a setting or two on 7
My System SpecsSystem Spec
23 Jun 2009   #5

Win7/Vista/Ubuntu
 
 

about 30 fps or less on L4D Windows 7 vs 50-60 on Vista

15-25 on Crysis Wars on Windows 7 vs 30-40 on Vista

a few others, but I haven't recorded anything.

Could the fact that I have 2 different graphics cards be part of it? If I disable the onboard graphics card on the motherboard, could that improve performance (My screen is plugged into the 9800)

I tried Windows 7 because I heard there was better performance on Windows 7, but I'm not seeing it.
My System SpecsSystem Spec
23 Jun 2009   #6

Win7/Vista/Ubuntu
 
 

I'm using the lastest nvidia drivers available. I even uninstalled the drivers and reinstalled them. Still no proformance boost.
My System SpecsSystem Spec
23 Jun 2009   #7

Windows 7 Ultimate retail // Windows 7 build 7264 x64, Vista Home Premium SP2 x64
 
 

Quote   Quote: Originally Posted by Green Fox View Post
I'm using the lastest nvidia drivers available. I even uninstalled the drivers and reinstalled them. Still no proformance boost.

Which build of Windows 7 are you using?
My System SpecsSystem Spec
23 Jun 2009   #8

Windows 7 Professional, Windows Longhorn 4074
 
 

I can't even play games in Windows 7. I think it's a DirectX thing.
My System SpecsSystem Spec
23 Jun 2009   #9

Windows 7 Ultimate retail // Windows 7 build 7264 x64, Vista Home Premium SP2 x64
 
 

Quote   Quote: Originally Posted by ikilledkenny View Post
I can't even play games in Windows 7. I think it's a DirectX thing.

At first I couldn't either, the game would come up then stop responding. I solved that by downloading the latest directX from the website(google directx download, that should take you to it) then I updated my graphics drivers, and all was good. maybe you could see if it would work for you
My System SpecsSystem Spec
23 Jun 2009   #10

Windows 7 Professional, Windows Longhorn 4074
 
 

I installed DirectX 9.0c, but the drivers that come with Windows 7 are better/newer than intel's drivers. Like, they are intel's drivers, but intel doesn't have the version I have on their website.

Yet another reason to dislike intel...
My System SpecsSystem Spec
Reply

 LOSS of proformance on 7




Thread Tools



Similar help and support threads for2: LOSS of proformance on 7
Thread Forum
Am at a loss Chillout Room
Power Loss To Notebook Shows Loss of Windows Activation (!!??) Windows Updates & Activation
Solved HELP PLEASE. at a loss :( General Discussion
BSOD, At a Loss BSOD Help and Support
At a Loss BSOD Help and Support
I'm at a loss BSOD Help and Support
memory loss Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:31 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33