Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Program Load problem


10 Feb 2011   #1

Windows 7 Professional 64bit
 
 
Program Load problem

Hi,

Usually I just read through these forums however I have come across a issue that doesn't appear to be covered.

Before I start I should let you know Im not at all good with comps and can only do basics.

I have installed a game (Hearts of Iron 3). This works fine. However when I install the expansion (Semper Fi) and try to load it, I get the following error:

Quote:
The program can't start because d3dx9_40.dll is missing from your computer. Try reinstalling the program to fix the problem.

Like the error message suggested, I went ahead and reinstalled, twice actually, but again I get this error.

This error is weird because before I reinstalled windows the games worked fine.

Extra information :
1 )Before I reinstalled windows, when the games worked fine, I also had other newer games such as Battlefield Bad Company 2, Starcraft e.t.c
2) After reinstallign windows I only have Starcraft and Company Of Heroes.
3) Operating system I am using is Windows 7 professional 64 bit. (This did not come with my laptop, I had to purchase it seperately).

My System SpecsSystem Spec
.

10 Feb 2011   #2

Windows 7 Ultimate X64 SP1
 
 

Hi geezafrombrum, congratulations on your first post

That error is quite common if you don't have DirectX9 or 10 installed, try downloading the DirectX End-User Runtime and installing it.

Download details: DirectX End-User Runtime Web Installer
My System SpecsSystem Spec
10 Feb 2011   #3

Windows 7 Professional 64bit
 
 

Hi severedsolo,

Im at university atm so will give it a try as soon as I get home. Thank you for taking the time to answer. I will give a reply post later stating wether the method is successful.

Regards, Geeza.
My System SpecsSystem Spec
.


10 Feb 2011   #4

Windows 7 Professional 64bit
 
 

I have downloaded the link (40 mins it took for 40mb, What's going on here?) and installed the file. I can confirm it has worked.

Thanks a lot severedsolo, yor help is really appreciated!

Regards, geeza.
My System SpecsSystem Spec
11 Feb 2011   #5

Windows 7 Ultimate X64 SP1
 
 

Yeah it can be very slow at times, I'm glad it worked for you I'll go ahead and mark this thread as solved.
My System SpecsSystem Spec
Reply

 Program Load problem




Thread Tools



Similar help and support threads for2: Program Load problem
Thread Forum
can i add a program to load at the startup but with a deleay? General Discussion
.exe program doesnt load on startup General Discussion
Automatic program load in safe mode Software
Need help in increase cpu load of a program and more. Performance & Maintenance
Solved almost no program will run, they just load a little bit General Discussion
msconfig program won't load General Discussion
Trying to load a whole program to RAM Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 08:09 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33