Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: AoE2 and AOE2:Conquerors don't launch

20 Feb 2011   #1

Home Premium32
 
 
AoE2 and AOE2:Conquerors don't launch

I just installed AOE2 and the Conquerors expansion today along with the patches and when I click the desktop icon, the splash screen appears and after about 10-20 seconds, the splash screen disappears and nothing happens. I tried putting it in Windows XP SP3 compatibility but it didn't make a difference. Any fixes?

Also it worked for my old XP computer.

My System SpecsSystem Spec
.

Reply

 AoE2 and AOE2:Conquerors don't launch





Thread Tools



Similar help and support threads for2: AoE2 and AOE2:Conquerors don't launch
Thread Forum
ago of empires 2 the conquerors expansion. Gaming
AOE II Conquerors Multiplayer LAN Problem!!! Gaming
Serious AOE2 server problem! Gaming
AOE2 on Windows 7 Gaming
age of empires II conquerors Gaming
age of empires II conquerors Gaming
Several issues (aoe2, ra3, steam) Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:49 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33