Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 x64 Age of Empires 3

14 Mar 2011   #1
Draconarius

Windows 7 Home Premium 64bit
 
 
Windows 7 x64 Age of Empires 3

Hello,

First of all, sorry if this has been answered before, but I was unable to find a solution that worked through my searching.

I recently bought an ASUS G73JH with Windows 7 64 bit loaded on it. Everything seems to be okay, except for Age of Empires 3 (and both expansions). The game will run okay for a few minutes, but eventually the game image will disappear to be replaced by flickering solid color screens. I can get that to go away by minimizing and maximizing the program, but sooner or later the game crashes altogether, forcing me to restart the system.

I have tried to run the game in compatibility mode for Vista and XP, I've updated all of my drivers and I've tried running the main game on its own (no add-on packs) and each add-on separately. Nothing I've done has made any difference, though.

Any help would be greatly appreciated.

My system specs:

MODEL: ASUS G73JH
OS: Windows 7 x64
PROCESSOR: Intel Core i7 Q720
RAM: 4GB DDR2
GRAPHICS CARD: ATI Mobility Radeon HD5870


My System SpecsSystem Spec
.
14 Mar 2011   #2
Maguscreed

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

I have no personal experience with this, but if you look at the response to this
http://answers.microsoft.com/en-us/w...9-75ae1c736515

They seem to have provided links to every possible solution.
My System SpecsSystem Spec
14 Mar 2011   #3
Draconarius

Windows 7 Home Premium 64bit
 
 

That was quick. Many thanks.
My System SpecsSystem Spec
.

Reply

 Windows 7 x64 Age of Empires 3




Thread Tools






Similar help and support threads
Thread Forum
Age Empires 3 on Windows 7
Hi When I try to run Age of Empires it starts and sort runs, but it closes and I get this message "DisplayInfo.RB_GetScreenIndex - did not find monitor 0, 0, 1920, 1080 Can anyone help. Best regards Rob
Gaming
Age of Empires 3 Windows 7 64 bit
Hello. When connecting to the network, the game AoE3, crashes completely and can not be closed (in task manager too). I downloaded the latest update from web, but didn't help. What can i do ?
Gaming
windows 7 and age of empires III compatibility issue
I have installed Age of Empires III and it runs with my windows 7 ultimate, but in the homescreen and game there are severe graphic distortions and I can't play the game. I have tried changing the compatibility to run the game for windows vista, xp, etc. but nothing works. I have also uninstalled...
Gaming
Which Windows Platform do I need to play Ages of Empires III?
I have a 15" macbook pro, and for obvious reasons I'm installing Windows as well. I was going to buy the Windows 7 Home Premium pack because thats all i need for school, but will that be able to run Ages of Empires well?
Gaming
Age of Empires 3 + windows 7 ??
I got a new laptop last week and I was a pretty big fan of Age of Empires series 1(used to play when I was in school more than 4 - 5yrs back), so I downloaded age of empires 3 hoping to play that on windows 7. After downloading 1.66gb file for over 3 days I was disappointed to find its showing...
Gaming
Age of Empires 3 for 10 cents today only on Windows Live!
Day7 - Games For Windows Get a good game for next to free. Also, 10 cent games every day. Budget gamers now have a place to go :)
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:49.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App