Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: XINPUT1_3.DLL errors (FIX)

20 Mar 2011   #1
Orbital Shark

 
 
XINPUT1_3.DLL errors (FIX)

Hi all,

Just installed Fallout: New Vegas (tried Crysis 2: Beta with same issue) and got a message stating that "XINPUT1_3.DLL is missing" and after some searching found only threads/posts (not here) relating to steam...

My first thought was DIRECTX so I downloaded the DirectX End-User Runtime Web Installer from Microsoft, installed it and tried running the game and it works (almost) perfectly. I say almost as I'm playing on a mobile GFX card

ALL games ship with the latest DirectX version (at time of disk creation) and the installers should be automatic. But, sometimes, those installers will read that you already have the latest DX version and will not install. The issue with this is that because not all games utilize certain files they may be "misplaced" by your system (It's happened to me ).

So, if anyone is having this issue, or similar just download the above installer and all should be working perfectly.


OS


My System SpecsSystem Spec
.

04 Jun 2011   #2
Hypericum

Windows 7 Home Premium 64bit
 
 

Thank you my friend. I have this problem and i succesfully solved it with your help.
My System SpecsSystem Spec
08 Jun 2011   #3
Orbital Shark

 
 

You're very welcome, glad it worked
My System SpecsSystem Spec
.


23 Jun 2011   #4
zvucnjak

Windows 7 64bit
 
 

Hello!

I installed W7 64 bit today, and had the same problem with New Vegas.
When I try the DirectX End-User Runtime Web Installer, I get a "internal error" message and it won't install...
My System SpecsSystem Spec
23 Jun 2011   #5
Orbital Shark

 
 

Hi,

Did you download the file first then run it or did you select run from the offset?

You may find in some cases, you may need to download the file then right-click and run as Administrator may solve the issue
My System SpecsSystem Spec
01 May 2013   #6
HKB

Windows 7 ult. sp1. 64bit
 
 

I just need to thank you also. I just put in a new C: drive, most data (many programs, all the 'My' directories) is on D:..

Did a fresh Win 7 install went to play a game installed originally to D: and got the error. You save me so much work.

Thanks, thanks, and thanks!
My System SpecsSystem Spec
13 Feb 2015   #7
zvecd

32 bit
 
 

You can download DirectX from official website or xinput1_3.dll only from here: Xinput1_3.dll Is Missing? Download For Windows And Fix It! , for example.
My System SpecsSystem Spec
Reply

 XINPUT1_3.DLL errors (FIX)




Thread Tools





Similar help and support threads
Thread Forum
Chain of Driver Errors (GPU, .NET framework) and Other System Errors.
Hey, prepare for a big post. So first of I will begin with the previous issue I had and story that went along with it to give you some background info. I was away for all of December in Japan and when I come back home to my computer (working at the moment) it was having some issues with the RAM...
Drivers
Win 7 Update errors, Readiness Test returning 5000+ errors Help
Need some guidance. I'm trying to help a friend who got hit by something, virus, malware etc. Cleaned that up but.... In looking over his Win 7 64bit Home Premium system, I noticed his Windows Update had not run in over a year. So I tried to run it manually and have been going down a rabbit...
Windows Updates & Activation
MemTest86 Errors Questions - 72 errors recieved when running after 3hr
I was hoping that someone may be able to help me decipher what sort of error messages I encountered as a result of running MemTAest86 for a few hours. I have gotten 72 error messages, and I have no way of knowing how severe these messages are. Any help would be appreciated.
Hardware & Devices
Easy CD Creator 5 errors, removed now CDROM errors
I was trying to troubleshoot two errors in Event Viewer and know they were caused by Easy CD Creator 5 so I uninstalled it and then my DVD players would not work. cdralw2k.sys and cdr4_2k.sys were the cause of the errors and were incompatible with Windows 7. Did a system restore to get the DVDs...
BSOD Help and Support
Boot errors,shutdown errors, wake errors.
Wake from sleep is slow and I loose control over curser for 10 sec. These are most of the errors and their numbers that I have been getting over the past 5 days. Boot duration 100,101,109,103 Stanby duration 300 Driver caused delay 351 Thumbdrive driver delay
Performance & Maintenance
bluescreens/stack dumps/memory errors/bad image errors
Hello, I've had nothing but great luck with Windows 7 and my current computer for almost a year. A couple weeks ago, however, I started getting intermittent, and seemingly random stop screens. There seems to be no pattern to the blue screens; sometimes I'll be gaming or sometimes the...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:45.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App