Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Team Fortress 2 poor performance


01 Apr 2011   #1

 
 
Team Fortress 2 poor performance

Hello
I am desperate now I and I am looking for some help because I will throw the damn game out the window. I bought the game in 2009 when I had a really bad graphics card ( My computer specs in the bottom of the post). It was na old ATI but I ran TF on low and some medium with 25+. I bought a 9800GT and I was able to run it on medium setting+ (no AA or fancy stuff). I don't remember when but I started to get declining performance (with every update..) I reinstalled windows, update drivers and other stuff which came to mind. Then I gave up. I tried again and I gave up again...

Now I downloaded the game again and decided to play. I hadn't been playing so I didn't know what to expect. I joined a normal sever and my fps was 10 MAX when playing and 20 MAX when looking at a wall. I lower the setting to all low and it was the same.
Now I am using the script which lowers the graphics to extremely low (pixels...) and does some other stuff like making the corpses disappear and stuff and I get decent fps ranging from 20 to 100.

I have noticed that it is not because of the graphics (the problem). When I try and play on normal settings (without the script) I get spikes and even the sound lags.

I have no idea what the cause of this can be but here is what I have done so please don't suggest it. Thank you

Reinstalled windows.
Installed tf on fresh windows
Installed latest drivers
Ended all unnecessary processes
Tried defrag
I disabled my AV

My Computer:
Intel Pentium D 2,66 ghz
2gb Dual channel ram
9800GT

I know my processor isn't the best but I have seen people with pentium 4 running it on max (also please see the recommended requirements)

That is what I can tell you. If you have any questions ask. I have written to steam support but I haven't received an answer for now.

Please help and thank you.


My System SpecsSystem Spec
.

02 Apr 2011   #2

 
 

Tf is the or near same engine used for hl2 and other valve games. Your cpu and vid card should be good enough to run it at high settings. Or seems to me.

Using Windows 7 your only 2 gigs of mem might be a prob. But seems most your probs is trying to play mp and low fps- which can be net related.

How fast is your isp? Have you tried to tweak your net speed- what about setting your net speed in the steam client. Google your exact prob- maybe it is some in game program file net tweaks you can do to help. I do know most normal or non steam games can be tweaked from the main program files and say a user file.

Are you using a router etc. does the router or modem have a fire wall. You only need 1 firewall on your system- either on the system its self which I prefer or on the router or modem.

What about security- I turn off all my security when gaming other than my firewall. Do you tweak your system for best gaming performance. What about areo or glass what ever it is called- set display to normal- do not use the fancy areo glass stuff- or on off for gaming- back on when not gaming if you care too.

What about your lan drivers. Windows 7 can act funny or glitchy and may not install drivers right- maybe delete[uninstall] lan drivers reboot reinstall lan drivers reboot etc. Or just let Windows 7 install the lan drivers after you uninstall them. I prefer installing lan sound and vid drivers manually- but will let Windows 7 install the lan- a fresh install Windows 7 will auto install the lan anyway- seems to work fine for me and had a update yesterday I think it was..

Do you have anything on your rig that uses java- it can cause probs with Windows 7. Make sure all programs and security are updated- tho you can have that stuff off or set for manual updates- they will still ping your system trying to update and can cause lag etc until you do update- windows or anti virus what ever.

I need to test my rig with some mp- I have not to date tried to play mp using Windows 7. I would like to know my rig works ok in mp- but using Windows 7 I am not sure. I will get to it someday- its just I do not much play mp anymore- it did work fine in borderlands co op tho- so maybe it is ok..

Have you tried posting at steam tf forums- it is their game and folks playing it might help ya the best or faster- You already have a steam account so why not?

If I can think of more I will post.
My System SpecsSystem Spec
02 Apr 2011   #3

Windows 8.1 Pro
 
 

Hi headbuster

Have a look through this - Tips on Troubleshooting Game Issues. Especially tips 5, and 11
My System SpecsSystem Spec
.


03 Apr 2011   #4

 
 

First of all thanks for the answers to both.

I have posted in the steam forums but people there aren't supportive.
I have sent a ticket to steam support but I haven't received an answer yet.

I have tried many things. My system is a bit old and for example there are no current sound drivers or lan drivers or motherboard drivers. I either let windows install some or I install the latest I can find (2007) and I really don't want to install win XP again...

I don't know how I can locate the problem either. I use net_graph 3 and it show stuttering...that's all I know.
My System SpecsSystem Spec
03 Apr 2011   #5

Windows 8.1 Pro
 
 

It really would benifit you to get your sound and video drivers direct from the manufacturer as opposed from Microsoft's Windows update as Windows updates just does the driver portion and not the other features the the manufacturer provides. Bottom line is it is alway better to get drivers form the manufacturer. I'm pretty sure you can get drivers for a 9800GT from Nvidia's website - NVIDIA GeForce 9800 GT: supercharge your graphics horsepower with this GPU at the perfect price and performance combination.

As far as sound card drivers if your board has on-board sound card go to the motherboard's website and find them there. If you have a seperate card, visit the card's website and get them there.

Also make sure you've updated your DirectX files, just because Windows 7 has DX11, doesn't mean the DX files are updated, especially DX9.

See tip# 5 & 6 here Tips on Troubleshooting Game Issues

Good luck
My System SpecsSystem Spec
Reply

 Team Fortress 2 poor performance




Thread Tools



Similar help and support threads for2: Team Fortress 2 poor performance
Thread Forum
Team Fortress 2 fan? Gaming
Team Fortress 2 Crashes Gaming
Problems with team fortress 2 Gaming
Team Fortress 2 Gaming
Team Fortress 2 Gaming
Team Fortress 2 Issues Gaming
Team Fortress 2 issues Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:08 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33