Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Age Of Empires 3 Lags On My Window 7


17 Apr 2011   #1

window 7 Home Premium 64 bit
 
 
Age Of Empires 3 Lags On My Window 7

Hi guys I really need help with my window 7 and age of empires 3. I install the game many times and it still has this problem. [The problem is basically the game lags really really hard every 5 mins and then the other 5 mins it goes back to normal with a consistent pattern of lagging stopping lagging stopping]. It is not my connection because I've tried it on my window vista and it does not have this problem. Also when I open the game there is a message saying that "window 7 color scheme has been changed to basic" which I know why, but would this be the cause of the lag in the game? I really dont know how to fix this problem. I've research on google for like the past month to try to find a solution, but I couldn't get it to work properly on my window 7. Please Help Guys!

My computer is Window 7 Home Premium 64 Bit / AMD Athlon x4 620 Processor 2.60 GHz / 6.00 GB Ram / NVIDIA GeForce 9100 Graphics /

I mean my computer have more than enough to run this game, but why does it lag like this?

Please Help!


My System SpecsSystem Spec
.

17 Apr 2011   #2

Windows 7 Ultimate 64-bit
 
 

Did you update your graphics/chipset drivers to the latest version? If not, download the latest drivers from your manufacturer's official site.

The color scheme thing is just partly disabling Windows Aero, which is done to improve your gaming performance.

Also note that your graphics card is fairly weak. Age of Empires III does not require anything too fancy to run, but at times it can really use up your card. (lots of particles, objects, animations).
My System SpecsSystem Spec
Reply

 Age Of Empires 3 Lags On My Window 7




Thread Tools



Similar help and support threads for2: Age Of Empires 3 Lags On My Window 7
Thread Forum
Age of Empires 2: AoC expansion Gaming
♠ AGE OF EMPIRES 2 ♠ (Window Mode and colour fix) Gaming
Age of empires Gaming
Age of Empires II Gaming
Age of Empires III! [ALL] Gaming
age of empires II conquerors Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:27 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33