Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Borderlands and AA

17 May 2011   #1

Windows 7 Home Premium 64bit
 
 
Borderlands and AA

At 1080P, all settings Max, x16 AF, my game runs just beautifully.
(Except for DoF is disbaled. I just do not like the effect)

But, one thing thats always bothered me about the game are the occasional jaggies I can see.

I realize the game technically doesnt support AA, But Ive tried forcing it in the CP.

Even at x2 or x4. Performance really takes a huge hit.

Ive noticed with everything at max (No AA) my GPU is only using about 40-45% use to run the game.
With even just x2 AA it jumps to 99% use, and runs really bad.
Whats going on with that?


So Im curious if Im missing something here, or if others have had better luck or the same?


Im a bit confused because on other games that technically do not support AA, Ive been able to force it without issue.
For example:
Oblivion w/HDR enabled forced AA no issue running at (x8Q) and x16 AF.Even with lots of HD texture mods..
Bioshock forced AA, does just fine at x4 with x4MultiSample.

But this particular game really just doesnt seem to like even x2 at all .. unless of course Im missing something.

My System SpecsSystem Spec
.

17 May 2011   #2

ultimate 64 sp1
 
 

i've not played it for a long long time, and i still remember the dreaded jaggies.

the visual style of the game accentuates the problem, i seem to remember every edge of rock, hut etc having a thick black border, which always showed aliasing.

that was when i had my 4890, and as you say if you force enabled aa, performance took a severe nose-dive.

it seems that other early unreal 3 engine games, like the original bioshock and mass effect also had this aa problem - which seemed amazing for a 21st century game to have jaggies.

since then, they seem to have worked out how to add aa without too much frame-rate damage in more modern u3 games like me2 and homefront.

i suppose you'll just have to put up with the aliasing on these games until the next generation of gfx cards which have a bit more horsepower to deal with it.

i haven't tried borderlands with my 6950. maybe i should give it another playthrough - i remember enjoying it quite a lot - loads of guns and stats!

who was that old blind guy lived in the nearby shack in the first level? i was shocked and sad to see him go...
My System SpecsSystem Spec
17 May 2011   #3

Windows 8.1 Pro
 
 

AA is kind of messy with the game, especially for those with ATI cards (yeah I know you switched to Nvidia). Anyway have a look through here - Borderlands: How to enable VSync, AA, etc... | Video Game Online Forums & Community | Game Platform Discussions for Video Games - GameTrailers.com

Also the was a fix where you could rename the exe to UT3.exe and supposedly AA would work (for ATI cards). Don't know what they had for Nvidia though. Again, read through the link I provide.

Quote   Quote: Originally Posted by mickey megabyte View Post
i haven't tried borderlands with my 6950. maybe i should give it another playthrough - i remember enjoying it quite a lot - loads of guns and stats!
The 6950 is no better as this is more a game issue. You could try renaming the exe like I suggested above.

FYI - List of games that need renaming of exe to get AA working - Rage3D Discussion Area
My System SpecsSystem Spec
.


17 May 2011   #4

Windows 7 Home Premium 64bit
 
 

Thanks.

You would think the art style would help hide jaggies, but seems to actually make them stand out more.




I did try renaming the exe to Bioshock.
Sadly, the result was the same as forcing it as Borderlands.


I can tell, with both methods, that is indeed working.
GPU works much harder, and game stutters in many areas.
Which is sad, because it looks so much better.


Its certainly a game issue it seems. I honestly do not believe it to be a ATI or Nvidia issue.
The card doesnt seem to have any issues doing AA with most every other game.

I remember these issues with my 4890, and just thought a more powerful GPU would be able to handle it. Apparently not.


At least Vsync works perfectly fine.
I think despise Image Tearing worse than I do a few jaggies

But, Id rather the game run smooth, no tearing, and a few jaggies rather than stuttering.



I did try it in Mass Effect 1 & 2 BTW.
Seems to work pretty well, and looks really good.
I read there may be graphical glitches in spots because of it however, but I havent seen them just yet. Then again, I havent played much yet either.
My System SpecsSystem Spec
18 May 2011   #5

Windows 7 Home Premium 64bit
 
 

Ok, so I was messing around with this a bit more.

If I disable Dynamic Shadows, I can run at x4AA x2Supersample or x8 Multisample AA and the game runs fine.
Looks nice too.

Turn dynamic shadows back on, and any AA what-so-ever, even x2, and the game starts to stutter.

What really weird, is I was watching the FPS in Evga's Precision, and its showing 45-60 FPS, when the game starts stuttering (with Shadows + AA)
It should be smooth at that frame rate ...
My System SpecsSystem Spec
18 May 2011   #6

ultimate 64 sp1
 
 

i'm going to reinstall it from my steam backup, and experiment with my 6950, just for the fun of it.

will report back in a few hours.
My System SpecsSystem Spec
18 May 2011   #7

ultimate 64 sp1
 
 

well this is opening up a can of worms

the game installed ok from steam backup, had to download some extra updates as it's been a while - BUT it wouldn't remember my settings - just like homefront. i think it's because i've got my steam games installing on E:, and my documents on F: - i wasn't getting a 'Borderlands' folder created in 'My Games'.

anyway did some googling and finally sorted it out by manually copying and pasting files from within my steam folder and making a My Games/Borderland/WillowGame/Config folder.

now my video settings and custom keybindings are being remembered.

BUT i've still got to solve my save game problem though.

i've made a SaveData folder in My Games/Borderlands/ and files are being saved in there when i visit the new-u stations - but when i try to load them, i'm taken right back to getting off the bus! even though the saved games say level 2 and remember names that i've given them when saving from outside dr zed's place AND i've got all the weapons that i picked up - see screenshot below - just got off the bus but i still have pistol found in the first box that claptrap shows me after taking out first wave of bandits.

so it looks like i'm going to have to muck about for a bit longer trying to solve this issue - oh well, ain't no rest for the wicked...

what files and folders should i have in My Games? does this look right?

Name:  bord.PNG
Views: 1129
Size:  8.4 KB

=======================================

the good news is that the game runs fine on max settings and 8xaa - i downloaded the borderlands advanced config tool, and have these settings enabled:

Borderlands and AA-bac.jpg

game looks lovely, and framerates are good, even with dynamic shadows and ambient occlusion - although i've got to do a bit of experimenting to find optimum settings.

here's an example screenshot - jaggies not entirely eliminated - particularly visible in highlighted region, but much better than normal - as you can see edges of pistol and claptrap are nice and smooth (there's also a bit of jpg compression artefacts going on due to screenshot, but ignore that)

Borderlands and AA-jag.jpg

(top right is my ati tray tools overlay, showing fps, cpu activity and time. it can show lots more info, but that's my default setting.)


My System SpecsSystem Spec
18 May 2011   #8

Windows 8.1 Pro
 
 

Well I've got the retail version so I know nothing of the way to configure for Steam so thanks for the info.

Anyway I never even bothered trying to fix AA with the game, just got used to it and played the game. Quite bored with it now seeing how I played it to death (single player).

Anyway thanks for the info, including this - borderlands advanced config tool - never knew such a thing existed. Nice find.

Hopefully this'll help Wishmaster.

Thanks.
My System SpecsSystem Spec
18 May 2011   #9

ultimate 64 sp1
 
 

i've managed to sort my saved games, not quite sure how, but it seems to work now.

also had to bump my aa down to 4x - was getting a bit of a framerate dip with too many bad guys on the screen.

apparently there's a much newer version of the advanced settings tool - but the link is dead...

found another tool here, but it doesn't seem as fully featured as the other...more googling needs to be donw
My System SpecsSystem Spec
18 May 2011   #10

Windows 8.1 Pro
 
 

Don't know where Steam puts your saved files but the retail disk puts them here -

C:\Users\UserProfile\Documents\My Games\Borderlands\SaveData

I would imagine the steam version of the game does the same. It does it with Fallout NV, (which of course is a steam based game).....

C:\Users\UserProfile\Documents\My Games\FalloutNV\Saves
My System SpecsSystem Spec
Reply

 Borderlands and AA





Thread Tools



Similar help and support threads for2: Borderlands and AA
Thread Forum
Solved borderlands 2 ?? Gaming
Borderlands 2 (W7 Ultimate x64) Gaming
Error With Borderlands. Gaming
Borderlands 2 Released Gaming
Borderlands menu bug Gaming
BORDERLANDS pc freezing. Gaming
borderlands install with Win 7 64 Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:50 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33