Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Star Wars Empire At War Crash

09 Jun 2011   #1
Bobthemaster

Windows 7 Ultimate 64-bit
 
 
Star Wars Empire At War Crash

So, I have a problem that I have now been scouring the internet for, trying to solve. Both my copies of Star Wars Empire at War, and the expansion Forces of Corruption continuously crash at the loading screen for the main menu. Now, before I am told to download the patch, I have tried running the Vista patch, as well as running the game in compatibility mode in XP AND Vista, and as administrator. I've also been told that it may be my graphics card, but I'm not sure. My specs are as follows:

Intel i7 920 2.66 GhZ running 3.00 GhZ
nVidia GTX 480
6 GB Corsair RAM
2 TB HDD
EVGA 121-BL-E756-TR LGA 1366 Intel X58 Micro ATX SLI

Think I could get any help with this matter?


My System SpecsSystem Spec
.

10 Jun 2011   #2
Bobthemaster

Windows 7 Ultimate 64-bit
 
 

Well, after going through some extensive work, I have managed to get the game running. However, the game is now having rendering issues, specifically it doesn't want to load particle effects and ambient lighting. Are there any suggestions as to how I could fix this issue now?

(Also, I now know that the crash in the title of the thread is irrelevant, so if a mod wishes to change this, please go right ahead.)
My System SpecsSystem Spec
11 Jun 2011   #3
Clinkz

Windows 7 Professional x64 Backtrack 4 R2
 
 

Bobthemaster,

If it is ok would you mind posting how you got the game past the initial crash. Just in case other people have the same problem, they can refer to your solution.

As for yourr graphics issues, have you tried updating both your GPU drivers and Direct X 9?
My System SpecsSystem Spec
.


11 Jun 2011   #4
Bobthemaster

Windows 7 Ultimate 64-bit
 
 

Well, my solution was a little bit convoluted, and kinda shoehorned. What I did was I did a complete uninstall of both my games, and a very thorough cleaning out of my registry errors. Afterwards, I did a complete reboot of my machine, and then I proceeded to install the games again, this time on my external HDD. Afterwards, I ran the various patches for the game, including the FoC Vista 64-bit RAM fix. Afterwards, my current set up has both the launchers for the games, and their executables have been set to run as admin and are running in compatibility mode for Vista SP 2.

In regards to the graphics, yes, I did the most recent update available through Windows, though I have yet to check on the nVidia website for newer drivers. And for DirectX 9, I installed the DirectX 9 that came bundled with the games. I've even tried having my shortcuts for the games trying to run the .exe with the dx9 command. It hasn't fixed it yet. Is it possible my graphics card is too new, and too powerful(since it runs standard with DirectX 11) to run this game?
My System SpecsSystem Spec
Reply

 Star Wars Empire At War Crash




Thread Tools





Similar help and support threads
Thread Forum
Star Wars Empire at War Forces of Corruption
I cannot for the life of me get this to work, regular Star Wars - EAW works fine but when I try to play the FOC expansion it won't work and I get this exeption that I uploaded to be read. Windows 7 Home Premium 64-Bit 12GB of RAM GeForce GTX 295 Why won't it work?!
Gaming
Star Wars Empire At War suddenly crashing at startup (Details inside)
Long story short, my empire at war game just suddenly stopped working. I click "start game", the .exe file starts up, and then just crashes. No error or anything. I will say this though - it doesn't seem to even try to read the disc anymore like it used to. What I mean by that is when I'd hit...
Gaming
BSOD / System crash / reboot playing Star wars the old republic
Hello, I have recently built a computer ( 2 days ago ) and have been having trouble when attempting to play the new game Star wars the old republic. After about 5 minutes my system crashes and restarts instantly to the same prompt when you force a shut down or lose power. All indications...
BSOD Help and Support
Star Wars Shadows of the Empire
I know this is a stretch but I may as well ask. Does anyone know how to get Star Wars: Shadows of the Empire working properly on Windows 7 64-bit or 32-bit with a modern video card? Whenever I try to launch it no matter what settings, I try the Hoth Level and I can only see the ground, nothing else.
Gaming
Star wars empire at war;forces of corruption issue
Me and my friend have modded our games. and i have vista and the mod works fine. but he has Windows 7 and when he starts the mod it says it cant find the file path C:\Program Files\LucasArts\Star Wars Empire at War Forces of Corruption\swfoc.exe it says please check the file pth and try...
Gaming
Star Wars Empire at War Crashes
I have Star Wars Empire at War on Star Wars Best of PC. Once I start it up, then go to multiplayer and sign in--it freezes. Then I have to start the Task Manager and end process. The actual single player works fine, but I can't get multiplayer to work? Is there a patch of somekind? Please help,...
Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:18.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App