Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Mouse delay problem

22 Jul 2011   #1
clodis

Windows 7 x64 Enterprise
 
 
Mouse delay problem

Hello Guys,

These are my specs:

Phenom x4 9650 2.31 GHz
6 GB RAM memoy
Asus M2N-E motherboard
HD Samsung SpinPoint F3 1TB
Video Gigabyte GTX 460
Power Everest 85Plus 600W
Mouse Steelseries Xai
Monitor Samsung 2233rz 120HZ
Keyboard Razer Arctosa
Windows 7 x64


The main issue is related to mouse which is not working properly, it has a delay in response. In the past 2 years because of this issue, as the FPS games are unplayble, I did change a couple of mouses: 2xG5, MX518, Razer Copperhead, Intelli 3.0, Mionix Naos 5000 and now SS Xai, hopping the problem will dissapear and it didn't. So I assume that it has something to do with the USB.

I noticed in the past days that when the mouse is pluged in a new USB where the mouse wasn't before the driver is installing and after that the mouse works excellent for a couple of minutes, than slowly the lag is starting. I tried this 3 times (as I have 4 USB) and each time was the same.

The only thing that I could think of looking on the internet si the USB Bandwidth however I didn't find a way to change this, not sure if it's possible.

So please if you bumped into this issue before or if you have any idea let me know and I will check as I don't know what to do else.

Also I want to mention that the mouse is used at a polling rate of 1000 HZ, both keyboard and mouse are pluged in USB, motherboard drivers are the latest from Nvidia site.

Apologize for any english mistakes.

Kind regards


My System SpecsSystem Spec
.

22 Jul 2011   #2
SlasherIT

Ubuntu 12.10
 
 

Download and install this: http://cdn.steelseries.com/mice/Xai_v1.4.2.exe These are the drivers for your current mouse, install them and then report back your success here...
My System SpecsSystem Spec
22 Jul 2011   #3
clodis

Windows 7 x64 Enterprise
 
 

I wish it would be that easy. I already have the drivers for Xai installed.

Thank you for posting
My System SpecsSystem Spec
.


22 Jul 2011   #4
SlasherIT

Ubuntu 12.10
 
 

Lets try Re-installing it.

1. Uninstall the Xai driver with Revo. Download and install Revo Uninstaller Download Revo Uninstaller Freeware - Free and Full Download - Uninstall software, remove programs, solve uninstall problems (Check out this tutorial Revo Uninstaller Freeware - Uninstall Programs on how to uninstall with it).

2. Re-install the Xai driver.

Report back your success here...
My System SpecsSystem Spec
22 Jul 2011   #5
clodis

Windows 7 x64 Enterprise
 
 

OK i am here to report back my success!!!! The problem was solved by downgrading the bios. For my motherboard I had Bios V5001 which is beta. I thought it might have an effect and I installed version 1703 which is stable and now the problem is solved.

Thank you SlasherIT for your support.
My System SpecsSystem Spec
22 Jul 2011   #6
SlasherIT

Ubuntu 12.10
 
 

Good job clodis, very good thinking, didn't know you were on a beta BIOS. My advice to you, is to NEVER use a beta BIOS, as the BIOS is the most crucial part of the computer, without it, its useless. Let the beta testing to others...
My System SpecsSystem Spec
Reply

 Mouse delay problem




Thread Tools





Similar help and support threads
Thread Forum
Skyrim Mouse Lag, .5 Second Delay
Edit:NVM Fixed, just disabled V-Sync in my NVidia Control Panel, Thanks Anyway Edit2: Now when i move my mouse UP It moves fast, but side to side is slower, how would i fix this?
Gaming
Mouse delay in CS1.6
My mouse I'm currently using is a Steelseries Kinzu that I had recently bought 3 days ago. I'm currently having a problem with a bit of mouse lag. This only happens in CS 1.6, and not any other games. When I move my mouse, the movement on my monitor isn't right. It's delayed like the LCD screens...
Gaming
Right mouse click delay on shortcuts
Hi everyone! From few days I have problem with right click of the mouse when I use it on shortcuts. The problem is that there is a delay which is between 1 to 3 seconds. It happends only shortcuts. When I use right click on other files (.exe, .jpg, etc.), on desktop or folders, the context menu...
General Discussion
Mouse click = delay in game
Hey, I have a win7 64x with a deathadder 3g. Whenever I play bfbc2 there, sometimes, seems to be a delay between me clicking the right mousebutton and the game reacting. I read that there is a delay between the click sound in windows and clicking the mouse, this is not the case here. I...
Gaming
Delay in Mouse Activation
Did a reinstall of Win7. Only one glitch: my cordless Logitech USB mouse doesn't activate for about 1.5 minutes after the logon screen. A wired mouse works fine. I've tried removing drivers, reinstalling drivers, letting Windows do its own thing for drivers--same result. After about a minute and...
Hardware & Devices
Mouse delay and OpenGL games delay. Help!
Hi there. Im running Windows 7 Professional x86 final on this machine: athlon x2 5.000+ 2x2gb ddr800 dual-channel memory ati radeon hd 4650 512mb 128bits 500g sata hd The os is updated and all the settings of the os are on default. The settings of videocard are in performance/balanced.
Gaming

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:24.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App